Let’s suppose that MovieDbHelper is an interface and MovieDbHelperImpl
The lost droid and the magic Dagger: an intro to dependency injection for Android.

Of course it’s very personal, but in my opinion it’s much better to generalize an Interface “DbHelper” and implementation would be “MovieDbHelper”. This provides greater flexibility. It would also fix the problem with ugly naming of classes like “ISomeInterface” and “SomeInterfaceImpl”.