Včera jsme nasazovali novější verzi verzi Ubuntu (AWS ami-a9d276c9) která ale bohužel nemá Python 2 který je pro Ansible potřeba. Řešením je zakázat získávání faktů a v případě že chybí ho nainstalovat.

gather_facts: no
tasks:
# ensure python 2 is installed - required for Ansible
- name: install python 2
raw: test -e /usr/bin/python || (apt -y update && apt install -y python-minimal)
become: True

Written by

#Python #AWS #Angular #Autoprop

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store