I think this example would be better if it didn’t conflate FP and OOP.
Andrew Eddie
1

Both createUser() and User.create() are factory functions, which are FP concepts. Neither of them is strictly functional, though either might be used in a functional context, assuming they’re pure functions.

The naming convention, not the FP vs OOP context is the part that’s relevant to the discussion at hand.

One clap, two clap, three clap, forty?

By clapping more or less, you can signal to us which stories really stand out.