When I read that example I’m immediately confused because I read `itemUpdated` as the item to be updated, when, in fact, it should simply be a boolean value representing whether or not the component should update.
It turns out that naming things is hard, and if you can avoid doing it and still communicate the meaning clearly, you should.
There are only two hard problems in computer science:
- Naming things
- Cache invalidation
- Off by one errors