Expo SDK v32.0.0 is now available
Eric Samelson
3.5K28

I’m getting “There was a problem sending log messages to your log development environment” error. Stacktrace leads to node_modules/expo/tools/hashAssetFiles.

I did all the necessary upgrade steps. I believe it’s related to the fact I’m using static HTML, CSS and javascript files built with webpack inside the project.

I had the same error when upgrading to expo 31 but it only occurred because I forgot to build my assets after expo upgrade.

This time the bug does not want to go away no matter what I do. Do you guys know what might be the issue?

module.exports = function(api) {
api.cache(true);
return {
presets: ["babel-preset-expo"],
plugins: [
[
"module-resolver",
{
alias: {
assets: "./assets",
components: "./components",
constants: "./constants",
learnMocks: "./learnMocks",
screens: "./screens",
utils: "./utils"
}
}
]
]
};
};

My package.json

"dependencies": {
"@expo/samples": "2.1.1",
"@expo/vector-icons": "^8.0.0",
"@okgrow/react-native-copilot": "^2.4.1",
"apollo-boost": "^0.1.23",
"apollo-cache-inmemory": "^1.3.12",
"cors": "^2.8.5",
"expo": "31.0.4",
"graphql": "^14.0.2",
"graphql-tag": "^2.10.0",
"moment": "^2.22.2",
"react": "16.5.0",
"react-apollo": "^2.3.3",
"react-native": "https://github.com/expo/react-native/archive/sdk-31.0.1.tar.gz",
"react-native-device-info": "0.22.2 ",
"react-native-markdown-renderer": "^3.2.8",
"react-native-webview": "^2.14.0",
"react-native-youtube": "^1.1.0",
"react-navigation": "^2.18.2",
"reselect": "^4.0.0",
"sentry-expo": "~1.9.0",
"whatwg-fetch": "^2.0.4"
},
"devDependencies": {
"@babel/core": "^7.0.0",
"@babel/plugin-syntax-dynamic-import": "^7.0.0",
"@babel/preset-env": "^7.1.0",
"babel-eslint": "9.0.0",
"babel-loader": "^8.0.4",
"babel-preset-expo": "5",
"eslint": "^5.6.1",
"eslint-config-airbnb": "^17.1.0",
"eslint-config-prettier": "^3.1.0",
"eslint-import-resolver-alias": "^1.1.2",
"eslint-plugin-import": "^2.14.0",
"eslint-plugin-jsx-a11y": "^6.1.2",
"eslint-plugin-prettier": "^3.0.0",
"eslint-plugin-react": "^7.11.1",
"graphql-tools": "^4.0.3",
"prettier": "^1.14.3",
"react-test-renderer": "^16.5.2"
},
"peerDependencies": {
"eslint": "^5.6.1",
"eslint-config-airbnb": "^17.1.0",
"eslint-plugin-import": "^2.14.0",
"eslint-plugin-jsx-a11y": "^6.1.2",
"eslint-plugin-prettier": "^3.0.0",
"eslint-plugin-react": "^7.11.1"
}

I did all the mentioned upgrade steps, including applying changes to react navigstion and I’m stuck for good.
Do you guys know what might be the issue? Apart from that, thanks for awesome work!