Both createUser() and User.create()
Eric Elliott
1

Yeah ok. I agree that createUser is active voice, and I agree that User.create is technically passive voice (but that’s the nature of dot notation), but I don’t agree that in this case, either is better or worse to use in practice. Obviously inverting the latter to make it active voice, Create.User, is silly. However, Factory.createUser is a good use of active voice.

Where I do come across this issue, however, is in naming files. For example if I’m building an Express app, while passive voice file names sort by subject nicely (userPost.js or userCreate.js), I think naming files, or classes for that matter, with active voice is better.