如何安裝 Xcode ?

學習21世紀最棒的程式語言Swift,開發酷炫的iOS App,需要搭配Xcode (下載連結)。

不過彼得潘最近教課時發現有些學生遇上了麻煩,無法安裝Xcode,難道是他們和 Xcode 今生無緣嗎?

不是的。問題出在學生們的作業系統,macOS 版本太舊,只有10.6.8。安裝Xcode 需要 macOS 10.11.5 以上。

注意: 一定要 10.11.5 以上 !

如果不清楚自己 macOS 版本,可點選螢幕左上角的蘋果圖案後,點選 Abount This Mac,查詢 macOS 的版本。

奇怪的是有些人無法升級到10.11.5,系統說他們的軟體版本已經新到不能再新了 (Your software is up to date)。

這是因為 macOS 升級時,預設只會更新小數點第三位。也就是你可以從10.6.1升級到10.6.8,但是不能從10.6.8升級到10.7或10.11。如果真心想升級小數點第二位,那是比較大的改版,需要打開 App Sotre,才能下載安裝最新的 macOS。

打開 App Store,搜尋 mac 後排名第一的即是最新版的 macOS Sierra。點選它即可進入其頁面點選下載按鈕安裝。

如果版本已經是10.11,只是不到10.11.5的朋友,那就簡單多了。只要從 App Store 的更新項目頁面即可升級。