Wouldn’t the idiomatic way be controller.User
Garret Meier

The name controller.User implies that the type is a “user of the controller” whereas the type is actually a “user controller”. The Go documentation does suggest avoiding a stutter but I think calling a UserController a User is confusing regardless of the package it is in.

One clap, two clap, three clap, forty?

By clapping more or less, you can signal to us which stories really stand out.