[…newBooks] instead of
List#toArray() so that it’s more readable or semantic.
Something.toArray is okay, but it just doesn’t read as more maintainable than knowing instead that common adoption patterns apply to it.
Awesome article, it’s amazing how we both blogged about such similar things at the same time! Let me know what you think of my article: