Chris Hamons
Oct 30, 2017 · 1 min read

So there is work scheduled to add IDE support for choosing the target framework version for XM Full projects.

I’ve thought about just bumping it up to 4.6.1 or higher, it’d likely just be a one line change here:

however I am concerned about backwards compatibility. What if an application depends on a nuget with a 4.5 and 4.6 variant, and my change caused a new one to be chosen and that broke things on upgrade (in a hard to debug way).

Xamarin.Mac has reasonably high backwards compatibility requirements.

    Chris Hamons

    Written by

    C# Monkey, Xamarin.Mac Lead