One weird trick to name your tests
Anup Cowkur
703

I got a very personal approach for this

it’s basically :

test{methodName}_{whenThen}_{Ok/Error}

eg.

testLogin_ShouldFailIfIncorrectPassword_Ok

I know the suffix thing can be quite misleading, but I find it quite practical to identify unit test types, especially when you’re working with RxJava and error propagation