Hunting for great names in programming
DHH
78417

I have seen so many misnamed (and therefore misleading) functions- this is a valuable approach to discovering better names. But I have one comment, triggered by the fact that, at the end, DHH wasn’t really happy with the name. Maybe 1 more step? I suggest SecurityUrlProtector#enforce_secure_ip(url), since the private/public distinction is the foremost issue (now), but it seems we might have other considerations in the future.

Like what you read? Give Ebmud Developer a round of applause.

From a quick cheer to a standing ovation, clap to show how much you enjoyed this story.