Dart tooling options

At Dart Summit, the Dart team announced they will be deprecating eclipse support in favor of WebStorm.

This led to the following common misconception

“Wait a minute, WebStorm costs $. I have to pay to develop Dart?”.

Yes, WebStorm does cost money, but this is NOT your only option and NO you do not have to pay to develop Dart applications.

WebStorm is actually a version of IntelliJ IDEA. The only difference is that Webstorm has a few different features built in optimized for web development. But these features have nothing to do with Dart and you could really care less about them.

According to their documentation

“IntelliJ IDEA remains JetBrains’ flagship product and IntelliJ IDEA provides full JavaScript support along with *all* other features of WebStorm via bundled or downloadable plugins. The only thing missing is the simplified project setup.”

The cool thing here is IntelliJ IDEA has a community edition which has all the features WebStorm has and all the features you need to build Dart apps, just install the Dart plugin. See: https://www.jetbrains.com/idea/download/

The pro version of IntelliJ IDEA has features like UML diagrams, but really, are you doing UML diagrams these days? ☺. See: https://www.jetbrains.com/idea/features/editions_comparison_matrix.html

The other option is Sublime & Atom. Both are solid editors and both have really great support for Dart. See: https://github.com/guillermooo/dart-sublime-bundle

Developing Dart applications does not cost money and it’s more accessible now than before!

Show your support

Clapping shows how much you appreciated Faisal Abid’s story.