I think it's a mistake not to provide support for LTS versions of the framework!
Paris Paraskeva
1

Laravel 5.5 is an LTS release.

Like I’ve said some times in the past, we create our packages to use in our own projects which are mostly built on the latest version of the framework. Popularity is not our main goal.