How to cross compile QT for Raspberry Pi 3 on Linux (Ubuntu) for Beginners!
Amir Mansouri
12934

I got the following error after configure command:

The OpenGL ES 2.0 functionality test failed!

Help me! Thanx

Edit: I found the solution.

  1. Fixed QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in the file <Qt>/Src/qtbase/mkspecs/devices/linux-rasp-pi-g++/qmake.conf

2. Created symbolic links to the folder /mnt/rasp-pi-rootfs/opt/vc/lib

libEGL.so -> libbrcmEGL.so
libGLESv2.so -> libbrcmGLESv2.so

One clap, two clap, three clap, forty?

By clapping more or less, you can signal to us which stories really stand out.