Meteor-React-Ionic Mobile App Part 1: The Basic Template
Sam Corcos
11414

  1. I get the error below

1–1.

=> Started proxy.
=> Started MongoDB.
=> Errors prevented startup:

While building the application:
 C:/myReact/ReactMobile/client/styles/styles.scss:1:9: Scss compiler
 error: file to import not found or unreadable:
 .meteor/local/build/programs/server/assets/packages/meteoric_ionic-sass/ionic

Current dir: C:/myReact/ReactMobile/client/styles/

1–2.

=> Started proxy.
=> Errors prevented startup:

While reading package from
 `/C/myReact/ReactMobile/packages/npm-container`:
 package.js:14:7: must declare valid version of dependency:
 name@ReactMobile

=> Your application has errors. Waiting for file change.
=> Started MongoDB.

2. My code below is wrong ? Can I fill the same way ?

What is the difference between package.js and packages.js?

2–1. package.js

{
 “name”: “ReactMobile”,
 “private”: true,
 “scripts”: {
 “start”: “meteor run”
 },
 “dependencies”: {
 “meteor-node-stubs”: “~0.2.0”,
 “react”: “0.13.3”,
 “react-router”: “0.13.3”,
 “externalify”: “0.1.0”
 }
}

2–2. packages.js

{
 “name”: “ReactMobile”,
 “private”: true,
 “scripts”: {
 “start”: “meteor run”
 },
 “dependencies”: {
 “meteor-node-stubs”: “~0.2.0”,
 “react”: “0.13.3”,
 “react-router”: “0.13.3”,
 “externalify”: “0.1.0”
 }
}

One clap, two clap, three clap, forty?

By clapping more or less, you can signal to us which stories really stand out.