Errores de Instalación

Días atrás, mientras trataba de leer algunos cómics on-line; me encontré con una catarata de publicidades previas a cada pagina que quería leer, esta situación me puso un poco frenético.

Entiendo que esta publicidades a veces solventan el sitio con los cómics publicados on-line, pero me resulto muy chocante el tiempo que perdía entre cada pagina.

Entonces recordé que había escrito un post en mi blog sobre un framework para extracción de datos llamado Scrapy, por aquellos días me interesaba obtener los slides de unas presentaciones del sitio Slideshare; sin tener que pasar por todas ellas.

Releyendo ese antiguo post para configurar el framework Scrapy en mi computadora, con Ubuntu 14.10, descubrí que la instalación de scrapy fallaba; así que comence a buscarle una solución y publicarlo para que otros con el mismo problema lo resuelvan mas rapidamente.

Estos son los pre-requisitos necesarios para instalar Scrapy y luego realice estos pasos: (para Ubuntu)

$ sudo apt-get install python-pip python-dev build-essential
$ sudo pip install — upgrade pip
$ sudo pip install — upgrade virtualenv
$ sudo pip install scrapy

La instalación de Scrapy me resulto con errores, primero sobre la falta de archivo ffi.h y luego sobre otro archivo llamado aes.h, buscando en google encontré este post. Que podria resumir con:

$ sudo apt-get install libffi-dev libssl-dev libxml2-dev libxslt1-dev

Con esto ejecutado y resultando sin errores, pude instalar Scrapy sin problemas.

$ sudo pip install scrapy

Al final, me di cuenta de MI ERROR, al no instalar los pre-requisitos de Scrapy correctamente; era por este motivo que fallaba la instalación.

Moraleja

Lean las guías de instalaciones dos (2) veces [o más] para evitar sorpresas durante la instalación de una aplicación. O dicho de otra forma….

RTFM

Roy Trenneman

(Foto principal tomada del sitio Unsplash)

Show your support

Clapping shows how much you appreciated Gumersindo Jose Rey’s story.