It was obvious that we only needed debounce from lodash, so I uninstalled lodash and installed lodash.debouce
Analysing and minimising the size of client side bundle with webpack and source-map-explorer
Nimesh
3665

Webpack 1 doesn’t support native ES import very well, that’s why you have imported whole library.

Webpack 2 should fix it we tree shaking mechanism.

In meantime you don’t need to find another libary.

Instead of import { debounce } from 'lodash'you can write import debounce from 'lodash/debounce'

Like what you read? Give Miron Machnicki a round of applause.

From a quick cheer to a standing ovation, clap to show how much you enjoyed this story.