10 Practical tips to write cleaner more maintainable code

Miguel Álvarez Lesmes
4 min readAug 4, 2023

--

Have you ever stopped to consider just how significant proper boolean variable naming can be for your code maintainability? If not, let’s ponder this together for a moment.

If you’re like most developers, you’ve likely found yourself knee-deep in the trenches of coding on countless occasions. Picture it: It’s your third straight night of coding. Your focus is unwavering, the task at hand — debugging an issue that’s been giving you trouble. Then, out of the blue, you stumble upon a simple yet cryptic boolean variable.

What did true mean in this context? What was the significance of false? Hours of sleuthing and deciphering later, the message hidden in the code finally begins to reveal itself.

Yet, a thought nags at the back of your mind: life could have been so much easier, so much more efficient, had there been a little more forethought into variable naming.

Why Proper Variable Naming Matters

If the above scenario strikes a chord, you’re not alone. As programmers, we’re tasked not only with writing functional code but also with ensuring that our code is clean, readable, and maintainable. It’s not simply about getting the job done; it’s about getting it done well.

This is where the craft of proper variable naming comes into play — a seemingly minor detail that can make a major difference in your programming practice. But how can you make your variable naming more effective? Let’s delve into some practical tips and techniques.

1. Use Descriptive Names

The name of the variable should clearly indicate its purpose or the kind of value it holds. For instance, isPaid, hasChildren, shouldDisplay are all examples of descriptive names that immediately convey meaning.

2. Use Positive Phrasing

Try to phrase the variable in the positive, rather than the negative. For example, isConnected is more intuitive and readable than isNotConnected. This can help prevent double negatives in your code, which can be confusing.

3. Prefix With Question Words

Often, boolean variables represent a yes/no situation, so it can be helpful to start the variable name with a question word like is, has, can, or should. For instance, isEmpty, canExecute, shouldContinue are all effective ways to name boolean variables.

4. Consider Default Values

If your variable will have a default value, make sure the name still makes sense with that default value. For instance, if a user is not an admin by default, isAdmin makes more sense as a boolean variable than isRegularUser.

5. Avoid Neutral Words

Try not to use words that could be interpreted as either positive or negative, such as value, state, status, etc. They don't provide a clear idea of what true or false represents.

6. Avoid Abbreviations

Unless it’s a very common abbreviation, try not to shorten words. Clarity is more important than brevity. isAuthenticated is more readable than isAuth.

7. Boolean Flags Should Indicate State, Not Actions

If a boolean variable is used as a flag, it should represent a state, not an action. For example, isComplete instead of doComplete.

8. Consistency

Be consistent in your naming conventions across your codebase. If you’re using is as a prefix in one place, use it everywhere else too. This makes it easier for others (and future you) to understand your code.

9. Avoid Redundancy

Avoid including the data type in the variable name, e.g., booleanIsReady. The boolean nature should be clear from the context and the use of a clear, descriptive name.

10. Be Domain-Specific

Sometimes, it’s better to use the terminology of the domain than general terms. If you are writing a medical software, isAlive is better than isActive.

The key takeaway? Code is read far more often than it’s written.

Thus, readability and clarity should always take precedence when naming your variables.

Proper variable naming can greatly improve the readability and maintainability of your code, thereby saving you — and others — hours of deciphering down the line.

So go ahead, share this post with your network. Let’s prevent more programmers from the fate of having to decipher poorly named Boolean variables.

Got insights, anecdotes, or your own secret sauce for better Boolean naming? Let’s spill them in the comments below — your wisdom is a valuable asset to the community. Let’s keep learning and growing together.

PS: Let me finish by saying that I’m on a mission to empower Flutter developers to become highly skilled & respected leaders in the Flutter space.

If you are a

Young & ambitious Flutter developer who is feeling a bit stuck in their current career and wants to become a highly skilled, confident, and respected leader in the Flutter development space so that you can feel accomplished, successful, and proud of your work, earn a higher income, and enjoy greater career growth and satisfaction

It would mean a lot to me if we could have a short 15-minute call with you, as I would like to know what topics are of importance to you.

If you are open to it, you can use this link to book a call with me: https://calendly.com/migalv/let-s-meet

In exchange for your time, I would be happy to answer any questions about Flutter development that you have for me.

--

--

Miguel Álvarez Lesmes

I'm on a journey to empower Flutter developers to go from feeling stuck in their careers to becoming highly skilled & respected leaders in the Flutter space