/build-tools/24.0.2/aapt : Syntax error : Unterminated quoted string”

Lately i started using NativeScript to build mobile apps and since NativeScript is used to build native apps not hybride apps, but using web technologies such as JavaScript and CSS (actually just a subset of CSS), you need to configure your platform for native development (which a hell by the way).For Android you need to install Java and the Android SDK .

After setting up my development environment,installing Java and the Android SDK and then installing NativeScript CLI ,I generated a new project using

nativescript create myApp

And then i tried to build it using

nativescript build myApp

The build process has failed with this error related to aapt,the error says

/build-tools/24.0.2/aapt : Syntax error : Unterminated quoted string”

I have done many researches on Google trying to solve the problem and fortunately for me i found my source of problem and a solution too .So if you get the same problem don’t worry it’s just related to build-tools .Google dropped support for 32 bit processors starting with this version so either you need to use a 64 bit processor or use version 23 of build tools ,you can download it here and you need to change also the platform tools ,just copy them and replace the existing ones in Android SDK home directory .

I’m using Ubuntu but if you are using Windows or MAC i think that this solution works for you too since it’s just related to the processor architecture.

References

You can find my Android and NativeScript tutorials here

Like what you read? Give Ahmed Bouchefra a round of applause.

From a quick cheer to a standing ovation, clap to show how much you enjoyed this story.