Resolviendo error de compilación de IB en Xamarin IOS


Tabla de errores:

❌ ibtool exited with code 1 (ProjectName.iOS)

❌ Compiling IB documents for earlier than iOS 7 is no longer supported. (ProjectName.iOS) ibtool


¡Vamos a corregirlo!

Para corregirlo tenemos dos opciones:

Opción 1⃣: Modificar el Deployment target

En tu proyecto iOS busca el archivo llamado Info.plist y ábrelo, dentro de la Categoría Información de implementación (Deployment Info category), configura el Destino de Implementación (Deployment Target) con una versión de 7.0 en adelante. Y Listo! Problema solucionado. 😎

⚠ El Deployment Target es la versión mínima de iOS que la aplicación admite y apartir de la cuál podrá ser descargada. En este caso, si lo configuramos en la versión iOS 7.0, los dispositivos con versiones anteriores no podrán descargarlo.


Opción 2⃣ : Actualiza tu XCode

¡Sólo debes actualizar tu versión XCode! .🎉 Si tu versión de macOS es posterior a la 10.13.6 tendrás que actualizarla. Y luego actualizar la versión de XCode.

Gracias por leer mi artículo 💚

Artículo en inglés: https://askxammy.com/how-to-fix-ib-compiling-error-in-xamarin-ios/