其他步骤都比较顺利, 到这一步时出现问题, 提示包依赖问题

sudo apt-get install docker-engine
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies: docker-engine : Depends: init-system-helpers (>= 1.18~) but 1.14 is to be installed Depends: lsb-base (>= 4.1+Debian11ubuntu7) but 4.1+Debian11ubuntu6 is to be installed Depends: libdevmapper1.02.1 (>= 2:1.02.99) but 2:1.02.77–6ubuntu2 is to be installed Recommends: aufs-tools but it is not going to be installed Recommends: cgroupfs-mount but it is not installable or cgroup-lite but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

在google上搜索, 发现有相似的问题:, 并且有人给出了解决方案, 就是这个命令

sudo wget -qO- | sh

用这个命令可以成功安装Docker到Ubuntu 14.04系统上.

One clap, two clap, three clap, forty?

By clapping more or less, you can signal to us which stories really stand out.