<!doctype html><html lang="en"><head><title data-rh="true">I followed myself, for months, through Apple’s Find My network | by Stephan Janssen | Nov, 2022 | Medium</title><meta data-rh="true" charset="utf-8"/><meta data-rh="true" name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1,maximum-scale=1"/><meta data-rh="true" name="theme-color" content="#000000"/><meta data-rh="true" name="twitter:app:name:iphone" content="Medium"/><meta data-rh="true" name="twitter:app:id:iphone" content="828256236"/><meta data-rh="true" property="al:ios:app_name" content="Medium"/><meta data-rh="true" property="al:ios:app_store_id" content="828256236"/><meta data-rh="true" property="al:android:package" content="com.medium.reader"/><meta data-rh="true" property="fb:app_id" content="542599432471018"/><meta data-rh="true" property="og:site_name" content="Medium"/><meta data-rh="true" property="og:type" content="article"/><meta data-rh="true" property="article:published_time" content="2022-11-22T21:17:22.381Z"/><meta data-rh="true" name="title" content="I followed myself, for months, through Apple’s Find My network | by Stephan Janssen | Nov, 2022 | Medium"/><meta data-rh="true" property="og:title" content="I followed myself, for months, through Apple’s Find My network"/><meta data-rh="true" property="al:android:url" content="medium://p/95b7d6f2e8b1"/><meta data-rh="true" property="al:ios:url" content="medium://p/95b7d6f2e8b1"/><meta data-rh="true" property="al:android:app_name" content="Medium"/><meta data-rh="true" name="description" content="A while ago, I read an interesting story about the Apple Find My network being reverse engineered. This had led to the creation of OpenHaystack, a tool that allows you to create your own AirTag-like…"/><meta data-rh="true" property="og:description" content="A while ago, I read an interesting story about the Apple Find My network being reverse engineered. This had led to the creation of…"/><meta data-rh="true" property="og:url" content="https://medium.com/@stephanjanssen/i-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1"/><meta data-rh="true" property="al:web:url" content="https://medium.com/@stephanjanssen/i-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1"/><meta data-rh="true" property="og:image" content="https://miro.medium.com/max/929/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg"/><meta data-rh="true" property="article:author" content="https://medium.com/@stephanjanssen"/><meta data-rh="true" name="author" content="Stephan Janssen"/><meta data-rh="true" name="robots" content="noindex,follow,max-image-preview:large"/><meta data-rh="true" name="referrer" content="unsafe-url"/><meta data-rh="true" property="twitter:title" content="I followed myself, for months, through Apple’s Find My network"/><meta data-rh="true" name="twitter:site" content="@Medium"/><meta data-rh="true" name="twitter:app:url:iphone" content="medium://p/95b7d6f2e8b1"/><meta data-rh="true" property="twitter:description" content="A while ago, I read an interesting story about the Apple Find My network being reverse engineered. This had led to the creation of…"/><meta data-rh="true" name="twitter:image:src" content="https://miro.medium.com/max/929/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg"/><meta data-rh="true" name="twitter:card" content="summary_large_image"/><meta data-rh="true" name="twitter:label1" content="Reading time"/><meta data-rh="true" name="twitter:data1" content="6 min read"/><meta data-rh="true" name="twitter:tile:template:testing" content="2"/><meta data-rh="true" name="twitter:tile:image" content="https://miro.medium.com/max/929/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg"/><meta data-rh="true" name="twitter:tile:info1:icon" content="Person"/><meta data-rh="true" name="twitter:tile:info1:text" content="Stephan Janssen"/><meta data-rh="true" name="twitter:tile:info2:icon" content="Calendar"/><meta data-rh="true" name="twitter:tile:info2:text" content="Nov 22, 2022"/><meta data-rh="true" name="twitter:cta" content="Read on Medium"/><link data-rh="true" rel="icon" href="https://miro.medium.com/1*m-R_BkNf1Qjr1YbyOIJY2w.png"/><link data-rh="true" rel="search" type="application/opensearchdescription+xml" title="Medium" href="/osd.xml"/><link data-rh="true" rel="apple-touch-icon" sizes="152x152" href="https://miro.medium.com/fit/c/152/152/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="120x120" href="https://miro.medium.com/fit/c/120/120/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="76x76" href="https://miro.medium.com/fit/c/76/76/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="60x60" href="https://miro.medium.com/fit/c/60/60/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="mask-icon" href="https://cdn-static-1.medium.com/_/fp/icons/Medium-Avatar-500x500.svg" color="#171717"/><link data-rh="true" rel="preconnect" href="https://glyph.medium.com" crossOrigin=""/><link data-rh="true" id="glyph_preload_link" rel="preload" as="style" type="text/css" href="https://glyph.medium.com/css/unbound.css"/><link data-rh="true" id="glyph_link" rel="stylesheet" type="text/css" href="https://glyph.medium.com/css/unbound.css"/><link data-rh="true" rel="author" href="https://medium.com/@stephanjanssen"/><link data-rh="true" rel="canonical" href="https://medium.com/@stephanjanssen/i-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1"/><link data-rh="true" rel="alternate" href="android-app://com.medium.reader/https/medium.com/p/95b7d6f2e8b1"/><script data-rh="true" type="application/ld+json">{"@context":"http:\u002F\u002Fschema.org","@type":"NewsArticle","image":["https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F1200\u002F1*0ohXyjS-TGUg9L1lWkbHRg.jpeg"],"url":"https:\u002F\u002Fmedium.com\u002F@stephanjanssen\u002Fi-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1","dateCreated":"2022-11-22T21:17:22.381Z","datePublished":"2022-11-22T21:17:22.381Z","dateModified":"2022-11-22T21:17:23.504Z","headline":"I followed myself, for months, through Apple’s Find My network","name":"I followed myself, for months, through Apple’s Find My network","description":"A while ago, I read an interesting story about the Apple Find My network being reverse engineered. This had led to the creation of OpenHaystack, a tool that allows you to create your own AirTag-like…","identifier":"95b7d6f2e8b1","author":{"@type":"Person","name":"Stephan Janssen","url":"https:\u002F\u002Fmedium.com\u002F@stephanjanssen"},"creator":["Stephan Janssen"],"publisher":{"@type":"Organization","name":"Medium","url":"https:\u002F\u002Fmedium.com\u002F","logo":{"@type":"ImageObject","width":308,"height":60,"url":"https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F616\u002F1*OMF3fSqH8t4xBJ9-6oZDZw.png"}},"mainEntityOfPage":"https:\u002F\u002Fmedium.com\u002F@stephanjanssen\u002Fi-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1"}</script><style type="text/css" data-fela-rehydration="454" data-fela-type="STATIC">html{box-sizing:border-box;-webkit-text-size-adjust:100%}*, *:before, *:after{box-sizing:inherit}body{margin:0;padding:0;text-rendering:optimizeLegibility;-webkit-font-smoothing:antialiased;color:rgba(0,0,0,0.8);position:relative;min-height:100vh}h1, h2, h3, h4, h5, h6, dl, dd, ol, ul, menu, figure, blockquote, p, pre, form{margin:0}menu, ol, ul{padding:0;list-style:none;list-style-image:none}main{display:block}a{color:inherit;text-decoration:none}a, button, input{-webkit-tap-highlight-color:transparent}img, svg{vertical-align:middle}button{background:transparent;overflow:visible}button, input, optgroup, select, textarea{margin:0}:root{--reach-tabs:1;--reach-menu-button:1}#speechify-root{font-family:Sohne, sans-serif}div[data-popper-reference-hidden="true"]{visibility:hidden;pointer-events:none}
/*XCode style (c) Angel Garcia <angelgarcia.mail@gmail.com>*/.hljs {background: #fff;color: black;
}/* Gray DOCTYPE selectors like WebKit */
.xml .hljs-meta {color: #c0c0c0;
}.hljs-comment,
.hljs-quote {color: #007400;
}.hljs-tag,
.hljs-attribute,
.hljs-keyword,
.hljs-selector-tag,
.hljs-literal,
.hljs-name {color: #aa0d91;
}.hljs-variable,
.hljs-template-variable {color: #3F6E74;
}.hljs-code,
.hljs-string,
.hljs-meta .hljs-string {color: #c41a16;
}.hljs-regexp,
.hljs-link {color: #0E0EFF;
}.hljs-title,
.hljs-symbol,
.hljs-bullet,
.hljs-number {color: #1c00cf;
}.hljs-section,
.hljs-meta {color: #643820;
}.hljs-title.class_,
.hljs-class .hljs-title,
.hljs-type,
.hljs-built_in,
.hljs-params {color: #5c2699;
}.hljs-attr {color: #836C28;
}.hljs-subst {color: #000;
}.hljs-formula {background-color: #eee;font-style: italic;
}.hljs-addition {background-color: #baeeba;
}.hljs-deletion {background-color: #ffc8bd;
}.hljs-selector-id,
.hljs-selector-class {color: #9b703f;
}.hljs-doctag,
.hljs-strong {font-weight: bold;
}.hljs-emphasis {font-style: italic;
}
</style><style type="text/css" data-fela-rehydration="454" data-fela-type="KEYFRAME">@-webkit-keyframes k1{0%{transform:scale(1)}50%{transform:scale(1.1)}100%{transform:scale(1)}}@-moz-keyframes k1{0%{transform:scale(1)}50%{transform:scale(1.1)}100%{transform:scale(1)}}@keyframes k1{0%{transform:scale(1)}50%{transform:scale(1.1)}100%{transform:scale(1)}}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE">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</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (min-width: 1080px)">.d{display:none}.t{flex-direction:row}.z{width:80px}.ab{min-height:100vh}.ac{flex-shrink:1}.ae{border-right:1px solid rgba(230, 230, 230, 1)}.cu{display:block}.cv{text-align:center}.cw{padding:40px 0}.el{margin-bottom:0}.ex{margin-bottom:40px}.fe{margin:0 32px}.ff{max-width:692px}.fl{padding:0 16px}.fx{margin-bottom:32px}.fy{margin-top:56px}.he{display:inline-flex}.iy{font-size:32px}.iz{margin-top:0.6em}.ja{line-height:40px}.jb{letter-spacing:-0.016em}.jw{font-size:20px}.jx{margin-top:2em}.jy{line-height:32px}.jz{letter-spacing:-0.003em}.me{margin-top:0px}.mg{display:inline-block}.ni{line-height:24px}.nj{max-height:24px}.nk{letter-spacing:0}.og{margin:0}.ol{white-space:normal}.oq{margin:0 0 0 12px}.pd{margin:0 64px}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (max-width: 1079.98px)">.e{display:none}.kw{margin-left:auto}.kx{text-align:center}.md{margin-top:0px}.mf{display:inline-block}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (max-width: 903.98px)">.f{display:none}.ll{display:inline-block}.mc{margin-top:0px}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (max-width: 727.98px)">.g{display:none}.cm{display:block}.lk{display:inline-block}.ma{margin-top:0px}.mb{margin-right:0px}.pa{padding:24px 0}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (max-width: 551.98px)">.h{display:none}.p{flex-direction:column}.v{width:auto}.ah{display:block}.eh{margin-bottom:56px}.et{margin-bottom:80px}.ey{margin:0 24px}.fh{padding:0 8px}.fp{margin-bottom:24px}.fq{margin-top:32px}.gl{display:inline-block}.hm{display:flex}.ii{font-size:32px}.ij{margin-top:0.64em}.ik{line-height:40px}.il{letter-spacing:-0.016em}.jg{font-size:18px}.jh{margin-top:1.56em}.ji{line-height:28px}.jj{letter-spacing:-0.003em}.kk{margin-top:40px}.ln{margin-left:0px}.ly{margin-top:0px}.lz{margin-right:0px}.mu{font-size:16px}.mv{line-height:20px}.mw{max-height:20px}.mx{letter-spacing:0}.oc{margin:0}.oh{white-space:pre-line}.om{margin:10px 0 0 0}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (min-width: 904px) and (max-width: 1079.98px)">.i{display:none}.s{flex-direction:column}.y{width:auto}.ak{display:block}.ek{margin-bottom:56px}.ew{margin-bottom:40px}.fc{margin:0 32px}.fd{max-width:692px}.fk{padding:0 16px}.fv{margin-bottom:24px}.fw{margin-top:32px}.go{display:inline-block}.hd{display:inline-flex}.iu{font-size:32px}.iv{margin-top:0.6em}.iw{line-height:40px}.ix{letter-spacing:-0.016em}.js{font-size:20px}.jt{margin-top:2em}.ju{line-height:32px}.jv{letter-spacing:-0.003em}.kn{margin-top:56px}.nf{line-height:24px}.ng{max-height:24px}.nh{letter-spacing:0}.of{margin:0}.ok{white-space:normal}.op{margin:0 0 0 12px}.pc{margin:0 64px}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (min-width: 728px) and (max-width: 903.98px)">.j{display:none}.r{flex-direction:column}.x{width:auto}.aj{display:block}.ej{margin-bottom:56px}.ev{margin-bottom:40px}.fa{margin:0 32px}.fb{max-width:692px}.fj{padding:0 16px}.ft{margin-bottom:24px}.fu{margin-top:32px}.gn{display:inline-block}.hc{display:inline-flex}.iq{font-size:32px}.ir{margin-top:0.6em}.is{line-height:40px}.it{letter-spacing:-0.016em}.jo{font-size:20px}.jp{margin-top:2em}.jq{line-height:32px}.jr{letter-spacing:-0.003em}.km{margin-top:56px}.nc{line-height:24px}.nd{max-height:24px}.ne{letter-spacing:0}.oe{margin:0}.oj{white-space:normal}.oo{margin:0 0 0 12px}.pb{margin:0 48px}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (min-width: 552px) and (max-width: 727.98px)">.k{display:none}.q{flex-direction:column}.w{width:auto}.ai{display:block}.ei{margin-bottom:56px}.eu{margin-bottom:80px}.ez{margin:0 24px}.fi{padding:0 8px}.fr{margin-bottom:24px}.fs{margin-top:32px}.gm{display:inline-block}.hn{display:flex}.im{font-size:32px}.in{margin-top:0.64em}.io{line-height:40px}.ip{letter-spacing:-0.016em}.jk{font-size:18px}.jl{margin-top:1.56em}.jm{line-height:28px}.jn{letter-spacing:-0.003em}.kl{margin-top:40px}.lo{margin-left:0px}.my{font-size:16px}.mz{line-height:20px}.na{max-height:20px}.nb{letter-spacing:0}.od{margin:0}.oi{white-space:pre-line}.on{margin:10px 0 0 0}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="print">.li{display:none}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (min-width: 7000px)">.af{width:224px}.cx{text-align:left}.cy{padding:40px 24px}.dj{display:none}.dl{display:block}.fg{margin:0 auto}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="all and (max-width: 1239.98px)">.es{width:280px}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="(prefers-reduced-motion: no-preference)">.kp{transition:transform 300ms cubic-bezier(0.2, 0, 0.2, 1)}</style><style type="text/css" data-fela-rehydration="454" data-fela-type="RULE" media="(orientation: landscape) and (max-width: 903.98px)">.nr{max-height:none}</style></head><body><div id="root"><div class="a b c"><div class="d e f g h i j k"></div><script>document.domain = document.domain;</script><div class="l c"><div class="m n l"><div class="o p q r s t u"><div class="v w x y z ab ac ae af"><nav class="ag"><div class="ah ai aj ak d"><div class="al am an o ao u ap aq ar as at c"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Homepage" rel="noopener follow" href="/?source=---three_column_layout_nav----------------------------------"><svg viewBox="0 0 1043.63 592.71" class="bj bk"><g data-name="Layer 2"><g data-name="Layer 1"><path d="M588.67 296.36c0 163.67-131.78 296.35-294.33 296.35S0 460 0 296.36 131.78 0 294.34 0s294.33 132.69 294.33 296.36M911.56 296.36c0 154.06-65.89 279-147.17 279s-147.17-124.94-147.17-279 65.88-279 147.16-279 147.17 124.9 147.17 279M1043.63 296.36c0 138-23.17 249.94-51.76 249.94s-51.75-111.91-51.75-249.94 23.17-249.94 51.75-249.94 51.76 111.9 51.76 249.94"></path></g></g></svg></a><div class="o ao"><div class="l bl"><div><a class="bm b bn bo bp bq br bs bt bu bv bw bx by bz ca cb cc cd ce cf cg ch ci cj" rel="noopener follow" href="/plans?source=upgrade_membership---three_column_layout_nav----------------------------------">Get unlimited access</a></div></div><div class="ck cl cm"><span class="bm b bn bo cn"><a class="co cp aw ax ay az ba bb bc bd cq cr bg cs ct" href="https://rsci.app.link/?%24canonical_url=https%3A%2F%2Fmedium.com%2Fp%2F95b7d6f2e8b1&amp;%7Efeature=LoOpenInAppButton&amp;%7Echannel=ShowPostUnderUser&amp;%7Estage=mobileNavBar&amp;source=---three_column_layout_nav----------------------------------" rel="noopener follow">Open in app</a></span></div></div></div><div class="an l"></div></div><div class="ag h k j i cu"><div class="cz o da u db aq at c"><div class="cv cw cx cy"><a aria-label="Homepage" rel="noopener follow" href="/?source=---three_column_layout_nav----------------------------------"><svg viewBox="0 0 1043.63 592.71" class="dc bk"><g data-name="Layer 2"><g data-name="Layer 1"><path d="M588.67 296.36c0 163.67-131.78 296.35-294.33 296.35S0 460 0 296.36 131.78 0 294.34 0s294.33 132.69 294.33 296.36M911.56 296.36c0 154.06-65.89 279-147.17 279s-147.17-124.94-147.17-279 65.88-279 147.16-279 147.17 124.9 147.17 279M1043.63 296.36c0 138-23.17 249.94-51.76 249.94s-51.75-111.91-51.75-249.94 23.17-249.94 51.75-249.94 51.76 111.9 51.76 249.94"></path></g></g></svg></a></div><div class="l"><div class="dd l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/?source=---three_column_layout_nav----------------------------------"><div class="o do"><div class="cn de o df dg dh di"><div class="l dj dk"><div><div class="ci" aria-hidden="false"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Home"><path d="M4.5 10.75v10.5c0 .14.11.25.25.25h5c.14 0 .25-.11.25-.25v-5.5c0-.14.11-.25.25-.25h3.5c.14 0 .25.11.25.25v5.5c0 .14.11.25.25.25h5c.14 0 .25-.11.25-.25v-10.5M22 9l-9.1-6.83a1.5 1.5 0 0 0-1.8 0L2 9" stroke="currentColor" stroke-linecap="round" stroke-linejoin="round"></path></svg></div></div></div><div class="cl dl dk" aria-hidden="true"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Home"><path d="M4.5 10.75v10.5c0 .14.11.25.25.25h5c.14 0 .25-.11.25-.25v-5.5c0-.14.11-.25.25-.25h3.5c.14 0 .25.11.25.25v5.5c0 .14.11.25.25.25h5c.14 0 .25-.11.25-.25v-10.5M22 9l-9.1-6.83a1.5 1.5 0 0 0-1.8 0L2 9" stroke="currentColor" stroke-linecap="round" stroke-linejoin="round"></path></svg></div><div class="cl dl bm b dm dn">Home</div></div></div></a></div><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fme%2Fnotifications&amp;source=---three_column_layout_nav-----------------------notifications_sidenav-----------"><div class="dd l"><div class="o do"><div class="cn de o df dg dh di"><div class="l dj dk"><div><div class="ci" aria-hidden="false"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Notifications"><path d="M15 18.5a3 3 0 1 1-6 0" stroke="currentColor" stroke-linecap="round"></path><path d="M5.5 10.53V9a6.5 6.5 0 0 1 13 0v1.53c0 1.42.56 2.78 1.57 3.79l.03.03c.26.26.4.6.4.97v2.93c0 .14-.11.25-.25.25H3.75a.25.25 0 0 1-.25-.25v-2.93c0-.37.14-.71.4-.97l.03-.03c1-1 1.57-2.37 1.57-3.79z" stroke="currentColor" stroke-linejoin="round"></path></svg></div></div></div><div class="cl dl dk" aria-hidden="true"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Notifications"><path d="M15 18.5a3 3 0 1 1-6 0" stroke="currentColor" stroke-linecap="round"></path><path d="M5.5 10.53V9a6.5 6.5 0 0 1 13 0v1.53c0 1.42.56 2.78 1.57 3.79l.03.03c.26.26.4.6.4.97v2.93c0 .14-.11.25-.25.25H3.75a.25.25 0 0 1-.25-.25v-2.93c0-.37.14-.71.4-.97l.03-.03c1-1 1.57-2.37 1.57-3.79z" stroke="currentColor" stroke-linejoin="round"></path></svg></div><div class="cl dl bm b dm dn">Notifications</div></div></div></div></a></span><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fme%2Flists&amp;source=---three_column_layout_nav-----------------------lists_sidenav-----------"><div class="dd l"><div class="o do"><div class="cn de o df dg dh di"><div class="l dj dk"><div><div class="ci" aria-hidden="false"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Lists"><path d="M4.5 6.25V21c0 .2.24.32.4.2l5.45-4.09a.25.25 0 0 1 .3 0l5.45 4.09c.16.12.4 0 .4-.2V6.25a.25.25 0 0 0-.25-.25H4.75a.25.25 0 0 0-.25.25z" stroke="currentColor" stroke-linecap="round"></path><path d="M8 6V3.25c0-.14.11-.25.25-.25h11.5c.14 0 .25.11.25.25V16.5" stroke="currentColor" stroke-linecap="round"></path></svg></div></div></div><div class="cl dl dk" aria-hidden="true"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Lists"><path d="M4.5 6.25V21c0 .2.24.32.4.2l5.45-4.09a.25.25 0 0 1 .3 0l5.45 4.09c.16.12.4 0 .4-.2V6.25a.25.25 0 0 0-.25-.25H4.75a.25.25 0 0 0-.25.25z" stroke="currentColor" stroke-linecap="round"></path><path d="M8 6V3.25c0-.14.11-.25.25-.25h11.5c.14 0 .25.11.25.25V16.5" stroke="currentColor" stroke-linecap="round"></path></svg></div><div class="cl dl bm b dm dn">Lists</div></div></div></div></a></span><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fme%2Fstories%2Fdrafts&amp;source=---three_column_layout_nav-----------------------stories_sidenav-----------"><div class="dd l"><div class="o do"><div class="cn de o df dg dh di"><div class="l dj dk"><div><div class="ci" aria-hidden="false"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Stories"><path d="M4.75 21.5h14.5c.14 0 .25-.11.25-.25V2.75a.25.25 0 0 0-.25-.25H4.75a.25.25 0 0 0-.25.25v18.5c0 .14.11.25.25.25z" stroke="currentColor"></path><path d="M8 8.5h8M8 15.5h5M8 12h8" stroke="currentColor" stroke-linecap="round"></path></svg></div></div></div><div class="cl dl dk" aria-hidden="true"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Stories"><path d="M4.75 21.5h14.5c.14 0 .25-.11.25-.25V2.75a.25.25 0 0 0-.25-.25H4.75a.25.25 0 0 0-.25.25v18.5c0 .14.11.25.25.25z" stroke="currentColor"></path><path d="M8 8.5h8M8 15.5h5M8 12h8" stroke="currentColor" stroke-linecap="round"></path></svg></div><div class="cl dl bm b dm dn">Stories</div></div></div></div></a></span><div class="dp dq l"><hr class="dr ds dt bc" aria-hidden="true"/></div><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fnew-story&amp;source=---three_column_layout_nav-----------------------new_post_sidenav-----------"><div class="dd l"><div class="o do"><div class="cn de o df dg dh di"><div class="l dj dk"><div><div class="ci" aria-hidden="false"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Write"><path d="M14 4a.5.5 0 0 0 0-1v1zm7 6a.5.5 0 0 0-1 0h1zm-7-7H4v1h10V3zM3 4v16h1V4H3zm1 17h16v-1H4v1zm17-1V10h-1v10h1zm-1 1a1 1 0 0 0 1-1h-1v1zM3 20a1 1 0 0 0 1 1v-1H3zM4 3a1 1 0 0 0-1 1h1V3z" fill="currentColor"></path><path d="M17.5 4.5l-8.46 8.46a.25.25 0 0 0-.06.1l-.82 2.47c-.07.2.12.38.31.31l2.47-.82a.25.25 0 0 0 .1-.06L19.5 6.5m-2-2l2.32-2.32c.1-.1.26-.1.36 0l1.64 1.64c.1.1.1.26 0 .36L19.5 6.5m-2-2l2 2" stroke="currentColor"></path></svg></div></div></div><div class="cl dl dk" aria-hidden="true"><svg width="24" height="24" viewBox="0 0 24 24" fill="none" aria-label="Write"><path d="M14 4a.5.5 0 0 0 0-1v1zm7 6a.5.5 0 0 0-1 0h1zm-7-7H4v1h10V3zM3 4v16h1V4H3zm1 17h16v-1H4v1zm17-1V10h-1v10h1zm-1 1a1 1 0 0 0 1-1h-1v1zM3 20a1 1 0 0 0 1 1v-1H3zM4 3a1 1 0 0 0-1 1h1V3z" fill="currentColor"></path><path d="M17.5 4.5l-8.46 8.46a.25.25 0 0 0-.06.1l-.82 2.47c-.07.2.12.38.31.31l2.47-.82a.25.25 0 0 0 .1-.06L19.5 6.5m-2-2l2.32-2.32c.1-.1.26-.1.36 0l1.64 1.64c.1.1.1.26 0 .36L19.5 6.5m-2-2l2 2" stroke="currentColor"></path></svg></div><div class="cl dl bm b dm dn">Write</div></div></div></div></a></span></div><div class="du dv o ao"></div></div></div><div class="ah ai aj ak d"><div class="l ap ar ed as at c"><div class="eb an do ec"><div class="ag o ao ee"><div class="ef dq l eg"></div><div class="ef dq l eg"></div><div class="ef dq l eg"></div></div></div></div></div></nav></div><main class="eh ei ej ek el em l en"><div class="l"><div class="et eu ev ew ex l"><div class="o dx"><div class="em ce ey ez fa fb fc fd fe ff fg"><article><div class="l"><div class="fh fi fj fk fl fm fn ce fo ch l"></div><div class="l"><header class="pw-post-byline-header fp fq fr fs ft fu fv fw fx fy l"><div class="o fz u"><div class="o"><div class="ga l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/@stephanjanssen?source=post_page-----95b7d6f2e8b1--------------------------------"><div class="l do"><img alt="Stephan Janssen" class="l ch gc gd ge gg" src="https://miro.medium.com/fit/c/96/96/1*BJu-Q7C4fMIH-wicAjCEnQ.png" width="48" height="48" loading="lazy"/><div class="gb gc l gd ge gf aq"></div></div></a></div><div class="l"><div class="pw-author bm b dm dn gh"><div class="gi o gj"><div><div class="ci" aria-hidden="false"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/@stephanjanssen?source=post_page-----95b7d6f2e8b1--------------------------------">Stephan Janssen</a></div></div><div class="gk gl gm gn go d"><span><button class="bm b gp bo gq gr gs gt gu gv gw bd bz gx gy gz cd cf cg ch ci cj">Follow</button></span></div></div></div><div class="o ao ha"><p class="pw-published-date bm b bn bo cn"><span>Nov 22</span></p><div class="hb ci" aria-hidden="true"><span class="l" aria-hidden="true"><span class="bm b bn bo cn">·</span></span></div><div class="pw-reading-time bm b bn bo cn">6 min read</div></div></div></div><div class="o ao"><div class="h k hc hd he"><div class="hf l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on twitter"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M20 5.34c-.67.41-1.4.7-2.18.87a3.45 3.45 0 0 0-5.02-.1 3.49 3.49 0 0 0-1.02 2.47c0 .28.03.54.07.8a9.91 9.91 0 0 1-7.17-3.66 3.9 3.9 0 0 0-.5 1.74 3.6 3.6 0 0 0 1.56 2.92 3.36 3.36 0 0 1-1.55-.44V10c0 1.67 1.2 3.08 2.8 3.42-.3.06-.6.1-.94.12l-.62-.06a3.5 3.5 0 0 0 3.24 2.43 7.34 7.34 0 0 1-4.36 1.49l-.81-.05a9.96 9.96 0 0 0 5.36 1.56c6.4 0 9.91-5.32 9.9-9.9v-.5c.69-.49 1.28-1.1 1.74-1.81-.63.3-1.3.48-2 .56A3.33 3.33 0 0 0 20 5.33" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="hf l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on facebook"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M19.75 12.04c0-4.3-3.47-7.79-7.75-7.79a7.77 7.77 0 0 0-5.9 12.84 7.77 7.77 0 0 0 4.69 2.63v-5.49h-1.9v-2.2h1.9v-1.62c0-1.88 1.14-2.9 2.8-2.9.8 0 1.49.06 1.69.08v1.97h-1.15c-.91 0-1.1.43-1.1 1.07v1.4h2.17l-.28 2.2h-1.88v5.52a7.77 7.77 0 0 0 6.7-7.71" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="hf l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on linkedin"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M19.75 5.39v13.22a1.14 1.14 0 0 1-1.14 1.14H5.39a1.14 1.14 0 0 1-1.14-1.14V5.39a1.14 1.14 0 0 1 1.14-1.14h13.22a1.14 1.14 0 0 1 1.14 1.14zM8.81 10.18H6.53v7.3H8.8v-7.3zM9 7.67a1.31 1.31 0 0 0-1.3-1.32h-.04a1.32 1.32 0 0 0 0 2.64A1.31 1.31 0 0 0 9 7.71v-.04zm8.46 5.37c0-2.2-1.4-3.05-2.78-3.05a2.6 2.6 0 0 0-2.3 1.18h-.07v-1h-2.14v7.3h2.28V13.6a1.51 1.51 0 0 1 1.36-1.63h.09c.72 0 1.26.45 1.26 1.6v3.91h2.28l.02-4.43z" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path fill-rule="evenodd" clip-rule="evenodd" d="M3.57 14.67c0-.57.13-1.11.38-1.6l.02-.02v-.02l.02-.02c0-.02 0-.02.02-.02.12-.26.3-.52.57-.8L7.78 9v-.02l.01-.02c.44-.41.91-.7 1.44-.85a4.87 4.87 0 0 0-1.19 2.36A5.04 5.04 0 0 0 8 11.6L6.04 13.6c-.19.19-.32.4-.38.65a2 2 0 0 0 0 .9c.08.2.2.4.38.57l1.29 1.31c.27.28.62.42 1.03.42.42 0 .78-.14 1.06-.42l1.23-1.25.79-.78 1.15-1.16c.08-.09.19-.22.28-.4.1-.2.15-.42.15-.67 0-.16-.02-.3-.06-.45l-.02-.02v-.02l-.07-.14s0-.03-.04-.06l-.06-.13-.02-.02c0-.02 0-.03-.02-.05a.6.6 0 0 0-.14-.16l-.48-.5c0-.04.02-.1.04-.15l.06-.12 1.17-1.14.09-.09.56.57c.02.04.08.1.16.18l.05.04.03.06.04.05.03.04.04.06.1.14.02.02c0 .02.01.03.03.04l.1.2v.02c.1.16.2.38.3.68a1 1 0 0 1 .04.25 3.2 3.2 0 0 1 .02 1.33 3.49 3.49 0 0 1-.95 1.87l-.66.67-.97.97-1.56 1.57a3.4 3.4 0 0 1-2.47 1.02c-.97 0-1.8-.34-2.49-1.03l-1.3-1.3a3.55 3.55 0 0 1-1-2.51v-.01h-.02v.02zm5.39-3.43c0-.19.02-.4.07-.63.13-.74.44-1.37.95-1.87l.66-.67.97-.98 1.56-1.56c.68-.69 1.5-1.03 2.47-1.03.97 0 1.8.34 2.48 1.02l1.3 1.32a3.48 3.48 0 0 1 1 2.48c0 .58-.11 1.11-.37 1.6l-.02.02v.02l-.02.04c-.14.27-.35.54-.6.8L16.23 15l-.01.02-.01.02c-.44.42-.92.7-1.43.83a4.55 4.55 0 0 0 1.23-3.52L18 10.38c.18-.21.3-.42.35-.65a2.03 2.03 0 0 0-.01-.9 1.96 1.96 0 0 0-.36-.58l-1.3-1.3a1.49 1.49 0 0 0-1.06-.42c-.42 0-.77.14-1.06.4l-1.2 1.27-.8.8-1.16 1.15c-.08.08-.18.21-.29.4a1.66 1.66 0 0 0-.08 1.12l.02.03v.02l.06.14s.01.03.05.06l.06.13.02.02.01.02.01.02c.05.08.1.13.14.16l.47.5c0 .04-.02.09-.04.15l-.06.12-1.15 1.15-.1.08-.56-.56a2.3 2.3 0 0 0-.18-.19c-.02-.01-.02-.03-.02-.04l-.02-.02a.37.37 0 0 1-.1-.12c-.03-.03-.05-.04-.05-.06l-.1-.15-.02-.02-.02-.04-.08-.17v-.02a5.1 5.1 0 0 1-.28-.69 1.03 1.03 0 0 1-.04-.26c-.06-.23-.1-.46-.1-.7v.01z" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="hj o ao"></div></div><div class="ck hk"><div><div class="ci" aria-hidden="false"></div></div></div></div></div><div class="hl hm hn j i d"><div class="ga l"></div><div class="ho l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on twitter"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M20 5.34c-.67.41-1.4.7-2.18.87a3.45 3.45 0 0 0-5.02-.1 3.49 3.49 0 0 0-1.02 2.47c0 .28.03.54.07.8a9.91 9.91 0 0 1-7.17-3.66 3.9 3.9 0 0 0-.5 1.74 3.6 3.6 0 0 0 1.56 2.92 3.36 3.36 0 0 1-1.55-.44V10c0 1.67 1.2 3.08 2.8 3.42-.3.06-.6.1-.94.12l-.62-.06a3.5 3.5 0 0 0 3.24 2.43 7.34 7.34 0 0 1-4.36 1.49l-.81-.05a9.96 9.96 0 0 0 5.36 1.56c6.4 0 9.91-5.32 9.9-9.9v-.5c.69-.49 1.28-1.1 1.74-1.81-.63.3-1.3.48-2 .56A3.33 3.33 0 0 0 20 5.33" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="ho l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on facebook"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M19.75 12.04c0-4.3-3.47-7.79-7.75-7.79a7.77 7.77 0 0 0-5.9 12.84 7.77 7.77 0 0 0 4.69 2.63v-5.49h-1.9v-2.2h1.9v-1.62c0-1.88 1.14-2.9 2.8-2.9.8 0 1.49.06 1.69.08v1.97h-1.15c-.91 0-1.1.43-1.1 1.07v1.4h2.17l-.28 2.2h-1.88v5.52a7.77 7.77 0 0 0 6.7-7.71" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="ho l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi" aria-label="Share on linkedin"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path d="M19.75 5.39v13.22a1.14 1.14 0 0 1-1.14 1.14H5.39a1.14 1.14 0 0 1-1.14-1.14V5.39a1.14 1.14 0 0 1 1.14-1.14h13.22a1.14 1.14 0 0 1 1.14 1.14zM8.81 10.18H6.53v7.3H8.8v-7.3zM9 7.67a1.31 1.31 0 0 0-1.3-1.32h-.04a1.32 1.32 0 0 0 0 2.64A1.31 1.31 0 0 0 9 7.71v-.04zm8.46 5.37c0-2.2-1.4-3.05-2.78-3.05a2.6 2.6 0 0 0-2.3 1.18h-.07v-1h-2.14v7.3h2.28V13.6a1.51 1.51 0 0 1 1.36-1.63h.09c.72 0 1.26.45 1.26 1.6v3.91h2.28l.02-4.43z" fill="#A8A8A8"></path></svg></span></button></div></div></div><div class="l hg"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba bb bc bd be bf bg bh bi"><span class="ci hh dw hi"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path fill-rule="evenodd" clip-rule="evenodd" d="M3.57 14.67c0-.57.13-1.11.38-1.6l.02-.02v-.02l.02-.02c0-.02 0-.02.02-.02.12-.26.3-.52.57-.8L7.78 9v-.02l.01-.02c.44-.41.91-.7 1.44-.85a4.87 4.87 0 0 0-1.19 2.36A5.04 5.04 0 0 0 8 11.6L6.04 13.6c-.19.19-.32.4-.38.65a2 2 0 0 0 0 .9c.08.2.2.4.38.57l1.29 1.31c.27.28.62.42 1.03.42.42 0 .78-.14 1.06-.42l1.23-1.25.79-.78 1.15-1.16c.08-.09.19-.22.28-.4.1-.2.15-.42.15-.67 0-.16-.02-.3-.06-.45l-.02-.02v-.02l-.07-.14s0-.03-.04-.06l-.06-.13-.02-.02c0-.02 0-.03-.02-.05a.6.6 0 0 0-.14-.16l-.48-.5c0-.04.02-.1.04-.15l.06-.12 1.17-1.14.09-.09.56.57c.02.04.08.1.16.18l.05.04.03.06.04.05.03.04.04.06.1.14.02.02c0 .02.01.03.03.04l.1.2v.02c.1.16.2.38.3.68a1 1 0 0 1 .04.25 3.2 3.2 0 0 1 .02 1.33 3.49 3.49 0 0 1-.95 1.87l-.66.67-.97.97-1.56 1.57a3.4 3.4 0 0 1-2.47 1.02c-.97 0-1.8-.34-2.49-1.03l-1.3-1.3a3.55 3.55 0 0 1-1-2.51v-.01h-.02v.02zm5.39-3.43c0-.19.02-.4.07-.63.13-.74.44-1.37.95-1.87l.66-.67.97-.98 1.56-1.56c.68-.69 1.5-1.03 2.47-1.03.97 0 1.8.34 2.48 1.02l1.3 1.32a3.48 3.48 0 0 1 1 2.48c0 .58-.11 1.11-.37 1.6l-.02.02v.02l-.02.04c-.14.27-.35.54-.6.8L16.23 15l-.01.02-.01.02c-.44.42-.92.7-1.43.83a4.55 4.55 0 0 0 1.23-3.52L18 10.38c.18-.21.3-.42.35-.65a2.03 2.03 0 0 0-.01-.9 1.96 1.96 0 0 0-.36-.58l-1.3-1.3a1.49 1.49 0 0 0-1.06-.42c-.42 0-.77.14-1.06.4l-1.2 1.27-.8.8-1.16 1.15c-.08.08-.18.21-.29.4a1.66 1.66 0 0 0-.08 1.12l.02.03v.02l.06.14s.01.03.05.06l.06.13.02.02.01.02.01.02c.05.08.1.13.14.16l.47.5c0 .04-.02.09-.04.15l-.06.12-1.15 1.15-.1.08-.56-.56a2.3 2.3 0 0 0-.18-.19c-.02-.01-.02-.03-.02-.04l-.02-.02a.37.37 0 0 1-.1-.12c-.03-.03-.05-.04-.05-.06l-.1-.15-.02-.02-.02-.04-.08-.17v-.02a5.1 5.1 0 0 1-.28-.69 1.03 1.03 0 0 1-.04-.26c-.06-.23-.1-.46-.1-.7v.01z" fill="#A8A8A8"></path></svg></span></button></div></div></div></div></header><span class="l"></span><section><div><div class="gf as hv hw hx hy"></div><div class="hz ia ib ic id"><div class=""><h1 id="45d2" class="pw-post-title ie if ig bm ih ii ij ik il im in io ip iq ir is it iu iv iw ix iy iz ja jb jc gh">I followed myself, for months, through Apple’s Find My network</h1></div><p id="8b93" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">A while ago, I read an interesting story about the Apple Find My network being reverse engineered. This had led to the creation of <a class="au kb" href="https://github.com/seemoo-lab/openhaystack" rel="noopener ugc nofollow" target="_blank">OpenHaystack</a>, a tool that allows you to create your own AirTag-like device for tracking things… Or people. All you would need in order to do this, is a cheap ESP32 microcontroller board with built-in Bluetooth and a MacBook.</p></div><div class="o dx kc kd hl ke" role="separator"><span class="kf gc ci kg kh ki"></span><span class="kf gc ci kg kh ki"></span><span class="kf gc ci kg kh"></span></div><div class="hz ia ib ic id"><p id="69b7" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">First, let&#x27;s take a step back to explain what the Find My network is, for those who don’t know. The Find My network is a system, created by Apple, that allows you to track all your Apple devices. At first this was used to track Apple’s communications devices, like iPhones or MacBooks. In case of a stolen or misplaced device, this would allow you to recover it. Later it also became possible to track people, like friends and family members if they enabled this feature. This feature is often used by parents to keep tabs on where their children are or friends and family when a loved one goes to travel abroad. This system works through the devices sending their locations to Apple’s servers, for which they need an internet connection, of course.</p><p id="49bd" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">When we travel, we bring much more than just our phones and laptops. So, Apple figured it would be a good idea to allow you to track other things, like backpacks, keys, suitcases and purses. These items, however, don’t have an internet connection so they had to find another way. Luckily, this wasn’t a new idea, Tile had been selling devices for this purpose for years. These devices worked through Bluetooth and connected to any devices with the Tile app nearby, in order to share their location. The bottleneck with this product was that not many devices had the Tile app. When Apple decided to create a similar product and install the necessary app on all Apple devices, suddenly, hundreds of millions of devices became available to use for tracking. And so, they released the AirTag, a small device that shares its location to the Find My network through Apple Devices in its proximity. They also opened the Find My network for other manufacturers of similar devices to use.</p><figure class="kk kl km kn fy ko fm fn paragraph-image"><div role="button" tabindex="0" class="kp kq do kr ce ks"><div class="fm fn kj"><picture><source srcSet="https://miro.medium.com/max/640/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 640w, https://miro.medium.com/max/720/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 720w, https://miro.medium.com/max/750/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 750w, https://miro.medium.com/max/786/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 786w, https://miro.medium.com/max/828/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 828w, https://miro.medium.com/max/1100/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 1100w, https://miro.medium.com/max/1400/1*FVcOrxtyPuTl7FoY5Mo4fA.webp 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px" type="image/webp"/><source data-testid="og" srcSet="https://miro.medium.com/max/640/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 640w, https://miro.medium.com/max/720/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 720w, https://miro.medium.com/max/750/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 750w, https://miro.medium.com/max/786/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 786w, https://miro.medium.com/max/828/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 828w, https://miro.medium.com/max/1100/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 1100w, https://miro.medium.com/max/1400/1*FVcOrxtyPuTl7FoY5Mo4fA.jpeg 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px"/><img alt="" class="ce kt ku c" width="700" height="350" loading="eager" role="presentation"/></picture></div></div><figcaption class="kv bl fo fm fn kw kx bm b bn bo cn">Front and back of an AirTag</figcaption></figure><p id="cd82" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Obviously, to many, due to the price (~$30), size and availability, this tiny tracker became an instant hit with the most nefarious participants in our society. Nearly a year after the initial release, Apple issued a <a class="au kb" href="https://www.apple.com/newsroom/2022/02/an-update-on-airtag-and-unwanted-tracking/" rel="noopener ugc nofollow" target="_blank">statement</a> about unwanted tracking with these devices and added some prevention measures. They created warnings, so that people with Apple devices who were carrying unknown Airtags would get notified. They created an <a class="au kb" href="https://play.google.com/store/apps/details?id=com.apple.trackerdetect" rel="noopener ugc nofollow" target="_blank">Android app</a>, allowing android users to detect AirTags (which doesn&#x27;t seem to work very well). They reduced the time after which an AirTag would start emitting an audible warning (which can quite easily be disabled by opening the device). So, while this isn’t waterproof, Apple certainly made an effort to reduce the danger of these devices.</p></div><div class="o dx kc kd hl ke" role="separator"><span class="kf gc ci kg kh ki"></span><span class="kf gc ci kg kh ki"></span><span class="kf gc ci kg kh"></span></div><div class="hz ia ib ic id"><p id="b3b2" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Now let’s continue where I left off. Because Apple created the Find My network as an open platform, any device can broadcast data through Bluetooth that can be picked up by Apple devices and submitted to the network. The creators of OpenHaystack reverse engineered the protocol and created an application that allows you to create your own tracker from an ESP32. The ESP32 is a small, cheap (~$5) microcontroller with Wi-Fi and Bluetooth connectivity that is popular in the DIY community for creating internet connected devices, like a wireless thermometer. With OpenHaystack, all you have to do is connect the device, push a button and you have a tracking device. The main disadvantage compared to an AirTag is that it’s bigger and doesn’t include a battery, but there are also some advantages that make some more nefarious use cases a lot easier.</p><p id="b107" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Cue my testing, where I wanted to see whether I could track myself without me noticing, hypothetically. Since AirTags have alle these safeguards built in, I figured my iPhone would at least warn me that I was being tracked.</p><p id="de75" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">So, I ordered myself an ESP32, downloaded and installed OpenHaystack and with a click of the button created my tracking device. Or so I thought, because due to driver issues and other shenanigans it took debugging, creating a virtual machine and running some stuff on the command line… and a couple of hours later it worked! I walked to my car, stuck a cable in the rear USB port and plugged in the device:</p><figure class="kk kl km kn fy ko fm fn paragraph-image"><div role="button" tabindex="0" class="kp kq do kr ce ks"><div class="fm fn ky"><picture><source srcSet="https://miro.medium.com/max/640/1*ylhA4grjTQL5uMsi7xJhqg.webp 640w, https://miro.medium.com/max/720/1*ylhA4grjTQL5uMsi7xJhqg.webp 720w, https://miro.medium.com/max/750/1*ylhA4grjTQL5uMsi7xJhqg.webp 750w, https://miro.medium.com/max/786/1*ylhA4grjTQL5uMsi7xJhqg.webp 786w, https://miro.medium.com/max/828/1*ylhA4grjTQL5uMsi7xJhqg.webp 828w, https://miro.medium.com/max/1100/1*ylhA4grjTQL5uMsi7xJhqg.webp 1100w, https://miro.medium.com/max/1400/1*ylhA4grjTQL5uMsi7xJhqg.webp 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px" type="image/webp"/><source data-testid="og" srcSet="https://miro.medium.com/max/640/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 640w, https://miro.medium.com/max/720/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 720w, https://miro.medium.com/max/750/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 750w, https://miro.medium.com/max/786/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 786w, https://miro.medium.com/max/828/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 828w, https://miro.medium.com/max/1100/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 1100w, https://miro.medium.com/max/1400/1*ylhA4grjTQL5uMsi7xJhqg.jpeg 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px"/><img alt="" class="ce kt ku c" width="700" height="700" loading="eager" role="presentation"/></picture></div></div></figure><p id="b6c9" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">I drove around for a couple of days and checked the OpenHaystack app to see whether it had logged anything. This is what I saw:</p><figure class="kk kl km kn fy ko fm fn paragraph-image"><div role="button" tabindex="0" class="kp kq do kr ce ks"><div class="fm fn kz"><picture><source srcSet="https://miro.medium.com/max/640/1*0ohXyjS-TGUg9L1lWkbHRg.webp 640w, https://miro.medium.com/max/720/1*0ohXyjS-TGUg9L1lWkbHRg.webp 720w, https://miro.medium.com/max/750/1*0ohXyjS-TGUg9L1lWkbHRg.webp 750w, https://miro.medium.com/max/786/1*0ohXyjS-TGUg9L1lWkbHRg.webp 786w, https://miro.medium.com/max/828/1*0ohXyjS-TGUg9L1lWkbHRg.webp 828w, https://miro.medium.com/max/1100/1*0ohXyjS-TGUg9L1lWkbHRg.webp 1100w, https://miro.medium.com/max/1400/1*0ohXyjS-TGUg9L1lWkbHRg.webp 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px" type="image/webp"/><source data-testid="og" srcSet="https://miro.medium.com/max/640/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 640w, https://miro.medium.com/max/720/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 720w, https://miro.medium.com/max/750/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 750w, https://miro.medium.com/max/786/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 786w, https://miro.medium.com/max/828/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 828w, https://miro.medium.com/max/1100/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 1100w, https://miro.medium.com/max/1400/1*0ohXyjS-TGUg9L1lWkbHRg.jpeg 1400w" sizes="(min-resolution: 4dppx) and (max-width: 700px) 50vw, (-webkit-min-device-pixel-ratio: 4) and (max-width: 700px) 50vw, (min-resolution: 3dppx) and (max-width: 700px) 67vw, (-webkit-min-device-pixel-ratio: 3) and (max-width: 700px) 65vw, (min-resolution: 2.5dppx) and (max-width: 700px) 80vw, (-webkit-min-device-pixel-ratio: 2.5) and (max-width: 700px) 80vw, (min-resolution: 2dppx) and (max-width: 700px) 100vw, (-webkit-min-device-pixel-ratio: 2) and (max-width: 700px) 100vw, 700px"/><img alt="" class="ce kt ku c" width="700" height="1210" loading="lazy" role="presentation"/></picture></div></div><figcaption class="kv bl fo fm fn kw kx bm b bn bo cn">Screen capture of location data in OpenHaystack</figcaption></figure><p id="5d3c" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">The resolution of the data wasn’t incredibly high (which can probably be fixed with improved firmware), but it clearly showed my workplace at the time and some other places I’d visited. Another interesting thing was that I hadn’t been notified of any device following me around. So, I left the device in my car a while longer, five months to be exact. And during these five months, nothing happened, except my location being transmitted to Apple’s servers the whole time.</p><p id="c39a" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">You might wonder what the implications of this are, since the device is bigger than an AirTag and doesn’t even have power. Well, there are some considerable ones:</p><p id="25ab" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">First, there are smaller versions of the ESP32 than the one I used. They go down to about the same size as the AirTag. There are also even smaller devices to which the firmware could be adapted.</p><p id="dbb0" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Secondly, the device can easily be hidden inside a vehicle. If I were to mount it behind the USB ports and power it straight from the 5V wires, you wouldn’t be able to see the device and it would always be powered on with the car. You could even use a voltage regulator to mount it to 12V wires and hide it in the dashboard.</p><p id="2c36" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Third, I can change the Bluetooth name and MAC address to make it look like it’s part of the vehicle it’s embedded in. This would make it really hard for anyone to distinguish its transmission from being part of the car, especially in a modern vehicle.</p><p id="cd63" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">Finally, unlike with AirTags, Apple can’t provide law enforcement with details about whoever owns the tag. Because while AirTags are activated through an Apple device and connected to an AppleID, an ESP32 is neither.</p><p id="1237" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">So, to summarize, while the openness of Apple’s Find My network is a nice change, it also opens it up for abuse. Since devices that Apple doesn’t control also don’t seem to trigger any warnings, this allows nefarious people to abuse the system to create a cheap, hard to identify, tracking devices and follow anyone around, without having to pay for cell service and with only a small chance of getting caught.</p><p id="6228" class="pw-post-body-paragraph jd je ig jf b jg jh ji jj jk jl jm jn jo jp jq jr js jt ju jv jw jx jy jz ka hz gh">I really hope Apple spends some more time to fine tune the system and finds a way to limit the possibilities for the Find My network to be abused, because right now it seems a bit too easy.</p></div></div></section></div></div></article><div class="la o"></div></div></div><div class="l"></div><footer class="lb lc ld le o ao lf lg c"><div class="l lh"><div class="o dx"><div class="em ce ey ez fa fb fc fd fe ff fg"><div class="o u li"><div class="o ao gj"><div class="lj l"><span class="l gl lk ll e d"><div class="o ao gj"><div class="pw-multi-vote-icon do lm ln lo lp"><div class=""><div class="dr lq de lr ls lt lu bb lv lw lx lp"><svg width="24" height="24" viewBox="0 0 24 24" aria-label="clap"><path fill-rule="evenodd" clip-rule="evenodd" d="M11.37.83L12 3.28l.63-2.45h-1.26zM15.42 1.84l-1.18-.39-.34 2.5 1.52-2.1zM9.76 1.45l-1.19.4 1.53 2.1-.34-2.5zM20.25 11.84l-2.5-4.4a1.42 1.42 0 0 0-.93-.64.96.96 0 0 0-.75.18c-.25.19-.4.42-.45.7l.05.05 2.35 4.13c1.62 2.95 1.1 5.78-1.52 8.4l-.46.41c1-.13 1.93-.6 2.78-1.45 2.7-2.7 2.51-5.59 1.43-7.38zM12.07 9.01c-.13-.69.08-1.3.57-1.77l-2.06-2.07a1.12 1.12 0 0 0-1.56 0c-.15.15-.22.34-.27.53L12.07 9z"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M14.74 8.3a1.13 1.13 0 0 0-.73-.5.67.67 0 0 0-.53.13c-.15.12-.59.46-.2 1.3l1.18 2.5a.45.45 0 0 1-.23.76.44.44 0 0 1-.48-.25L7.6 6.11a.82.82 0 1 0-1.15 1.15l3.64 3.64a.45.45 0 1 1-.63.63L5.83 7.9 4.8 6.86a.82.82 0 0 0-1.33.9c.04.1.1.18.18.26l1.02 1.03 3.65 3.64a.44.44 0 0 1-.15.73.44.44 0 0 1-.48-.1L4.05 9.68a.82.82 0 0 0-1.4.57.81.81 0 0 0 .24.58l1.53 1.54 2.3 2.28a.45.45 0 0 1-.64.63L3.8 13a.81.81 0 0 0-1.39.57c0 .22.09.43.24.58l4.4 4.4c2.8 2.8 5.5 4.12 8.68.94 2.27-2.28 2.71-4.6 1.34-7.1l-2.32-4.08z"></path></svg></div></div></div><div class="pw-multi-vote-count l ly lz ma mb mc md me"><p class="bm b gp bo cn"><span class="lq">--</span></p></div></div></span><span class="l h g f mf mg"><div class="o ao gj"><div class="pw-multi-vote-icon do lm ln lo lp"><div class=""><div class="dr lq de lr ls lt lu bb lv lw lx lp"><svg width="24" height="24" viewBox="0 0 24 24" aria-label="clap"><path fill-rule="evenodd" clip-rule="evenodd" d="M11.37.83L12 3.28l.63-2.45h-1.26zM15.42 1.84l-1.18-.39-.34 2.5 1.52-2.1zM9.76 1.45l-1.19.4 1.53 2.1-.34-2.5zM20.25 11.84l-2.5-4.4a1.42 1.42 0 0 0-.93-.64.96.96 0 0 0-.75.18c-.25.19-.4.42-.45.7l.05.05 2.35 4.13c1.62 2.95 1.1 5.78-1.52 8.4l-.46.41c1-.13 1.93-.6 2.78-1.45 2.7-2.7 2.51-5.59 1.43-7.38zM12.07 9.01c-.13-.69.08-1.3.57-1.77l-2.06-2.07a1.12 1.12 0 0 0-1.56 0c-.15.15-.22.34-.27.53L12.07 9z"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M14.74 8.3a1.13 1.13 0 0 0-.73-.5.67.67 0 0 0-.53.13c-.15.12-.59.46-.2 1.3l1.18 2.5a.45.45 0 0 1-.23.76.44.44 0 0 1-.48-.25L7.6 6.11a.82.82 0 1 0-1.15 1.15l3.64 3.64a.45.45 0 1 1-.63.63L5.83 7.9 4.8 6.86a.82.82 0 0 0-1.33.9c.04.1.1.18.18.26l1.02 1.03 3.65 3.64a.44.44 0 0 1-.15.73.44.44 0 0 1-.48-.1L4.05 9.68a.82.82 0 0 0-1.4.57.81.81 0 0 0 .24.58l1.53 1.54 2.3 2.28a.45.45 0 0 1-.64.63L3.8 13a.81.81 0 0 0-1.39.57c0 .22.09.43.24.58l4.4 4.4c2.8 2.8 5.5 4.12 8.68.94 2.27-2.28 2.71-4.6 1.34-7.1l-2.32-4.08z"></path></svg></div></div></div><div class="pw-multi-vote-count l ly lz ma mb mc md me"><p class="bm b gp bo cn"><span class="lq">--</span></p></div></div></span></div><div class="mh o"><div><div class="ci" aria-hidden="false"><button class="mj dr mk o ao de ml mm" aria-label="responses"><svg width="24" height="24" viewBox="0 0 24 24" aria-label="responses" class="mi"><path d="M18 16.8a7.14 7.14 0 0 0 2.24-5.32c0-4.12-3.53-7.48-8.05-7.48C7.67 4 4 7.36 4 11.48c0 4.13 3.67 7.48 8.2 7.48a8.9 8.9 0 0 0 2.38-.32c.23.2.48.39.75.56 1.06.69 2.2 1.04 3.4 1.04.22 0 .4-.11.48-.29a.5.5 0 0 0-.04-.52 6.4 6.4 0 0 1-1.16-2.65v.02zm-3.12 1.06l-.06-.22-.32.1a8 8 0 0 1-2.3.33c-4.03 0-7.3-2.96-7.3-6.59S8.17 4.9 12.2 4.9c4 0 7.1 2.96 7.1 6.6 0 1.8-.6 3.47-2.02 4.72l-.2.16v.26l.02.3a6.74 6.74 0 0 0 .88 2.4 5.27 5.27 0 0 1-2.17-.86c-.28-.17-.72-.38-.94-.59l.01-.02z"></path></svg></button></div></div></div></div><div class="o ao"><div class="ci" aria-hidden="false" aria-describedby="postFooterSocialMenu" aria-labelledby="postFooterSocialMenu"><div><div class="ci" aria-hidden="false"><button class="au av aw ax ay az ba hh bc bd be bf bg bh bi mn hi mo" aria-controls="postFooterSocialMenu" aria-expanded="false" aria-label="Share Post"><svg width="24" height="24" viewBox="0 0 24 24" fill="none"><path fill-rule="evenodd" clip-rule="evenodd" d="M15.22 4.93a.42.42 0 0 1-.12.13h.01a.45.45 0 0 1-.29.08.52.52 0 0 1-.3-.13L12.5 3v7.07a.5.5 0 0 1-.5.5.5.5 0 0 1-.5-.5V3.02l-2 2a.45.45 0 0 1-.57.04h-.02a.4.4 0 0 1-.16-.3.4.4 0 0 1 .1-.32l2.8-2.8a.5.5 0 0 1 .7 0l2.8 2.8a.42.42 0 0 1 .07.5zm-.1.14zm.88 2h1.5a2 2 0 0 1 2 2v10a2 2 0 0 1-2 2h-11a2 2 0 0 1-2-2v-10a2 2 0 0 1 2-2H8a.5.5 0 0 1 .35.14c.1.1.15.22.15.35a.5.5 0 0 1-.15.35.5.5 0 0 1-.35.15H6.4c-.5 0-.9.4-.9.9v10.2a.9.9 0 0 0 .9.9h11.2c.5 0 .9-.4.9-.9V8.96c0-.5-.4-.9-.9-.9H16a.5.5 0 0 1 0-1z" fill="#000"></path></svg></button></div></div></div><div class="mp l hg"></div></div></div></div></div></div></footer></div><div class="o dx"><div class="em ce ey ez fa fb fc fd fe ff fg"></div></div><div class="l"><div class="l mq li"><div class="l li"><div class="mr ms l mq"><div class="o dx"><div class="em ce ey ez fa fb fc fd fe ff fg"><div class="o ao u"><h2 class="bm mt mu mv mw mx my mz na nb jo nc nd ne js nf ng nh jw ni nj nk nl nm nn no np nq nr gh"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/@stephanjanssen?source=post_page-----95b7d6f2e8b1--------------------------------">More from Stephan Janssen</a></h2><div class="ns o"><span><button class="bm b bn bo gq bq gs gt gu gv gw bd bz gx gy gz cd cf cg ch ci cj">Follow</button></span><div class="ns l"><div><div><div class="ci" aria-hidden="false"><div class="l"><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?actionUrl=%2F_%2Fapi%2Fusers%2F99d4d5e949c0%2Flazily-enable-writer-subscription&amp;operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stephanjanssen%2Fi-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1&amp;user=Stephan+Janssen&amp;userId=99d4d5e949c0&amp;source=-----95b7d6f2e8b1---------------------subscribe_user-----------"><button class="bm b bn bo bp bb br bs bt bu bv bw bx by bz gx gy gz cd cf cg ch ci cj" aria-label="Subscribe"><svg width="38" height="38" viewBox="0 0 38 38" fill="none" class="nt nu nv"><rect x="26.25" y="9.25" width="0.5" height="6.5" rx="0.25"></rect><rect x="29.75" y="12.25" width="0.5" height="6.5" rx="0.25" transform="rotate(90 29.75 12.25)"></rect><path d="M19.5 12.5h-7a1 1 0 0 0-1 1v11a1 1 0 0 0 1 1h13a1 1 0 0 0 1-1v-5"></path><path d="M11.5 14.5L19 20l4-3"></path></svg></button></a></span></div></div></div></div></div></div></div><div class="nw l"><p class="bm b bn bo cn">Software Architecture, Digital Forensics, Legal, Drones, 3D Printers</p></div></div></div></div></div><div class="nx l"><div class="ny nz oa ob l"><div class="hr l bl"><div class="o dx"><div class="oc od oe of og kt em ce"><div class="ah oh ai oi gn oj go ok mg ol"><p class="bm b dm dn gh">Love podcasts or audiobooks? Learn on the go with our new app.</p></div><div class="om ah on ai oo gn op go oq mg"><a class="bm b bn bo gq bq gs or os ot ou bd bz ca cb cc cd cf cg ch ci cj" href="https://knowable.fyi/?utm_source=medium&amp;utm_medium=referral&amp;utm_campaign=medium-post-footer&amp;source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow">Try Knowable</a></div></div></div></div></div></div><div class="o dx"><div class="em ce ey ez fa fb fc fd fe ff fg"><div class="ov oa l"></div></div></div></div></div><div class="d"><div class="ow ox oy l lf ar ed as oz pa"><div class="o dx"><div class="ey ez pb pc pd pe em ce"><a class="au av aw ax ay az ba bb bc bd pf pg bg ph pi" aria-label="Go to homepage" rel="noopener follow" href="/?source=post_page-----95b7d6f2e8b1--------------------------------"><svg viewBox="0 0 3940 610" class="gs pj"><path d="M594.79 308.2c0 163.76-131.85 296.52-294.5 296.52S5.8 472 5.8 308.2 137.65 11.69 300.29 11.69s294.5 132.75 294.5 296.51M917.86 308.2c0 154.16-65.93 279.12-147.25 279.12s-147.25-125-147.25-279.12S689.29 29.08 770.61 29.08s147.25 125 147.25 279.12M1050 308.2c0 138.12-23.19 250.08-51.79 250.08s-51.79-112-51.79-250.08 23.19-250.08 51.8-250.08S1050 170.09 1050 308.2M1862.77 37.4l.82-.18v-6.35h-167.48l-155.51 365.5-155.51-365.5h-180.48v6.35l.81.18c30.57 6.9 46.09 17.19 46.09 54.3v434.45c0 37.11-15.58 47.4-46.15 54.3l-.81.18V587H1327v-6.35l-.81-.18c-30.57-6.9-46.09-17.19-46.09-54.3V116.9L1479.87 587h11.33l205.59-483.21V536.9c-2.62 29.31-18 38.36-45.68 44.61l-.82.19v6.3h213.3v-6.3l-.82-.19c-27.71-6.25-43.46-15.3-46.08-44.61l-.14-445.2h.14c0-37.11 15.52-47.4 46.08-54.3m97.43 287.8c3.49-78.06 31.52-134.4 78.56-135.37 14.51.24 26.68 5 36.14 14.16 20.1 19.51 29.55 60.28 28.09 121.21zm-2.11 22h250v-1.05c-.71-59.69-18-106.12-51.34-138-28.82-27.55-71.49-42.71-116.31-42.71h-1c-23.26 0-51.79 5.64-72.09 15.86-23.11 10.7-43.49 26.7-60.45 47.7-27.3 33.83-43.84 79.55-47.86 130.93-.13 1.54-.24 3.08-.35 4.62s-.18 2.92-.25 4.39a332.64 332.64 0 0 0-.36 21.69C1860.79 507 1923.65 600 2035.3 600c98 0 155.07-71.64 169.3-167.8l-7.19-2.53c-25 51.68-69.9 83-121 79.18-69.76-5.22-123.2-75.95-118.35-161.63m532.69 157.68c-8.2 19.45-25.31 30.15-48.24 30.15s-43.89-15.74-58.78-44.34c-16-30.7-24.42-74.1-24.42-125.51 0-107 33.28-176.21 84.79-176.21 21.57 0 38.55 10.7 46.65 29.37zm165.84 76.28c-30.57-7.23-46.09-18-46.09-57V5.28L2424.77 60v6.7l1.14-.09c25.62-2.07 43 1.47 53.09 10.79 7.9 7.3 11.75 18.5 11.75 34.26v71.14c-18.31-11.69-40.09-17.38-66.52-17.38-53.6 0-102.59 22.57-137.92 63.56-36.83 42.72-56.3 101.1-56.3 168.81C2230 518.72 2289.53 600 2378.13 600c51.83 0 93.53-28.4 112.62-76.3V588h166.65v-6.66zm159.29-505.33c0-37.76-28.47-66.24-66.24-66.24-37.59 0-67 29.1-67 66.24s29.44 66.24 67 66.24c37.77 0 66.24-28.48 66.24-66.24m43.84 505.33c-30.57-7.23-46.09-18-46.09-57h-.13V166.65l-166.66 47.85v6.5l1 .09c36.06 3.21 45.93 15.63 45.93 57.77V588h166.8v-6.66zm427.05 0c-30.57-7.23-46.09-18-46.09-57V166.65L3082 212.92v6.52l.94.1c29.48 3.1 38 16.23 38 58.56v226c-9.83 19.45-28.27 31-50.61 31.78-36.23 0-56.18-24.47-56.18-68.9V166.66l-166.66 47.85V221l1 .09c36.06 3.2 45.94 15.62 45.94 57.77v191.27a214.48 214.48 0 0 0 3.47 39.82l3 13.05c14.11 50.56 51.08 77 109 77 49.06 0 92.06-30.37 111-77.89v66h166.66v-6.66zM3934.2 588v-6.67l-.81-.19c-33.17-7.65-46.09-22.07-46.09-51.43v-243.2c0-75.83-42.59-121.09-113.93-121.09-52 0-95.85 30.05-112.73 76.86-13.41-49.6-52-76.86-109.06-76.86-50.12 0-89.4 26.45-106.25 71.13v-69.87l-166.66 45.89v6.54l1 .09c35.63 3.16 45.93 15.94 45.93 57V588h155.5v-6.66l-.82-.2c-26.46-6.22-35-17.56-35-46.66V255.72c7-16.35 21.11-35.72 49-35.72 34.64 0 52.2 24 52.2 71.28V588h155.54v-6.66l-.82-.2c-26.46-6.22-35-17.56-35-46.66v-248a160.45 160.45 0 0 0-2.2-27.68c7.42-17.77 22.34-38.8 51.37-38.8 35.13 0 52.2 23.31 52.2 71.28V588z"></path></svg></a><div class="pk l"><p class="bm b gp bo pl"><a class="au av aw ax ay az ba bb bc bd pm bg ph pi ki" href="https://medium.com/about?autoplay=1&amp;source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow">About</a><a class="au av aw ax ay az ba bb bc bd pm bg ph pi ki" href="https://help.medium.com/hc/en-us?source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow">Help</a><a class="au av aw ax ay az ba bb bc bd pm bg ph pi ki" href="https://policy.medium.com/medium-terms-of-service-9db0094a1e0f?source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow">Terms</a><a class="au av aw ax ay az ba bb bc bd pm bg ph pi" href="https://policy.medium.com/medium-privacy-policy-f03bf92035c9?source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow">Privacy</a></p></div><div class="j i d"><hr class="dr ds pn po" aria-hidden="true"/><h2 class="bm mt dm bo if pl">Get the Medium app</h2><div class="pk o"><div class="ga l"><a class="au av aw ax ay az ba bb bc bd pf pg bg ph pi" href="https://itunes.apple.com/app/medium-everyones-stories/id828256236?pt=698524&amp;mt=8&amp;ct=post_page&amp;source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow"><img alt="A button that says &#x27;Download on the App Store&#x27;, and if clicked it will lead you to the iOS App store" class="" src="https://miro.medium.com/max/270/1*Crl55Tm6yDNMoucPo1tvDg.png" width="135" height="41" loading="lazy"/></a></div><a class="au av aw ax ay az ba bb bc bd pf pg bg ph pi" href="https://play.google.com/store/apps/details?id=com.medium.reader&amp;source=post_page-----95b7d6f2e8b1--------------------------------" rel="noopener follow"><img alt="A button that says &#x27;Get it on, Google Play&#x27;, and if clicked it will lead you to the Google Play store" class="" src="https://miro.medium.com/max/270/1*W_RAPQ62h0em559zluJLdQ.png" width="135" height="41" loading="lazy"/></a></div></div></div></div></div></div></div></main><div class="eo ch c ep h k j i cu eq er es"><div class="ag ce ci do"><div class="l db pp"><div class="pq o da"><div class="l lh"><div class="pr ps pt l"><div class="l"><div class="o ao"><div class="pw-susi-button l lh"><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stephanjanssen%2Fi-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1&amp;source=post_page---three_column_layout_sidebar-----------------------three_column_layout_nav-----------"><button class="bm b bn bo bp bq br bs bt bu bv bw bx by bz ca cb cc cd ce cf cg ch ci cj" aria-label="sign up">Get started</button></a></span></div></div></div></div><div class="pr ps pt l"><div class="o hq pu pv"><div class="ci" aria-hidden="false" aria-describedby="searchResults" aria-labelledby="searchResults"></div><span class="qa l"><svg width="25" height="25" viewBox="0 0 25 25" fill="rgba(8, 8, 8, 1)"><path d="M20.07 18.93l-4.16-4.15a6 6 0 1 0-.88.88l4.15 4.16a.62.62 0 1 0 .89-.89zM6.5 11a4.75 4.75 0 1 1 9.5 0 4.75 4.75 0 0 1-9.5 0z"></path></svg></span><input role="combobox" aria-controls="searchResults" aria-expanded="false" aria-label="search" tabindex="0" class="dz pw bm bn bo ce px py gh pz" placeholder="Search" value=""/></div></div><div class="pr ps pt l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/@stephanjanssen?source=---three_column_layout_sidebar----------------------------------"><div class="l do"><img alt="Stephan Janssen" class="l ch gc qb qc gg" src="https://miro.medium.com/fit/c/176/176/1*BJu-Q7C4fMIH-wicAjCEnQ.png" width="88" height="88" loading="lazy"/><div class="gb gc l qb qc gf aq"></div></div></a><div class="qd l"></div><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/@stephanjanssen?source=---three_column_layout_sidebar----------------------------------"><h2 class="pw-author-name bm mt dm bo if gh"><span class="hz">Stephan Janssen</span></h2></a><div class="qe l"></div><div class="qf l"></div><p class="bm b bn bo cn"><span class="hz">Software Architecture, Digital Forensics, Legal, Drones, 3D Printers</span></p><div class="qg l"></div><div class="qh o"><span><button class="bm b bn bo gq bq gs gt gu gv gw bd bz gx gy gz cd qi cf cg ch ci cj">Follow</button></span><div class="ns l"><div><div><div class="ci" aria-hidden="false"><div class="l"><span><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/m/signin?actionUrl=%2F_%2Fapi%2Fusers%2F99d4d5e949c0%2Flazily-enable-writer-subscription&amp;operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stephanjanssen%2Fi-followed-myself-for-months-through-apples-find-my-network-95b7d6f2e8b1&amp;user=Stephan+Janssen&amp;userId=99d4d5e949c0&amp;source=---three_column_layout_sidebar-----------------------subscribe_user-----------"><button class="bm b bn bo bp bb br bs bt bu bv bw bx by bz gx gy gz cd cf cg ch ci cj" aria-label="Subscribe"><svg width="38" height="38" viewBox="0 0 38 38" fill="none" class="nt nu nv"><rect x="26.25" y="9.25" width="0.5" height="6.5" rx="0.25"></rect><rect x="29.75" y="12.25" width="0.5" height="6.5" rx="0.25" transform="rotate(90 29.75 12.25)"></rect><path d="M19.5 12.5h-7a1 1 0 0 0-1 1v11a1 1 0 0 0 1 1h13a1 1 0 0 0 1-1v-5"></path><path d="M11.5 14.5L19 20l4-3"></path></svg></button></a></span></div></div></div></div></div></div></div><div class="pr ps pt l"></div></div><div class="qj o gj ha"><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://help.medium.com/hc/en-us?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Help</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://medium.statuspage.io/?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Status</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://about.medium.com/creators/?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Writers</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://blog.medium.com/?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Blog</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" rel="noopener follow" href="/jobs-at-medium/work-at-medium-959d1a85284e?source=---three_column_layout_sidebar----------------------------------"><p class="bm b ql qm cn">Careers</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://policy.medium.com/medium-privacy-policy-f03bf92035c9?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Privacy</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://policy.medium.com/medium-terms-of-service-9db0094a1e0f?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Terms</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://medium.com/about?autoplay=1&amp;source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">About</p></a></div><div class="qk l"><a class="au av aw ax ay az ba bb bc bd be bf bg bh bi" href="https://speechify.com/medium?source=---three_column_layout_sidebar----------------------------------" rel="noopener follow"><p class="bm b ql qm cn">Text to speech</p></a></div></div></div></div></div></div></div></div></div></div></div><script>window.__BUILD_ID__="main-20221122-200333-19072869e1"</script><script>window.__GRAPHQL_URI__ = "https://medium.com/_/graphql"</script><script>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</script><script>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</script><script>window.__MIDDLEWARE_STATE__={"session":{"xsrf":""},"cache":{"cacheStatus":"HIT","inDisabledExperiment":false}}</script><script src="https://cdn-client.medium.com/lite/static/js/manifest.fc5e4dea.js"></script><script src="https://cdn-client.medium.com/lite/static/js/3034.5bf7db30.js"></script><script src="https://cdn-client.medium.com/lite/static/js/main.0ccc29bc.js"></script><script src="https://cdn-client.medium.com/lite/static/js/instrumentation.c71f0248.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8732.9d4e0df2.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3447.cd943c14.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/AppLayout.1bb144ce.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/reporting.bbdcaa9d.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5642.23fd33ba.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1752.a348f767.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1961.72b183c8.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5472.a7dd22a2.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1566.249d6842.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/2981.3c13b705.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1627.d634427d.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3115.e2c29797.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/4869.b295fc9d.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6336.6353f868.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5530.62d482b5.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5067.a8ee57d4.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5429.66526483.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7070.9daf5359.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1462.0f88af6f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6804.b85aab69.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/864.caaeb92a.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7589.609641bd.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/2519.cd863424.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5722.1a858fbd.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/4897.9582ba06.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6912.32116829.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8051.a24cf86b.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8501.f175441a.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3443.94fea087.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7129.bfaa754e.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/PostPage.MainContent.d2ea976f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8261.71f0be0b.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/5180.78a0b411.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7994.7da603bb.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/PostPage.RightColumnContent.7583ad6a.chunk.js"></script><script>window.main();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/vaafb692b2aea4879b33c060e79fe94621666317369993" integrity="sha512-0ahDYl866UMhKuYcW078ScMalXqtFJggm7TmlUtp0UlD4eQk0Ixfnm5ykXKvGJNFjLMoortdseTfsRT8oCfgGA==" data-cf-beacon='{"rayId":"76eb601b0b8b0684","token":"0b5f665943484354a59c39c6833f7078","version":"2022.11.3","si":100}' crossorigin="anonymous"></script>
</body></html>