<!doctype html><html lang="en"><head><script>!function(c,f){var t,o,i,e=[],r={passive:!0,capture:!0},n=new Date,a="pointerup",u="pointercancel";function p(n,e){t||(t=e,o=n,i=new Date,w(f),s())}function s(){0<=o&&o<i-n&&(e.forEach(function(n){n(o,t)}),e=[])}function l(n){if(n.cancelable){var e=(1e12<n.timeStamp?new Date:performance.now())-n.timeStamp;"pointerdown"==n.type?function(n,e){function t(){p(n,e),i()}function o(){i()}function i(){f(a,t,r),f(u,o,r)}c(a,t,r),c(u,o,r)}(e,n):p(e,n)}}function w(e){["click","mousedown","keydown","touchstart","pointerdown"].forEach(function(n){e(n,l,r)})}w(c),self.perfMetrics=self.perfMetrics||{},self.perfMetrics.onFirstInputDelay=function(n){e.push(n),s()}}(addEventListener,removeEventListener)</script><title data-rh="true">Beep Beep: The History of George Laurer and the Barcode</title><meta data-rh="true" charset="utf-8"/><meta data-rh="true" name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1"/><meta data-rh="true" name="theme-color" content="#000000"/><meta data-rh="true" name="twitter:app:name:iphone" content="Medium"/><meta data-rh="true" name="twitter:app:id:iphone" content="828256236"/><meta data-rh="true" property="al:ios:app_name" content="Medium"/><meta data-rh="true" property="al:ios:app_store_id" content="828256236"/><meta data-rh="true" property="al:android:package" content="com.medium.reader"/><meta data-rh="true" property="fb:app_id" content="542599432471018"/><meta data-rh="true" property="og:site_name" content="Medium"/><meta data-rh="true" property="og:type" content="article"/><meta data-rh="true" property="article:published_time" content="2019-12-10T20:00:26.625Z"/><meta data-rh="true" name="title" content="Beep Beep: The History of George Laurer and the Barcode"/><meta data-rh="true" property="og:title" content="Beep beep: The History of George Laurer and the Barcode"/><meta data-rh="true" property="twitter:title" content="Beep beep: The History of George Laurer and the Barcode"/><meta data-rh="true" name="twitter:site" content="@Medium"/><meta data-rh="true" name="twitter:app:url:iphone" content="medium://p/3522a15405ea"/><meta data-rh="true" property="al:android:url" content="medium://p/3522a15405ea"/><meta data-rh="true" property="al:ios:url" content="medium://p/3522a15405ea"/><meta data-rh="true" property="al:android:app_name" content="Medium"/><meta data-rh="true" name="description" content=" Author’s note: This story was initially reported out in 2014 but was not published. It’s released here today in memory of Laurer, who died today, aged 94. Forty-five years ago Clyde Dawson handed…"/><meta data-rh="true" property="og:description" content="How a 67-cent pack of Juicy Fruit, and a guy who said no, changed the way we shopped."/><meta data-rh="true" property="twitter:description" content="How a 67-cent pack of Juicy Fruit, and a guy who said no, changed the way we shopped."/><meta data-rh="true" property="og:url" content="https://medium.com/@stokel/beep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea"/><meta data-rh="true" property="al:web:url" content="https://medium.com/@stokel/beep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea"/><meta data-rh="true" property="og:image" content="https://miro.medium.com/max/1200/1*XqdcvabbiEpyJehoTXxCSg.jpeg"/><meta data-rh="true" name="twitter:image:src" content="https://miro.medium.com/max/1200/1*XqdcvabbiEpyJehoTXxCSg.jpeg"/><meta data-rh="true" name="twitter:card" content="summary_large_image"/><meta data-rh="true" property="article:author" content="https://medium.com/@stokel"/><meta data-rh="true" name="twitter:creator" content="@stokel"/><meta data-rh="true" name="author" content="Chris Stokel-Walker"/><meta data-rh="true" name="robots" content="index,follow"/><meta data-rh="true" name="referrer" content="unsafe-url"/><meta data-rh="true" name="twitter:label1" value="Reading time"/><meta data-rh="true" name="twitter:data1" value="11 min read"/><meta data-rh="true" name="parsely-post-id" content="3522a15405ea"/><link data-rh="true" rel="publisher" href="https://plus.google.com/103654360130207659246"/><link data-rh="true" rel="search" type="application/opensearchdescription+xml" title="Medium" href="/osd.xml"/><link data-rh="true" rel="apple-touch-icon" sizes="152x152" href="https://cdn-images-1.medium.com/fit/c/152/152/1*8I-HPL0bfoIzGied-dzOvA.png"/><link data-rh="true" rel="apple-touch-icon" sizes="120x120" href="https://cdn-images-1.medium.com/fit/c/120/120/1*8I-HPL0bfoIzGied-dzOvA.png"/><link data-rh="true" rel="apple-touch-icon" sizes="76x76" href="https://cdn-images-1.medium.com/fit/c/76/76/1*8I-HPL0bfoIzGied-dzOvA.png"/><link data-rh="true" rel="apple-touch-icon" sizes="60x60" href="https://cdn-images-1.medium.com/fit/c/60/60/1*8I-HPL0bfoIzGied-dzOvA.png"/><link data-rh="true" rel="mask-icon" href="https://cdn-static-1.medium.com/_/fp/icons/monogram-mask.KPLCSFEZviQN0jQ7veN2RQ.svg" color="#171717"/><link data-rh="true" rel="icon" href="https://cdn-static-1.medium.com/_/fp/icons/favicon-rebrand-medium.3Y6xpZ-0FSdWDnPM3hSBIA.ico"/><link data-rh="true" id="glyph_link" rel="stylesheet" type="text/css" href="https://glyph.medium.com/css/e/sr/latin/e/ssr/latin/e/ssb/latin/m2.css"/><link data-rh="true" rel="author" href="https://medium.com/@stokel"/><link data-rh="true" rel="canonical" href="https://medium.com/@stokel/beep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea"/><link data-rh="true" rel="alternate" href="android-app://com.medium.reader/https/medium.com/p/3522a15405ea"/><script data-rh="true" type="application/ld+json">{"@context":"http:\u002F\u002Fschema.org","@type":"NewsArticle","image":["https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F1200\u002F1*XqdcvabbiEpyJehoTXxCSg.jpeg"],"url":"https:\u002F\u002Fmedium.com\u002F@stokel\u002Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea","dateCreated":"2019-12-10T19:57:22.389Z","datePublished":"2019-12-10T19:57:22.389Z","dateModified":"2019-12-10T21:54:26.031Z","headline":"Beep beep: The History of George Laurer and the Barcode","name":"Beep beep: The History of George Laurer and the Barcode","description":" Author’s note: This story was initially reported out in 2014 but was not published. It’s released here today in memory of Laurer, who died today, aged 94. Forty-five years ago Clyde Dawson handed…","identifier":"3522a15405ea","keywords":["Lite:true","Tag:History","Tag:Barcode","Tag:Tech","Tag:Culture","Tag:Business","Topic:History","Elevated:false","LockedPostSource:LOCKED_POST_SOURCE_UGC","LayerCake:3"],"author":{"@type":"Person","name":"Chris Stokel-Walker","url":"https:\u002F\u002Fmedium.com\u002F@stokel"},"creator":["Chris Stokel-Walker"],"publisher":{"@type":"Organization","name":"Medium","url":"https:\u002F\u002Fmedium.com\u002F","logo":{"@type":"ImageObject","width":308,"height":60,"url":"https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F616\u002F1*OMF3fSqH8t4xBJ9-6oZDZw.png"}},"mainEntityOfPage":"https:\u002F\u002Fmedium.com\u002F@stokel\u002Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea","isAccessibleForFree":"False","hasPart":{"@type":"WebPageElement","isAccessibleForFree":"False","cssSelector":".meteredContent"}}</script><script data-rh="true" >(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
ga('create', 'UA-24232453-2', 'auto');
ga('send', 'pageview');</script><link rel="preload" href="https://cdn.optimizely.com/js/16180790160.js" as="script"><style type="text/css" data-fela-rehydration="374" data-fela-type="STATIC">html{box-sizing:border-box}*, *:before, *:after{box-sizing:inherit}body{margin:0;padding:0;text-rendering:optimizeLegibility;-webkit-font-smoothing:antialiased;color:rgba(0,0,0,0.8);position:relative;min-height:100vh}h1, h2, h3, h4, h5, h6, dl, dd, ol, ul, menu, figure, blockquote, p, pre, form{margin:0}menu, ol, ul{padding:0;list-style:none;list-style-image:none}main{display:block}a{color:inherit;text-decoration:none}a, button, input{-webkit-tap-highlight-color:transparent}img, svg{vertical-align:middle}button{background:transparent;overflow:visible}button, input, optgroup, select, textarea{margin:0}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="KEYFRAME">@-webkit-keyframes k1{0%{transform:scale(1);opacity:1}70%{transform:scale(1.4);opacity:0}100%{opacity:0}}@-moz-keyframes k1{0%{transform:scale(1);opacity:1}70%{transform:scale(1.4);opacity:0}100%{opacity:0}}@keyframes k1{0%{transform:scale(1);opacity:1}70%{transform:scale(1.4);opacity:0}100%{opacity:0}}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE">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</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (min-width: 1080px)">.d{display:none}.ah{margin:0 64px}.dx{margin-top:0.78em}.eh{margin-top:0.74em}.fv{margin-left:30px}.gd{margin-top:56px}.hl{font-size:21px}.hm{margin-top:2em}.im{padding-top:7px}.mm{padding-left:64px}.mn{padding-right:64px}.mo{max-width:1320px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 1079.98px)">.e{display:none}.fu{margin-left:30px}.gy{margin-left:auto}.gz{text-align:center}.mj{padding-left:64px}.mk{padding-right:64px}.ml{max-width:1080px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 903.98px)">.f{display:none}.ft{margin-left:30px}.mg{padding-left:48px}.mh{padding-right:48px}.mi{max-width:904px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 727.98px)">.g{display:none}.am{height:56px}.an{display:flex}.ay{font-size:14px}.az{margin-top:0px}.ba{margin-left:4px}.bb{-webkit-line-clamp:2}.bd{display:block}.cx{margin-bottom:0px}.eo{margin-top:32px}.ep{flex-direction:column-reverse}.fr{margin-bottom:30px}.fs{margin-left:0px}.kx{margin-bottom:24px}.ky{align-items:center}.kz{width:102px}.la{position:relative}.le{padding-left:0}.lp{margin-top:24px}.lz{padding:32px 0}.md{padding-left:24px}.me{padding-right:24px}.mf{max-width:728px}.nk{width:140px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 551.98px)">.h{display:none}.ac{margin:0 24px}.dt{margin-top:0.39em}.ed{margin-top:0.42em}.en{margin-top:32px}.ev{margin-bottom:0px}.fp{margin-bottom:30px}.fq{margin-left:0px}.fz{margin-top:40px}.hd{font-size:18px}.he{margin-top:1.56em}.ii{padding-top:0}.ma{padding-left:24px}.mb{padding-right:24px}.mc{max-width:552px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (min-width: 904px) and (max-width: 1079.98px)">.i{display:none}.ag{margin:0 64px}.dw{margin-top:0.78em}.eg{margin-top:0.74em}.gc{margin-top:56px}.hj{font-size:21px}.hk{margin-top:2em}.il{padding-top:7px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (min-width: 728px) and (max-width: 903.98px)">.j{display:none}.af{margin:0 48px}.dv{margin-top:0.78em}.ef{margin-top:0.74em}.gb{margin-top:56px}.hh{font-size:21px}.hi{margin-top:2em}.ik{padding-top:7px}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (min-width: 552px) and (max-width: 727.98px)">.k{display:none}.ae{margin:0 24px}.du{margin-top:0.39em}.ee{margin-top:0.42em}.ga{margin-top:40px}.hf{font-size:18px}.hg{margin-top:1.56em}.ij{padding-top:0}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="print">.ab{display:none}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="(prefers-reduced-motion: no-preference)">.y{transition:transform 300ms ease}.z{will-change:transform}.ip{transition:opacity 200ms}.kc{transition:border-color 150ms ease}.kd::before{background:
      radial-gradient(circle, rgba(0, 0, 0, 0.84) 60%, transparent 70%)
    }.ke::before{border-radius:50%}.kf::before{content:""}.kg::before{display:block}.kh::before{z-index:0}.ki::before{left:0}.kj::before{height:100%}.kk::before{position:absolute}.kl::before{top:0}.km::before{width:100%}.kn:hover::before{animation:k1 2000ms infinite cubic-bezier(.1,.12,.25,1)}.kr{transition:fill 200ms ease}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 1198px)">.iq{display:none}</style><style type="text/css" data-fela-rehydration="374" data-fela-type="RULE" media="all and (max-width: 1230px)">.jm{display:none}</style></head><body><div id="root"><div class="a b c"><div class="d e f g h i j k"></div><script>document.domain = document.domain;</script><script>window.PARSELY = window.PARSELY || {autotrack: false}</script><nav class="r s t u v c w x y z ab"><div class="branch-journeys-top"><div class="n p"><div class="ac ae af ag ah ai aj ak"><div class="al n o am an"><div class="r ao w"><div class="n o"><a aria-label="Homepage" rel="noopener" href="/?source=post_page-----3522a15405ea----------------------"><div class="r g"><svg height="22" width="112" viewBox="0 0 111.5 22" class="q"><path d="M56.3 19.5c0 .4 0 .5.3.7l1.5 1.4v.1h-6.5V19c-.7 1.8-2.4 3-4.3 3-3.3 0-5.8-2.6-5.8-7.5 0-4.5 2.6-7.6 6.3-7.6 1.6-.1 3.1.8 3.8 2.4V3.2c0-.3-.1-.6-.3-.7l-1.4-1.4V1l6.5-.8v19.3zm-4.8-.8V9.5c-.5-.6-1.2-.9-1.9-.9-1.6 0-3.1 1.4-3.1 5.7 0 4 1.3 5.4 3 5.4.8.1 1.6-.3 2-1zm9.1 3.1V9.4c0-.3-.1-.6-.3-.7l-1.4-1.5v-.1h6.5v12.5c0 .4 0 .5.3.7l1.4 1.4v.1h-6.5zm-.2-19.2C60.4 1.2 61.5 0 63 0c1.4 0 2.6 1.2 2.6 2.6S64.4 5.3 63 5.3a2.6 2.6 0 0 1-2.6-2.7zm22.5 16.9c0 .4 0 .5.3.7l1.5 1.4v.1h-6.5v-3.2c-.6 2-2.4 3.4-4.5 3.4-2.9 0-4.4-2.1-4.4-6.2 0-1.9 0-4.1.1-6.5 0-.3-.1-.5-.3-.7L67.7 7v.1H74v8c0 2.6.4 4.4 2 4.4.9-.1 1.7-.6 2.1-1.3V9.5c0-.3-.1-.6-.3-.7l-1.4-1.5v-.2h6.5v12.4zm22 2.3c0-.5.1-6.5.1-7.9 0-2.6-.4-4.5-2.2-4.5-.9 0-1.8.5-2.3 1.3.2.8.3 1.7.3 2.5 0 1.8-.1 4.2-.1 6.5 0 .3.1.5.3.7l1.5 1.4v.1H96c0-.4.1-6.5.1-7.9 0-2.7-.4-4.5-2.2-4.5-.9 0-1.7.5-2.2 1.3v9c0 .4 0 .5.3.7l1.4 1.4v.1h-6.5V9.5c0-.3-.1-.6-.3-.7l-1.4-1.5v-.2h6.5v3.1a4.6 4.6 0 0 1 4.6-3.4c2.2 0 3.6 1.2 4.2 3.5.7-2.1 2.7-3.6 4.9-3.5 2.9 0 4.5 2.2 4.5 6.2 0 1.9-.1 4.2-.1 6.5-.1.3.1.6.3.7l1.4 1.4v.1h-6.6zm-81.4-2l1.9 1.9v.1h-9.8v-.1l2-1.9c.2-.2.3-.4.3-.7V7.3c0-.5 0-1.2.1-1.8L11.4 22h-.1L4.5 6.8c-.1-.4-.2-.4-.3-.6v10c-.1.7 0 1.3.3 1.9l2.7 3.6v.1H0v-.1L2.7 18c.3-.6.4-1.3.3-1.9v-11c0-.5-.1-1.1-.5-1.5L.7 1.1V1h7l5.8 12.9L18.6 1h6.8v.1l-1.9 2.2c-.2.2-.3.5-.3.7v15.2c0 .2.1.5.3.6zm7.6-5.9c0 3.8 1.9 5.3 4.2 5.3 1.9.1 3.6-1 4.4-2.7h.1c-.8 3.7-3.1 5.5-6.5 5.5-3.7 0-7.2-2.2-7.2-7.4 0-5.5 3.5-7.6 7.3-7.6 3.1 0 6.4 1.5 6.4 6.2v.8h-8.7zm0-.8h4.3v-.8c0-3.9-.8-4.9-2-4.9-1.4.1-2.3 1.6-2.3 5.7z"></path></svg></div><div class="bc bd"><svg width="35" height="35" viewBox="5 5 35 35" class="q"><path d="M5 40V5h35v35H5zm8.56-12.63c0 .56-.03.69-.32 1.03L10.8 31.4v.4h6.97v-.4L15.3 28.4c-.29-.34-.34-.5-.34-1.03v-8.95l6.13 13.36h.71l5.26-13.36v10.64c0 .3 0 .35-.19.53l-1.85 1.8v.4h9.2v-.4l-1.83-1.8c-.18-.18-.2-.24-.2-.53V15.94c0-.3.02-.35.2-.53l1.82-1.8v-.4h-6.47l-4.62 11.55-5.2-11.54h-6.8v.4l2.15 2.63c.24.3.29.37.29.77v10.35z"></path></svg></div></a><div class="be bf r g"><svg width="2" height="29"><path d="M1 29V1" stroke="#D5D5D5" stroke-width="0.5" fill="none" stroke-linecap="round"></path></svg></div><div class="bg" id="lo-post-page-navbar-topic-copy"><a rel="noopener" href="/topic/history?source=post_page-----3522a15405ea----------------------"><div class="ap aq ar as at au av aw ax ay az ba bb">History</div></a></div></div></div><div class="r bh w"><div class="n o"><div class="n g"><div class="bg" id="lo-post-page-navbar-upsell-button"><div><a href="https://medium.com/membership?source=upgrade_membership---nav_full------------------------" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><span class="by b bz ca cb cc r cd ce">Become a member</span></a></div></div><div class="bg" id="lo-post-page-navbar-sign-in-link"><div class="cf r"><span class="by b bz ca cb cc r cd ce"><a href="https://medium.com/m/signin?operation=login&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_page-----3522a15405ea---------------------nav_reg-" class="cg ch bk bl bm bn bo bp bq br ci cj bu bv ck cl" rel="noopener">Sign in</a></span></div></div></div><div class="bg" id="lo-post-page-navbar-get-started-button"><div class="cf r"><button class="cm cn cg ch co ci cj cp br cq by b bz ca cb cc cr cs ct cu cv bu">Get started</button></div></div></div></div></div></div></div></div></nav><div class="cw al r cx am"></div><article class="meteredContent"><section class="cy cz da db ak dc ct n dd"></section><span class="r"></span><div><div class="de u df dg dh di"></div><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><div><div id="5a7b" class="dp dq ar bz dr b ds dt du dv dw dx dy"><h1 class="dr b ds dz ar"><strong class="bo">Beep Beep: The History of George Laurer and the Barcode</strong></h1></div></div><div id="6818" class="ea dq cd bz by eb ec ed ee ef eg eh ei"><h2 class="by eb ej ek cd"><strong class="bo">How a 67-cent pack of Juicy Fruit, and a guy who said no, changed the way we shopped.</strong></h2></div><div class="el"><div class="n em en eo ep"><div class="o n"><div><a rel="noopener" href="/@stokel?source=post_page-----3522a15405ea----------------------"><img alt="Chris Stokel-Walker" class="r eq er es" src="https://miro.medium.com/fit/c/96/96/0*1leymNVYve6WSQBW.jpeg" width="48" height="48"/></a></div><div class="et ak r"><div class="n"><div style="flex:1"><span class="by b bz ca cb cc r ar q"><div class="eu n o ev"><span class="by eb ew ca ax ex ey au av aw ar"><a class="bi bj bk bl bm bn bo bp bq br ez bu bv bw bx" rel="noopener" href="/@stokel?source=post_page-----3522a15405ea----------------------">Chris Stokel-Walker</a></span><div class="fa r bh h"><button class="fb ar q cn fc fd fe ff br bw fg fh fi fj fk fl cq by b bz fm fn cc cr cs ct cu cv bu">Follow</button></div></div></span></div></div><span class="by b bz ca cb cc r cd ce"><span class="by eb ew ca ax ex ey au av aw cd"><div><a class="bi bj bk bl bm bn bo bp bq br ez bu bv bw bx" rel="noopener" href="/@stokel/beep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea?source=post_page-----3522a15405ea----------------------">Dec 10</a> <!-- -->·<!-- --> <!-- -->11<!-- --> min read<span style="padding-left:4px"><svg class="star-15px_svg__svgIcon-use" width="15" height="15" viewBox="0 0 15 15" style="margin-top:-2px"><path d="M7.44 2.32c.03-.1.09-.1.12 0l1.2 3.53a.29.29 0 0 0 .26.2h3.88c.11 0 .13.04.04.1L9.8 8.33a.27.27 0 0 0-.1.29l1.2 3.53c.03.1-.01.13-.1.07l-3.14-2.18a.3.3 0 0 0-.32 0L4.2 12.22c-.1.06-.14.03-.1-.07l1.2-3.53a.27.27 0 0 0-.1-.3L2.06 6.16c-.1-.06-.07-.12.03-.12h3.89a.29.29 0 0 0 .26-.19l1.2-3.52z"></path></svg></span></div></span></span></div></div><div class="n fo fp fq fr fs ft fu fv ab"><div class="n o"><div class="fw r bh"><a href="//medium.com/p/3522a15405ea/share/twitter?source=post_actions_header---------------------------" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" target="_blank" rel="noopener"><svg width="29" height="29" class="q"><path d="M22.05 7.54a4.47 4.47 0 0 0-3.3-1.46 4.53 4.53 0 0 0-4.53 4.53c0 .35.04.7.08 1.05A12.9 12.9 0 0 1 5 6.89a5.1 5.1 0 0 0-.65 2.26c.03 1.6.83 2.99 2.02 3.79a4.3 4.3 0 0 1-2.02-.57v.08a4.55 4.55 0 0 0 3.63 4.44c-.4.08-.8.13-1.21.16l-.81-.08a4.54 4.54 0 0 0 4.2 3.15 9.56 9.56 0 0 1-5.66 1.94l-1.05-.08c2 1.27 4.38 2.02 6.94 2.02 8.3 0 12.86-6.9 12.84-12.85.02-.24 0-.43 0-.65a8.68 8.68 0 0 0 2.26-2.34c-.82.38-1.7.62-2.6.72a4.37 4.37 0 0 0 1.95-2.51c-.84.53-1.81.9-2.83 1.13z"></path></svg></a></div><div class="fw r bh"><a href="//medium.com/p/3522a15405ea/share/facebook?source=post_actions_header---------------------------" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" target="_blank" rel="noopener"><svg width="29" height="29" class="q"><path d="M23.2 5H5.8a.8.8 0 0 0-.8.8V23.2c0 .44.35.8.8.8h9.3v-7.13h-2.38V13.9h2.38v-2.38c0-2.45 1.55-3.66 3.74-3.66 1.05 0 1.95.08 2.2.11v2.57h-1.5c-1.2 0-1.48.57-1.48 1.4v1.96h2.97l-.6 2.97h-2.37l.05 7.12h5.1a.8.8 0 0 0 .79-.8V5.8a.8.8 0 0 0-.8-.79"></path></svg></a></div><div class="fx r ao"><div><div class="cu" role="tooltip" aria-hidden="true"><a href="https://medium.com/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_actions_header--------------------------bookmark_sidebar-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><svg width="25" height="25" viewBox="0 0 25 25"><path d="M19 6a2 2 0 0 0-2-2H8a2 2 0 0 0-2 2v14.66h.01c.01.1.05.2.12.28a.5.5 0 0 0 .7.03l5.67-4.12 5.66 4.13a.5.5 0 0 0 .71-.03.5.5 0 0 0 .12-.29H19V6zm-6.84 9.97L7 19.64V6a1 1 0 0 1 1-1h9a1 1 0 0 1 1 1v13.64l-5.16-3.67a.49.49 0 0 0-.68 0z" fill-rule="evenodd"></path></svg></a></div></div></div></div></div></div></div><figure class="fz ga gb gc gd ge da db paragraph-image"><div class="gf gg gh gi ak"><div class="da db fy"><div class="go r gh gp"><div class="gq r"><div class="gj gk de t u gl ak ax gm gn"><img class="de t u gl ak gr gs gt" src="https://miro.medium.com/max/60/1*XqdcvabbiEpyJehoTXxCSg.jpeg?q=20" width="1500" height="900" role="presentation"/></div><img class="gj gk de t u gl ak gu" width="1500" height="900" role="presentation"/><noscript><img class="de t u gl ak" src="https://miro.medium.com/max/3000/1*XqdcvabbiEpyJehoTXxCSg.jpeg" width="1500" height="900" role="presentation"/></noscript></div></div></div></div><figcaption class="cd ew gv gw gx dc da db gy gz by eb">Image credit: Wikipedia/Chris Stokel-Walker</figcaption></figure><p id="87e1" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn"><strong class="hc ho"><em class="hp">Author’s note: </em></strong>This story was initially reported out in 2014 but was not published. It’s released here today in memory of Laurer, who <a href="https://www.bbc.co.uk/news/world-us-canada-50726950" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow">died today</a>, aged 94.</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="4644" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">H</span>istory<strong class="hc ho"> </strong>was made, and it cost 67 cents.</p><p id="1c96" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Forty-five years ago Clyde Dawson handed over a 10-pack of Wrigley’s Juicy Fruit chewing gum to checkout clerk Sharon Buchanan in the Marsh Supermarket in Troy, OH. It had just gone 8am. Dawson wasn’t any ordinary shopper — he was Marsh’s director of research and development — and this wasn’t any ordinary day.</p><p id="4383" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">This was the first time the UPC barcode — the small black-and-white label we see on all the items we buy from stores — had been used in a commercial environment. Clyde Dawson was asked a year later whether he felt the implementation of barcode scanning in his stores was beneficial.</p><p id="fa0e" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“Decidedly yes,” he said. “For a 14-item order, the manual system handles 45 customers per hour; the scanning system 51 — a 13% improvement in throughput.” It might not have been the most impassioned answer, but Dawson was prescient. Four decades on, barcodes dominate our lives. A 67 cent packet of gum has ballooned into an enormous industry, and five billion barcodes are scanned each and every day.</p><p id="2125" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">But how did we get to this point, and who was responsible for the UPC barcode?</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="a9cd" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">W</span>ere it not for a radio and TV repair instructor called Mr Kuttlechuck, George Laurer would likely have ended up a ne’er-do-well.</p><p id="3615" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“At times I wasn’t the upright teenager I should’ve been,” Laurer admits. While in his freshman year at Forest Park High School in Baltimore, MD, Laurer contracted polio, taking him out of the regular classroom routine for nearly two years. When he did return, World War II interrupted his education again.</p><p id="eefd" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">When Laurer returned from war, he joined a radio and TV school. After a year tinkering with the electrics of TV and radio sets, Kuttlechuck took Laurer aside, and told him he should go to college. Kuttlechuck pulled a few strings, and Laurer joined the engineering school at the University of Maryland.</p><p id="8ab1" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">In 1951 Laurer graduated into a tough job market. With a friend, he set off on a trip along the east coast to apply for work at the country’s biggest and brightest engineering companies: RCA, General Electric and IBM. Laurer, who had been offered a job before graduation with the U.S. Navy Electronics Laboratory that was withdrawn before he could turn up for work, was determined to accept any fair offer. When IBM officials at Endicott, NY offered him $80 a week, he accepted, and began his tenure at the company.</p><p id="394f" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">While Laurer worked his way through college and into IBM, another engineer was first forming thoughts about a means through which items could be classified and recorded. On October 20, 1949 Bernard Silver and Norman Joseph (“Joe”) Woodland — who would later work at IBM with Laurer — submitted patent application 122,416: ‘Classifying Apparatus and Method.’</p><p id="e78c" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">The nine-page<a href="http://www.google.co.uk/patents/US2612994" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow"> document</a> was granted patent number 2,612,994 just shy of three years later, and in it Woodland and Silver outlined the rudimentary design of a barcode-like system. “One application of the invention,” they wrote, “is in the so-called super-market field.”</p><p id="9b0e" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">By this point Woodland, like Laurer, was employed by IBM, who passed on the concept for which their engineer held the patent. Woodland’s conception of the barcode — a series of concentric circles in a ‘bullseye’ formation — ended up in the hands of engineers at RCA, one of IBM’s main competitors, in 1952. Both Laurer and Woodland occupied themselves with other projects.</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="0127" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">S</span>upermarkets realized the benefits of computerized categorisation of their products soon after Woodland and Silver’s patent was granted. By the mid-1960s, brash bold futurism and the first inklings of a modern society meant supermarkets stretched across the country, replacing simple and small grocery stores. The average store offered around 10,000 products up for sale; overall a million different items were sold at supermarkets across the United States. It became a headache for retailers.</p><p id="0931" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“There had to be an industry solution,” explains Bill Selmeier, who was part of IBM’s supermarket marketing team in the early 1970s, and now runs <a href="http://www.idhistory.com" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow">IDHistory</a>, an online museum dedicated to the UPC barcode. In 1966 supermarkets like the Kroger company, at the time the U.S.’ third-largest retailer, and Heinz, a major food manufacturer,<a href="http://www.cummingsdesign.com/bar_codes101_UCC_History.htm" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow"> took the lead</a> in trying to automate the supermarket checkout experience.</p><p id="eb50" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">A Symbol Selection subcommittee was established in 1970 to find the best design for the UPC barcode. They set up an open competition, and invited companies to submit options for potential designs.</p><p id="dd30" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">At the time Laurer lived on Oak Park Road, a single-lane road lined with pine trees about a 15 minute drive outside of downtown Raleigh, NC. The neighborhood was collegial, with many IBM staff members living with their families in nearby houses.</p><p id="7cd5" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">One of Laurer’s neighbors, living across the road and a few houses up, was his direct boss, Paul McEnroe. McEnroe had booked a two-week vacation away with his family.</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="e123" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">I</span>BM was invited to submit a proposal, or at least to back a pre-existing option, of which there were many. RCA’s design for the barcode Symbol Selection Committee, a mark similar to that in Joe Woodland’s patent RCA had bought, passed over McEnroe’s desk, who palmed off its approval to Laurer, asking him to take the fortnight to produce a slide deck in preparation for his return.</p><p id="99e6" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“I just couldn’t do that,” he says, gruffly. “I didn’t know if I could do better or not, but one thing was certain: I could not support something I didn’t believe in. It didn’t matter if I could come up with another code, or a better code, or if any code could be done to fit it. Just my training and my background would not let me support something I did not fully agree with.”</p><p id="4bf8" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">It was a demeanor he got from his father, who turned down a career in New York law after going to college and passing the bar because he said “I can’t work with these crooks.” Laurer Sr went back to school and retrained — as an electrical engineer.</p><p id="6e72" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“We were a bunch of mavericks, believe me,” Laurer laughs.</p><p id="ed93" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">That flicker of feistiness was fanned by IBM’s working atmosphere: the company encouraged productive individualism, believes Bill Selmeier.</p><p id="8de1" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“George was an engineer. He wasn’t really trying to understand the way grocery manufacturers were thinking or how they’d react to this,” he says.</p><p id="b0b9" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Laurer instead saw the problem, and wanted to find a solution. He believed the circular design would not print crisply on contemporary commercial printers, many of which dated back to the early 20th century. He believed the lines were too close together. So he came up with an alternative.</p><p id="f24a" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">When Paul McEnroe, Laurer’s boss, returned from his vacation the day before the presentation to IBM bosses, he was greeted with some unfortunate news.</p><p id="4952" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“I said, ‘Paul, you’d better look at this because I didn’t do what you told me to do. I’ve done something entirely different.’”</p><p id="b6d5" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Laurer and McEnroe spent the rest of the day talking through the details of Laurer’s UPC proposal. Rather than write a white paper approving RCA’s bullseye barcode, Laurer had spent the past 14 days coming up with a proposal of his own: a linear barcode that met the requirements put forth by the supermarkets’ and manufacturers’ council, and also solved the problems of smudging and scale he saw with everyone else’s designs.</p><p id="5e32" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">McEnroe accepted Laurer’s proposal with one caveat: Laurer would make the presentation to IBM higherups the following day, and if the proposal didn’t fly, it would be his responsibility.</p><p id="51fa" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Aided by an easel full of flipcharts drawn by Laurer’s 15-year-old son, Craig, the proposal to IBM bosses went smoothly, but probing by IBM staff in Rochester, MN specialising in optical character reading highlighted some deficiencies that were ironed out before IBM’s proposal for a UPC barcode was presented to the committee of retailers and manufacturers in San Francisco, CA in January 1973.</p><p id="e7a8" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Laurer worked closely with two other men to make the IBM UPC design presentable. One, David Savir, ran through the system’s mathematics with a fine-tooth comb and produced dense operating manuals explaining the science behind UPC scanning and coding.</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="c88b" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">T</span>he team’s other principal actor was a recognisable face in the world of barcodes: Joe Woodland. The creator of the 1949 patent mentioning potential for the supermarket industry worked in the same office in IBM’s Raleigh, NC-based Building 602, a long, cavernous workshop the company leased on Yonkers Road, to the north-east of the city.</p><p id="7cba" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Woodland, by this point in his early 50s, was widely respected by all those involved in the UPC project. He was seen as the strategist of the IBM team, and gave them a distinct advantage: IBM could credibly claim lineage in barcode development all the way back to 1949 — conveniently overlooking the fact that they’d turned down the option to buy and develop Woodland’s original patent in 1952.</p><p id="b1e3" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">The group made their way to San Francisco and put forward their proposal to the assembled retailers and manufacturers.</p><p id="0b52" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“When it was over, the Symbol Selection Committee felt the IBM proposal was the strongest,” explains Bill Selmeier. “I’ve been told it was based on the fact that it met all issues about printing, and it had the densest information pack. In other words, you could get more characters in less space with IBM’s proposal than with the other ones” — an important consideration for retailers who weren’t keen to give up prime real estate on the front of their packaging.</p><p id="16ce" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">The industry now had a unified symbol it could throw its weight behind, the end result of a process first initiated in 1966. The excitement over the new system was palpable. A trade rag, the UPC Newsletter,<a href="http://www.idhistory.com/upcnewsletter/upcN1973-11.pdf" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow"> wrote in November 1973</a> that “The Universal Product Code, the symbol, and now — closing the loop — the electronic and scanning equipment! It’s all here. It now remains for all of us to move as expeditiously as possible toward full implementation of the system.”</p><p id="40a6" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">John L Strubbe, a 22-year veteran of Kroger Supermarkets who had<a href="http://www.cincinnatichamber.com/About-the-Chamber/Awards-and-Recognition/GLC/Strubbe,-1986.aspx#.U5rNxXbLO5o" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow"> served</a> as an intelligence officer with the US Marine Corps during World War II and the Korean War,<a href="http://www.idhistory.com/upcnewsletter/upcN1973-12.pdf" class="bi cv hq hr hs ht" target="_blank" rel="noopener nofollow"> spoke</a> at the Harris Trust and Savings Bank in Chicago, IL on November 15, 1973, his first act as the newly-elected chairman of the Uniform Grocery Product Code Council (UGPCC). 15 council members were gathered around him, looking forward to the year ahead in which Strubbe said there was “only one end result in mind: making a great concept work.”</p><p id="4a68" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">By the end of the year, the UGPCC had 800 members, whose companies accounted for nearly 90% of grocery sales excluding meat and fresh produce. But uptake of the UPC symbol itself was slow, even if companies were signing up to its code council. “There was the chicken and the egg problem,” says Laurer.</p><p id="234f" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“The retailers were waiting for the manufacturers” to put the newly-approved UPC symbol, as designed by the IBM team, on the products they sold, says Selmeier. “Well guess what? The manufacturers were waiting for the retailers.”</p><p id="68f4" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Laurer continues: “The grocers didn’t want to spend money for scanners” — which could cost [$200,000] per unit for stores — “until there were symbols on products. And the manufacturers didn’t want to put symbols on the packages until there was something to read them.”</p><p id="aa45" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">At the same time angry workers strongly opposed barcodes. A skeptical Congressional committee brought supermarket representatives in front of them to testify about the efficacy of the new system. A worried public didn’t trust the system, and fretted they’d be bilked on their weekly shopping bills. Academics at MIT believed barcodes were a flash in the pan that would soon be replaced by optical character recognition. But slowly, surely, the barcode became normal — and took over the world, starting at Marsh’s supermarket in Troy, OH.</p><p id="1841" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“I’ve often said the most important thing the UPC did was to show the world that barcodes were viable, “says Laurer. “After that, there are hundreds of other barcodes in existence today. The automobile VIN code, anyplace you look you’ll see other barcodes,” he adds. “The thing the UPC did was show the world that yes, barcodes are here to stay.”</p></div></div></section><hr class="hu eb hv hw hx gx hy hz ia ib ic"/><section class="dj dk dl dm dn"><div class="n p"><div class="ac ae af ag ah do aj ak"><p id="018c" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn id"><span class="r ie if ig ih ii ij ik il im gh">T</span>oday, the blue-suited IBMer wearing the wide lapels and big-rimmed glasses is an 88-year-old widower living in 50 acres of farmland outside of Wendell, NC. When I first call him on a sunny Wednesday afternoon he picks up the phone immediately: he’d been sat waiting for my call because, as he admitted in a prior email, sometimes it takes him so long to reach the telephone he misses calls entirely.</p><p id="3bd5" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Truth be told, Laurer didn’t really want to talk over the phone. Age has made him hard of hearing: my British accent combined with a transatlantic line means he can’t understand some of my shouted questions. Those he does hear, he tends to reconfirm by saying, “What I think you asked is…” and giving a precis of the query back at you. Only when I say “yes” does he launch into his answers.</p><p id="67a0" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Laurer has been retired for the best part of 26 years, but still engages with engineering today. His latest ongoing project takes up a section of the couple of acres in front of his home in Raleigh: he’s building a solar array with his grandson to measure how efficient present-day solar cells are in converting the power of the sun into energy. “I enjoy learning; I don’t know,” he says quizzically. “I just like that kind of stuff.”</p><p id="01ed" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">For 13 years following his retirement, he and his wife, Marilyn, would travel each summer around the United States, Mexico and Canada in their motorhome. Whenever they would pop into grocery stores, supermarkets or gas stations, Laurer’s wife would regularly smile and wink at cashiers and attendants, pointing out her husband invented the barcode they were scanning — and the concept behind the scanner machine, too.</p><p id="4f28" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“She pointed it out all the time,” Laurer says with a laugh. “Most of the time people had one of three reactions: one was, ‘You must be very rich’; another was ‘I don’t believe it’, and the third was: ‘Gee: didn’t we always have barcodes?’”</p><p id="e48f" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Then and now, when Laurer collects his weekly grocery shop, he’s happy to see his invention in its natural environment. “Even today, Chris, I think it’s so funny, because I remember how crude our amplifiers were, and the lasers, and things of that sort. When I look at these girls in the grocery store today I just can’t believe the products scan that well. I’m always amazed.”</p><p id="290f" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">It’s something we take for granted — that the barcode system we use works. On the odd occasion it fails, assistants can be befuddled, bemoaning the fact they have to tap in the product code by hand into their cash register. But when you think about it, it’s quite amazing.</p><p id="4616" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">“You have to realize,” Bill Selmeier explains to me, “that most of these people in Building 602 didn’t think they were changing the way the world shopped. They thought they were getting IBM into a new electronics business — and they still think of it that way.”</p><p id="c817" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">Between my conversations with George Laurer I had to visit a number of stores to do some shopping: a parent’s birthday and a party meant I needed to pick up a number of things from various shops.</p><p id="ff70" class="ha hb ar bz hc b hd he hf hg hh hi hj hk hl hm hn">In IKEA I stood in a line, watching harassed fathers calming stressed-out sons while their mother scanned items through the register. Later that day, I swiped a small grocery shop through a self-service point at a huge supermarket, and in amongst the chatter of shoppers, the clatter of grocery carts, and the beeping of tills, I thought: in this moment, at this time, 40 years ago, this wasn’t possible. Four decades ago this was a concept, not a reality. I thought of typewritten technical manuals, boring ties, smart shoes, and smoke-filled meeting rooms. And I thought of George Laurer, patiently waiting by the phone, and the work he did in his freshly-pressed suit before many of us were born to make real what was then a fantasy we take for granted today.</p></div></div></section></div></article><div class="gj di in s ak io ip iq" data-test-id="post-sidebar"><div class="n p"><div class="ac ae af ag ah ai aj ak"><div class="ir n dd"><div class="di"><div class="is it iu n"><div class="n o"><div class="iv r gh"><a href="https://medium.com/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_sidebar-----3522a15405ea---------------------clap_sidebar-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><div class="bp iw ix iy iz ja jb jc jd je jf"><svg width="29" height="29"><g fill-rule="evenodd"><path d="M13.74 1l.76 2.97.76-2.97zM16.82 4.78l1.84-2.56-1.43-.47zM10.38 2.22l1.84 2.56-.41-3.03zM22.38 22.62a5.11 5.11 0 0 1-3.16 1.61l.49-.45c2.88-2.89 3.45-5.98 1.69-9.21l-1.1-1.94-.96-2.02c-.31-.67-.23-1.18.25-1.55a.84.84 0 0 1 .66-.16c.34.05.66.28.88.6l2.85 5.02c1.18 1.97 1.38 5.12-1.6 8.1M9.1 22.1l-5.02-5.02a1 1 0 0 1 .7-1.7 1 1 0 0 1 .72.3l2.6 2.6a.44.44 0 0 0 .63-.62L6.1 15.04l-1.75-1.75a1 1 0 1 1 1.41-1.41l4.15 4.15a.44.44 0 0 0 .63 0 .44.44 0 0 0 0-.62L6.4 11.26l-1.18-1.18a1 1 0 0 1 0-1.4 1.02 1.02 0 0 1 1.41 0l1.18 1.16L11.96 14a.44.44 0 0 0 .62 0 .44.44 0 0 0 0-.63L8.43 9.22a.99.99 0 0 1-.3-.7.99.99 0 0 1 .3-.7 1 1 0 0 1 1.41 0l7 6.98a.44.44 0 0 0 .7-.5l-1.35-2.85c-.31-.68-.23-1.19.25-1.56a.85.85 0 0 1 .66-.16c.34.06.66.28.88.6L20.63 15c1.57 2.88 1.07 5.54-1.55 8.16a5.62 5.62 0 0 1-5.06 1.65 9.35 9.35 0 0 1-4.93-2.72zM13 6.98l2.56 2.56c-.5.6-.56 1.41-.15 2.28l.26.56-4.25-4.25a.98.98 0 0 1-.12-.45 1 1 0 0 1 .29-.7 1.02 1.02 0 0 1 1.41 0zm8.89 2.06c-.38-.56-.9-.92-1.49-1.01a1.74 1.74 0 0 0-1.34.33c-.38.29-.61.65-.71 1.06a2.1 2.1 0 0 0-1.1-.56 1.78 1.78 0 0 0-.99.13l-2.64-2.64a1.88 1.88 0 0 0-2.65 0 1.86 1.86 0 0 0-.48.85 1.89 1.89 0 0 0-2.67-.01 1.87 1.87 0 0 0-.5.9c-.76-.75-2-.75-2.7-.04a1.88 1.88 0 0 0 0 2.66c-.3.12-.61.29-.87.55a1.88 1.88 0 0 0 0 2.66l.62.62a1.88 1.88 0 0 0-.9 3.16l5.01 5.02c1.6 1.6 3.52 2.64 5.4 2.96a7.16 7.16 0 0 0 1.18.1c1.03 0 2-.25 2.9-.7A5.9 5.9 0 0 0 23 23.24c3.34-3.34 3.08-6.93 1.74-9.17l-2.87-5.04z"></path></g></svg></div></a></div><div class="jg r"><div class="jh"><h4 class="by eb ew ca cd"><button class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx">5 </button></h4></div></div></div></div><div><div class="cu" role="tooltip" aria-hidden="true"><a href="https://medium.com/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_sidebar--------------------------bookmark_sidebar-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><svg width="25" height="25" viewBox="0 0 25 25"><path d="M19 6a2 2 0 0 0-2-2H8a2 2 0 0 0-2 2v14.66h.01c.01.1.05.2.12.28a.5.5 0 0 0 .7.03l5.67-4.12 5.66 4.13a.5.5 0 0 0 .71-.03.5.5 0 0 0 .12-.29H19V6zm-6.84 9.97L7 19.64V6a1 1 0 0 1 1-1h9a1 1 0 0 1 1 1v13.64l-5.16-3.67a.49.49 0 0 0-.68 0z" fill-rule="evenodd"></path></svg></a></div></div></div></div></div></div></div><div class="gj di in s ji jj jk jl ip jm"></div><div><div class="jn ge n dd p"><div class="n p"><div class="ac ae af ag ah do aj ak"><div class="n jo"></div><div class="n o jo"></div><div class="jp r"><ul class="bp bq"><li class="cu jq jr js"><a href="/tag/history" class="jt ju cv cd r jv jw a b fn">History</a></li><li class="cu jq jr js"><a href="/tag/barcode" class="jt ju cv cd r jv jw a b fn">Barcode</a></li><li class="cu jq jr js"><a href="/tag/tech" class="jt ju cv cd r jv jw a b fn">Tech</a></li><li class="cu jq jr js"><a href="/tag/culture" class="jt ju cv cd r jv jw a b fn">Culture</a></li><li class="cu jq jr js"><a href="/tag/business" class="jt ju cv cd r jv jw a b fn">Business</a></li></ul></div><div class="jx n em ab"><div class="n o"><div class="jy r gh"><a href="https://medium.com/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_actions_footer-----3522a15405ea---------------------clap_footer-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><div class="c jz eq n o ka gh kb kc kd ke kf kg kh ki kj kk kl km kn ko"><div class="bp iw ix iy iz ja kp jc o gu eq n p kq u gl de t ak jd je jf kr"><svg width="33" height="33" viewBox="0 0 33 33"><path d="M28.86 17.34l-3.64-6.4c-.3-.43-.71-.73-1.16-.8a1.12 1.12 0 0 0-.9.21c-.62.5-.73 1.18-.32 2.06l1.22 2.6 1.4 2.45c2.23 4.09 1.51 8-2.15 11.66a9.6 9.6 0 0 1-.8.71 6.53 6.53 0 0 0 4.3-2.1c3.82-3.82 3.57-7.87 2.05-10.39zm-6.25 11.08c3.35-3.35 4-6.78 1.98-10.47L21.2 12c-.3-.43-.71-.72-1.16-.8a1.12 1.12 0 0 0-.9.22c-.62.49-.74 1.18-.32 2.06l1.72 3.63a.5.5 0 0 1-.81.57l-8.91-8.9a1.33 1.33 0 0 0-1.89 1.88l5.3 5.3a.5.5 0 0 1-.71.7l-5.3-5.3-1.49-1.49c-.5-.5-1.38-.5-1.88 0a1.34 1.34 0 0 0 0 1.89l1.49 1.5 5.3 5.28a.5.5 0 0 1-.36.86.5.5 0 0 1-.36-.15l-5.29-5.29a1.34 1.34 0 0 0-1.88 0 1.34 1.34 0 0 0 0 1.89l2.23 2.23L9.3 21.4a.5.5 0 0 1-.36.85.5.5 0 0 1-.35-.14l-3.32-3.33a1.33 1.33 0 0 0-1.89 0 1.32 1.32 0 0 0-.39.95c0 .35.14.69.4.94l6.39 6.4c3.53 3.53 8.86 5.3 12.82 1.35zM12.73 9.26l5.68 5.68-.49-1.04c-.52-1.1-.43-2.13.22-2.89l-3.3-3.3a1.34 1.34 0 0 0-1.88 0 1.33 1.33 0 0 0-.4.94c0 .22.07.42.17.61zm14.79 19.18a7.46 7.46 0 0 1-6.41 2.31 7.92 7.92 0 0 1-3.67.9c-3.05 0-6.12-1.63-8.36-3.88l-6.4-6.4A2.31 2.31 0 0 1 2 19.72a2.33 2.33 0 0 1 1.92-2.3l-.87-.87a2.34 2.34 0 0 1 0-3.3 2.33 2.33 0 0 1 1.24-.64l-.14-.14a2.34 2.34 0 0 1 0-3.3 2.39 2.39 0 0 1 3.3 0l.14.14a2.33 2.33 0 0 1 3.95-1.24l.09.09c.09-.42.29-.83.62-1.16a2.34 2.34 0 0 1 3.3 0l3.38 3.39a2.17 2.17 0 0 1 1.27-.17c.54.08 1.03.35 1.45.76.1-.55.41-1.03.9-1.42a2.12 2.12 0 0 1 1.67-.4 2.8 2.8 0 0 1 1.85 1.25l3.65 6.43c1.7 2.83 2.03 7.37-2.2 11.6zM13.22.48l-1.92.89 2.37 2.83-.45-3.72zm8.48.88L19.78.5l-.44 3.7 2.36-2.84zM16.5 3.3L15.48 0h2.04L16.5 3.3z" fill-rule="evenodd"></path></svg></div></div></a></div><div class="jg r"><div class="jh"><h4 class="by eb ew ca ar"><button class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx">5 claps</button></h4></div></div></div><div class="n o"><div class="fw r bh"><a href="//medium.com/p/3522a15405ea/share/twitter?source=post_actions_footer---------------------------" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" target="_blank" rel="noopener"><svg width="29" height="29" class="q"><path d="M22.05 7.54a4.47 4.47 0 0 0-3.3-1.46 4.53 4.53 0 0 0-4.53 4.53c0 .35.04.7.08 1.05A12.9 12.9 0 0 1 5 6.89a5.1 5.1 0 0 0-.65 2.26c.03 1.6.83 2.99 2.02 3.79a4.3 4.3 0 0 1-2.02-.57v.08a4.55 4.55 0 0 0 3.63 4.44c-.4.08-.8.13-1.21.16l-.81-.08a4.54 4.54 0 0 0 4.2 3.15 9.56 9.56 0 0 1-5.66 1.94l-1.05-.08c2 1.27 4.38 2.02 6.94 2.02 8.3 0 12.86-6.9 12.84-12.85.02-.24 0-.43 0-.65a8.68 8.68 0 0 0 2.26-2.34c-.82.38-1.7.62-2.6.72a4.37 4.37 0 0 0 1.95-2.51c-.84.53-1.81.9-2.83 1.13z"></path></svg></a></div><div class="fw r bh"><a href="//medium.com/p/3522a15405ea/share/facebook?source=post_actions_footer---------------------------" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" target="_blank" rel="noopener"><svg width="29" height="29" class="q"><path d="M23.2 5H5.8a.8.8 0 0 0-.8.8V23.2c0 .44.35.8.8.8h9.3v-7.13h-2.38V13.9h2.38v-2.38c0-2.45 1.55-3.66 3.74-3.66 1.05 0 1.95.08 2.2.11v2.57h-1.5c-1.2 0-1.48.57-1.48 1.4v1.96h2.97l-.6 2.97h-2.37l.05 7.12h5.1a.8.8 0 0 0 .79-.8V5.8a.8.8 0 0 0-.8-.79"></path></svg></a></div><div class="fw r bh"><div><div class="cu" role="tooltip" aria-hidden="true"><a href="https://medium.com/m/signin?operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2F%40stokel%2Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea&amp;source=post_actions_footer--------------------------bookmark_sidebar-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><svg width="25" height="25" viewBox="0 0 25 25"><path d="M19 6a2 2 0 0 0-2-2H8a2 2 0 0 0-2 2v14.66h.01c.01.1.05.2.12.28a.5.5 0 0 0 .7.03l5.67-4.12 5.66 4.13a.5.5 0 0 0 .71-.03.5.5 0 0 0 .12-.29H19V6zm-6.84 9.97L7 19.64V6a1 1 0 0 1 1-1h9a1 1 0 0 1 1 1v13.64l-5.16-3.67a.49.49 0 0 0-.68 0z" fill-rule="evenodd"></path></svg></a></div></div></div><div class="cu" aria-hidden="true"><div class="r bh"><button class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx"><svg width="25" height="25" viewBox="-480.5 272.5 21 21" class="q"><path d="M-463 284.6c.9 0 1.6-.7 1.6-1.6s-.7-1.6-1.6-1.6-1.6.7-1.6 1.6.7 1.6 1.6 1.6zm0 .9c-1.4 0-2.5-1.1-2.5-2.5s1.1-2.5 2.5-2.5 2.5 1.1 2.5 2.5-1.1 2.5-2.5 2.5zm-7-.9c.9 0 1.6-.7 1.6-1.6s-.7-1.6-1.6-1.6-1.6.7-1.6 1.6.7 1.6 1.6 1.6zm0 .9c-1.4 0-2.5-1.1-2.5-2.5s1.1-2.5 2.5-2.5 2.5 1.1 2.5 2.5-1.1 2.5-2.5 2.5zm-7-.9c.9 0 1.6-.7 1.6-1.6s-.7-1.6-1.6-1.6-1.6.7-1.6 1.6.7 1.6 1.6 1.6zm0 .9c-1.4 0-2.5-1.1-2.5-2.5s1.1-2.5 2.5-2.5 2.5 1.1 2.5 2.5-1.1 2.5-2.5 2.5z"></path></svg></button></div></div></div></div><div class="ks kt ku jp r ab"><div class="kv kw r gh"><span class="r kx an ky"><div class="r de kz la"><a rel="noopener" href="/@stokel?source=follow_footer--------------------------follow_footer-"><img alt="Chris Stokel-Walker" class="r eq lb lc" src="https://miro.medium.com/fit/c/160/160/0*1leymNVYve6WSQBW.jpeg" width="80" height="80"/></a></div><span class="r"><div class="ld r le"><p class="by eb fn ca cd lf lg">Written by</p></div><div class="ld lh n le"><div class="ak n o em"><h2 class="by li hv lj ar"><a class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener" href="/@stokel?source=follow_footer--------------------------follow_footer-">Chris Stokel-Walker</a></h2><div class="r g"><button class="lk ar q cn fc fd fe ff br bw fg fh fi fj fk fl cq by b bz ca cb cc cr cs ct cu cv bu">Follow</button></div></div></div></span></span><div class="ld ll r le bd"><div class="lm r"><h4 class="by eb ln lo cd">UK-based freelancer for The Guardian, The Economist, BuzzFeed News, the BBC and more. Tell me your story, or get me to write for you: stokel@gmail.com</h4></div><div class="bc lp bd"><button class="lk ar q cn fc fd fe ff br bw fg fh fi fj fk fl cq by b bz ca cb cc cr cs ct cu cv bu">Follow</button></div></div></div></div><div class="lq kt r ab"><a href="https://medium.com/p/3522a15405ea/responses/show?source=follow_footer--------------------------follow_footer-" class="bi bj bk bl bm bn bo bp bq br bs bt bu bv bw bx" rel="noopener"><span class="lr ls iz"><div class="lt lu cq r gx g"><span class="cg">Write the first response</span></div></span></a></div></div></div><div class="lv r lw ab"><div class="n p"><div class="ac ae af ag ah ai aj ak"></div></div></div></div></div><div class="lx r ly lz"><section class="da db ak ct r ma mb mc md me mf mg mh mi mj mk ml mm mn mo"><div class="mp mq kv n em g"><div class="mr n em"><div class="ms r mt"><div class="mu r"><a href="https://medium.com/about?autoplay=1&amp;source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br mv mw bu bv mx my" rel="noopener"><h4 class="mz na nb by li bz lo nc nd r">Discover <!-- -->Medium</h4></a></div><span class="by b bz ca cb cc r ne nf">Welcome to a place where words matter. On <!-- -->Medium<!-- -->, smart voices and original ideas take center stage - with no ads in sight.<!-- --> <a href="https://medium.com/about?autoplay=1&amp;source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br bu bv mx my ng" rel="noopener">Watch</a></span></div><div class="ms r mt"><div class="nh r"><a href="https://medium.com/topics?source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br mv mw bu bv mx my" rel="noopener"><h4 class="mz na nb by li bz lo nc nd r">Make <!-- -->Medium<!-- --> yours</h4></a></div><span class="by b bz ca cb cc r ne nf">Follow all the topics you care about, and we’ll deliver the best stories for you to your homepage and inbox.<!-- --> <a href="https://medium.com/topics?source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br bu bv mx my ng" rel="noopener">Explore</a></span></div><div class="ms r mt"><div class="mu r"><a href="https://medium.com/membership?source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br mv mw bu bv mx my" rel="noopener"><h4 class="mz na nb by li bz lo nc nd r">Become a member</h4></a></div><span class="by b bz ca cb cc r ne nf">Get unlimited access to the best stories on <!-- -->Medium<!-- --> — and support writers while you’re at it. Just $5/month.<!-- --> <a href="https://medium.com/membership?source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br bu bv mx my ng" rel="noopener">Upgrade</a></span></div></div></div><div class="n o em"><a class="bi bj bk bl bm bn bo bp bq br mv mw bu bv mx my" rel="noopener" href="/?source=post_page-----3522a15405ea----------------------"><svg height="22" width="112" viewBox="0 0 111.5 22" class="na"><path d="M56.3 19.5c0 .4 0 .5.3.7l1.5 1.4v.1h-6.5V19c-.7 1.8-2.4 3-4.3 3-3.3 0-5.8-2.6-5.8-7.5 0-4.5 2.6-7.6 6.3-7.6 1.6-.1 3.1.8 3.8 2.4V3.2c0-.3-.1-.6-.3-.7l-1.4-1.4V1l6.5-.8v19.3zm-4.8-.8V9.5c-.5-.6-1.2-.9-1.9-.9-1.6 0-3.1 1.4-3.1 5.7 0 4 1.3 5.4 3 5.4.8.1 1.6-.3 2-1zm9.1 3.1V9.4c0-.3-.1-.6-.3-.7l-1.4-1.5v-.1h6.5v12.5c0 .4 0 .5.3.7l1.4 1.4v.1h-6.5zm-.2-19.2C60.4 1.2 61.5 0 63 0c1.4 0 2.6 1.2 2.6 2.6S64.4 5.3 63 5.3a2.6 2.6 0 0 1-2.6-2.7zm22.5 16.9c0 .4 0 .5.3.7l1.5 1.4v.1h-6.5v-3.2c-.6 2-2.4 3.4-4.5 3.4-2.9 0-4.4-2.1-4.4-6.2 0-1.9 0-4.1.1-6.5 0-.3-.1-.5-.3-.7L67.7 7v.1H74v8c0 2.6.4 4.4 2 4.4.9-.1 1.7-.6 2.1-1.3V9.5c0-.3-.1-.6-.3-.7l-1.4-1.5v-.2h6.5v12.4zm22 2.3c0-.5.1-6.5.1-7.9 0-2.6-.4-4.5-2.2-4.5-.9 0-1.8.5-2.3 1.3.2.8.3 1.7.3 2.5 0 1.8-.1 4.2-.1 6.5 0 .3.1.5.3.7l1.5 1.4v.1H96c0-.4.1-6.5.1-7.9 0-2.7-.4-4.5-2.2-4.5-.9 0-1.7.5-2.2 1.3v9c0 .4 0 .5.3.7l1.4 1.4v.1h-6.5V9.5c0-.3-.1-.6-.3-.7l-1.4-1.5v-.2h6.5v3.1a4.6 4.6 0 0 1 4.6-3.4c2.2 0 3.6 1.2 4.2 3.5.7-2.1 2.7-3.6 4.9-3.5 2.9 0 4.5 2.2 4.5 6.2 0 1.9-.1 4.2-.1 6.5-.1.3.1.6.3.7l1.4 1.4v.1h-6.6zm-81.4-2l1.9 1.9v.1h-9.8v-.1l2-1.9c.2-.2.3-.4.3-.7V7.3c0-.5 0-1.2.1-1.8L11.4 22h-.1L4.5 6.8c-.1-.4-.2-.4-.3-.6v10c-.1.7 0 1.3.3 1.9l2.7 3.6v.1H0v-.1L2.7 18c.3-.6.4-1.3.3-1.9v-11c0-.5-.1-1.1-.5-1.5L.7 1.1V1h7l5.8 12.9L18.6 1h6.8v.1l-1.9 2.2c-.2.2-.3.5-.3.7v15.2c0 .2.1.5.3.6zm7.6-5.9c0 3.8 1.9 5.3 4.2 5.3 1.9.1 3.6-1 4.4-2.7h.1c-.8 3.7-3.1 5.5-6.5 5.5-3.7 0-7.2-2.2-7.2-7.4 0-5.5 3.5-7.6 7.3-7.6 3.1 0 6.4 1.5 6.4 6.2v.8h-8.7zm0-.8h4.3v-.8c0-3.9-.8-4.9-2-4.9-1.4.1-2.3 1.6-2.3 5.7z"></path></svg></a><span class="by b bz ca cb cc r ne nf"><div class="ni nj n em nk an"><a href="https://medium.com/about?autoplay=1&amp;source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br ez bu bv mx my" rel="noopener">About</a><a href="https://help.medium.com/?source=post_page-----3522a15405ea----------------------" class="bi bj bk bl bm bn bo bp bq br ez bu bv mx my" rel="noopener">Help</a><a class="bi bj bk bl bm bn bo bp bq br ez bu bv mx my" rel="noopener" href="/policy/9db0094a1e0f?source=post_page-----3522a15405ea----------------------">Legal</a></div></span></div></section></div></div></div><script src="https://cdn.optimizely.com/js/16180790160.js"></script><script>window.__BUILD_ID__ = "development"</script><script>window.__GRAPHQL_URI__ = "https://medium.com/_/graphql"</script><script>window.__PRELOADED_STATE__ = {"config":{"nodeEnv":"production","version":"master-20191210-195213-424ca21f17","productName":"Medium","publicUrl":"https:\u002F\u002Fcdn-client.medium.com\u002Flite","authDomain":"medium.com","authGoogleClientId":"216296035834-k1k6qe060s2tp2a2jam4ljdcms00sttg.apps.googleusercontent.com","favicon":"production","glyphUrl":"https:\u002F\u002Fglyph.medium.com","branchKey":"key_live_ofxXr2qTrrU9NqURK8ZwEhknBxiI6KBm","lightStep":{"name":"lite-web","host":"collector-medium.lightstep.com","token":"ce5be895bef60919541332990ac9fef2","appVersion":"master-20191210-195213-424ca21f17"},"algolia":{"appId":"MQ57UUUQZ2","apiKeySearch":"394474ced050e3911ae2249ecc774921","indexPrefix":"medium_","host":"-dsn.algolia.net"},"recaptchaKey":"6Lfc37IUAAAAAKGGtC6rLS13R1Hrw_BqADfS1LRk","sentry":{"dsn":"https:\u002F\u002F589e367c28ca47b195ce200d1507d18b@sentry.io\u002F1423575","environment":"production"},"isAmp":false,"googleAnalyticsCode":"UA-24232453-2","signInWallCustomDomainCollectionIds":["3a8144eabfe3","336d898217ee","61061eb0c96b","138adf9c44c","819cc2aaeee0"],"mediumOwnedAndOperatedCollectionIds":["544c7006046e","bcc38c8f6edf","444d13b52878","8d6b8a439e32","92d2092dc598","1285ba81cada","cb8577c9149e","8ccfed20cbb2","ae2a65f35510","3f6ecf56618","7b6769f2748b","fc8964313712","ef8e90590e66","191186aaafa0","d944778ce714","bdc4052bbdba","88d9857e584e"],"tierOneDomains":["medium.com","thebolditalic.com","arcdigital.media","towardsdatascience.com","uxdesign.cc","codeburst.io","psiloveyou.xyz","writingcooperative.com","entrepreneurshandbook.co","prototypr.io","betterhumans.coach.me","theascent.pub"]},"debug":{"requestId":"2f21e275-04c7-4e2b-9343-cc37b30b19d7","originalSpanCarrier":{"ot-tracer-spanid":"7ef054033d302dc6","ot-tracer-traceid":"2852fbc81e9e8814","ot-tracer-sampled":"true"}},"session":{"user":{"id":"lo_oJtk80EZaZuf"},"xsrf":""},"stats":{"itemCount":0,"sending":false,"timeout":null,"backup":{}},"navigation":{"showBranchBanner":null,"hasRenderedBranchBanner":null,"hideGoogleOneTap":false,"hideAlternateUser":false,"branchData":{"loaded":false},"currentLocation":"https:\u002F\u002Fmedium.com\u002F@stokel\u002Fbeep-beep-the-history-of-george-laurer-and-the-barcode-3522a15405ea","host":"medium.com","hostname":"medium.com","susiModal":{"step":null,"operation":"register","reportEventInfo":{"eventName":"","data":{}}}},"client":{"isBot":false,"isEu":false,"isNativeMedium":false,"isCustomDomain":false},"multiVote":{"clapsPerPost":{}},"metadata":{"faviconImageId":null}}</script><script>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</script><script src="https://cdn-client.medium.com/lite/static/js/manifest.643d461d.js"></script><script src="https://cdn-client.medium.com/lite/static/js/vendors~main.51281d83.chunk.js"></script><script src="https://cdn-client.medium.com/lite/static/js/main.a3bf722c.chunk.js"></script><script src="https://cdn-client.medium.com/lite/static/js/vendors~screen.collection.packageBuilder~screen.landingpages.pres45~screen.landingpages.tribute~scre~3e410f11.d2f0cb5c.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/screen.collection.packageBuilder~screen.landingpages.pres45~screen.landingpages.tribute~screen.post~~4767c889.ddfb0e02.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/screen.collection.packageBuilder~screen.landingpages.pres45~screen.landingpages.tribute~screen.post~~73c4bb05.1ff1b026.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/screen.post~screen.post.amp~screen.profile~screen.sequence.library~screen.sequence.post~screen.stori~aba94ffa.f795aa9f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/screen.post.bcb191c0.chunk.js"></script><script>window.main();</script></body></html>