Installation failed, reverting ./composer.json to its original content.

Installing valet

composer global require laravel/valet

I got this:

Installation failed, reverting ./composer.json to its original content.

to fix:

  • remove ./composer/cache folder
  • run composer global update

source: https://laracasts.com/discuss/channels/laravel/composer-conflict-when-installing-valet

Like what you read? Give wotan a round of applause.

From a quick cheer to a standing ovation, clap to show how much you enjoyed this story.