Getting started with UVa Online Judge

What is uva online judge after all ?

Ashish Patel
Codebrace
3 min readOct 18, 2016

--

UVa Online Judge is an online automated judge for programming problems like Codechef, Hackerrank etc.
but is one of the most used online judge.

The registration is open to all users and free. A user may submit a solution in C, C++, Java etc. You just have to get yourself registered at the site .

Solving a problem on the UVa Online Judge is same as all other judges but there are some things which are great about it, like

  • you can debug your code using udebug , you just need to enter your output for some problem for given input
    then it will compare your output with accepted code’s output so that you may be able to figure out tricky cases which may not letting your code to get AC
  • you can use uhunt to monitor your performance , it will also suggest you which problem to solve next according to your previous solved problems

Getting started : A step-by-step approach

Lets get started with an easy question ? . I have selected the problem at the uva called Back to High School Physics . It is indeed an easy problem . Go through the question , use sample input and sample output section to see what they really need . Once you get a feeling of what to do , try finding out the formula (the so called “algorithm” for this problem) . Think hard if you don’t get it ,

  • search for solution on internet but i will suggest you to solve only those problems which has been posted on
    CodeBrace, so that if you got stuck you can get the Hint.
  • for this go to category on CodeBrace and solve problems reverse Chronologically, so that you face easier problems first.

SOLUTION-

after thinking a little bit we came up with this solution , now let’s go to uva to submit this.

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

#include<stdio.h>

intmain()

{

long int v,t,s;

while(scanf("%ld%ld",&v,&t)==2){

s=v*t*2;

printf("%d\n",s);

}

return 0;

}

STEPS-

  1. Log in to the uva website . Go to Quick submit on the left .
  2. Enter question number on uva site (10007 here) , choose a language (click on C for above sample code)
  3. copy-paste your code here (you may browse it as well? ) and submit your code Congratulations !!!!
  4. you have now submitted a solution at the uva site (if you get AC- accepted) .
  5. You can check the status of your submission by selecting the “My Submissions” link on the left side of the page. The “Verdict” heading will tell you if it was solved or if there was a problem (e.g. wrong answer, ran too long, crashed, too much memory was used, compile error, etc).
  6. you may also see your status at uhunt.

Now go ahead and solve some more problems !!!

Next Problem to Solve :

As there are large number of problems to be solved, you have to select problems. The best way according to me is uhunt. Just punch in your username and see the miracle. Bookmark the page, at least that’s what I did? .

Use uhunt for figuring out what problem will be easiest to find:

image

Another word of advice, the solutions for UVA are available abundantly on the net. Please do not copy, as this is not a competition!

  • First try to solve a problem by your self.
  • If you keep on getting WA’s, Try udebug to check for critical input.
  • Still a WA then read a solution, but write your own code after understanding the solution.

AC’s are heavenly, work for them! Have fun…Enjoy coding!!!

#happy_coding #codebrace

--

--

Ashish Patel
Codebrace

Big Data Engineer at Skyscanner , loves Competitive programming, Big Data.