<!doctype html><html lang="en"><head><script defer src="https://cdn.optimizely.com/js/16180790160.js"></script><title data-rh="true">How to properly archive a project | by James Read | James Read’s Code, Containers and Cloud blog | Jul, 2021 | Medium</title><meta data-rh="true" charset="utf-8"/><meta data-rh="true" name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1"/><meta data-rh="true" name="theme-color" content="#000000"/><meta data-rh="true" name="twitter:app:name:iphone" content="Medium"/><meta data-rh="true" name="twitter:app:id:iphone" content="828256236"/><meta data-rh="true" property="al:ios:app_name" content="Medium"/><meta data-rh="true" property="al:ios:app_store_id" content="828256236"/><meta data-rh="true" property="al:android:package" content="com.medium.reader"/><meta data-rh="true" property="fb:app_id" content="542599432471018"/><meta data-rh="true" property="og:site_name" content="Medium"/><meta data-rh="true" property="og:type" content="article"/><meta data-rh="true" property="article:published_time" content="2021-07-08T11:15:33.774Z"/><meta data-rh="true" name="title" content="How to properly archive a project | by James Read | James Read’s Code, Containers and Cloud blog | Jul, 2021 | Medium"/><meta data-rh="true" property="og:title" content="How to properly archive a project"/><meta data-rh="true" property="twitter:title" content="How to properly archive a project"/><meta data-rh="true" name="twitter:site" content="@jreadDOTcom"/><meta data-rh="true" name="twitter:app:url:iphone" content="medium://p/48ddbd0208f8"/><meta data-rh="true" property="al:android:url" content="medium://p/48ddbd0208f8"/><meta data-rh="true" property="al:ios:url" content="medium://p/48ddbd0208f8"/><meta data-rh="true" property="al:android:app_name" content="Medium"/><meta data-rh="true" name="description" content="How many times have you seen projects abandoned on GitHub, or internal Wikis, with no explanation, no “next steps”, no follow-up or notes? How many hundreds of hours were lost to that project, and…"/><meta data-rh="true" property="og:description" content="The TURTLES model."/><meta data-rh="true" property="twitter:description" content="The TURTLES model."/><meta data-rh="true" property="og:url" content="https://medium.com/james-reads-public-cloud-technology-blog/how-to-properly-archive-a-project-48ddbd0208f8"/><meta data-rh="true" property="al:web:url" content="https://medium.com/james-reads-public-cloud-technology-blog/how-to-properly-archive-a-project-48ddbd0208f8"/><meta data-rh="true" property="og:image" content="https://miro.medium.com/max/550/1*iFBp8me_41MFPUno2q1tDA.jpeg"/><meta data-rh="true" name="twitter:image:src" content="https://miro.medium.com/max/550/1*iFBp8me_41MFPUno2q1tDA.jpeg"/><meta data-rh="true" name="twitter:card" content="summary_large_image"/><meta data-rh="true" property="article:author" content="https://james-read.medium.com"/><meta data-rh="true" name="twitter:creator" content="@jreadDOTcom"/><meta data-rh="true" name="author" content="James Read"/><meta data-rh="true" name="robots" content="index,follow,max-image-preview:large"/><meta data-rh="true" name="referrer" content="unsafe-url"/><meta data-rh="true" name="twitter:label1" content="Reading time"/><meta data-rh="true" name="twitter:data1" content="5 min read"/><link data-rh="true" rel="search" type="application/opensearchdescription+xml" title="Medium" href="/osd.xml"/><link data-rh="true" rel="apple-touch-icon" sizes="152x152" href="https://miro.medium.com/fit/c/152/152/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="120x120" href="https://miro.medium.com/fit/c/120/120/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="76x76" href="https://miro.medium.com/fit/c/76/76/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="apple-touch-icon" sizes="60x60" href="https://miro.medium.com/fit/c/60/60/1*sHhtYhaCe2Uc3IU0IgKwIQ.png"/><link data-rh="true" rel="mask-icon" href="https://cdn-static-1.medium.com/_/fp/icons/Medium-Avatar-500x500.svg" color="#171717"/><link data-rh="true" rel="preconnect" href="https://glyph.medium.com" crossOrigin=""/><link data-rh="true" rel="preconnect" href="https://logx.optimizely.com"/><link data-rh="true" id="glyph_preload_link" rel="preload" as="style" type="text/css" href="https://glyph.medium.com/css/unbound.css"/><link data-rh="true" id="glyph_link" rel="stylesheet" type="text/css" href="https://glyph.medium.com/css/unbound.css"/><link data-rh="true" rel="author" href="https://james-read.medium.com"/><link data-rh="true" rel="canonical" href="https://medium.com/james-reads-public-cloud-technology-blog/how-to-properly-archive-a-project-48ddbd0208f8"/><link data-rh="true" rel="alternate" href="android-app://com.medium.reader/https/medium.com/p/48ddbd0208f8"/><link data-rh="true" rel="icon" href="https://miro.medium.com/1*m-R_BkNf1Qjr1YbyOIJY2w.png"/><script data-rh="true" type="application/ld+json">{"@context":"http:\u002F\u002Fschema.org","@type":"NewsArticle","image":["https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F1200\u002F1*iFBp8me_41MFPUno2q1tDA.jpeg"],"url":"https:\u002F\u002Fmedium.com\u002Fjames-reads-public-cloud-technology-blog\u002Fhow-to-properly-archive-a-project-48ddbd0208f8","dateCreated":"2021-07-08T09:54:52.816Z","datePublished":"2021-07-08T09:54:52.816Z","dateModified":"2021-07-08T11:15:42.036Z","headline":"How to properly archive a project - James Read’s Code, Containers and Cloud blog - Medium","name":"How to properly archive a project - James Read’s Code, Containers and Cloud blog - Medium","description":"How many times have you seen projects abandoned on GitHub, or internal Wikis, with no explanation, no “next steps”, no follow-up or notes? How many hundreds of hours were lost to that project, and…","identifier":"48ddbd0208f8","author":{"@type":"Person","name":"James Read","url":"https:\u002F\u002Fjames-read.medium.com"},"creator":["James Read"],"publisher":{"@type":"Organization","name":"James Read’s Code, Containers and Cloud blog","url":"https:\u002F\u002Fmedium.com\u002Fjames-reads-public-cloud-technology-blog","logo":{"@type":"ImageObject","width":72,"height":60,"url":"https:\u002F\u002Fmiro.medium.com\u002Fmax\u002F144\u002F1*6I6y2FWHSG2KcaAaaUoFaQ.png"}},"mainEntityOfPage":"https:\u002F\u002Fmedium.com\u002Fjames-reads-public-cloud-technology-blog\u002Fhow-to-properly-archive-a-project-48ddbd0208f8"}</script><link rel="preload" href="https://cdn.optimizely.com/js/16180790160.js" as="script"><style type="text/css" data-fela-rehydration="475" data-fela-type="STATIC">html{box-sizing:border-box}*, *:before, *:after{box-sizing:inherit}body{margin:0;padding:0;text-rendering:optimizeLegibility;-webkit-font-smoothing:antialiased;color:rgba(0,0,0,0.8);position:relative;min-height:100vh}h1, h2, h3, h4, h5, h6, dl, dd, ol, ul, menu, figure, blockquote, p, pre, form{margin:0}menu, ol, ul{padding:0;list-style:none;list-style-image:none}main{display:block}a{color:inherit;text-decoration:none}a, button, input{-webkit-tap-highlight-color:transparent}img, svg{vertical-align:middle}button{background:transparent;overflow:visible}button, input, optgroup, select, textarea{margin:0}:root{--reach-tabs:1;--reach-menu-button:1}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE">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</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (min-width: 1080px)">.d{display:none}.ag{margin:0 64px}.ee{font-size:48px}.ef{margin-top:0.55em}.eg{line-height:60px}.eh{letter-spacing:-0.011em}.gl{margin-left:30px}.hk{font-size:21px}.hl{margin-top:2em}.hm{line-height:32px}.hn{letter-spacing:-0.003em}.hu{margin-top:56px}.it{font-size:30px}.iu{margin-top:1.95em}.iv{line-height:36px}.iw{letter-spacing:0}.jc{margin-top:0.86em}.jl{margin-top:1.05em}.ko{margin-right:5px}.lp{display:inline-block}.nj{font-size:22px}.nk{line-height:28px}.nx{width:calc(100% + 32px)}.ny{margin-left:-16px}.nz{margin-right:-16px}.oq{padding-left:16px}.or{padding-right:16px}.os{flex-basis:25%}.ot{max-width:25%}.pk{font-size:16px}.pl{line-height:20px}.qg{min-width:70px}.qh{min-height:70px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 1079.98px)">.e{display:none}.gk{margin-left:30px}.ia{margin-left:auto}.ib{text-align:center}.kn{margin-right:5px}.lo{display:inline-block}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 903.98px)">.f{display:none}.gj{margin-left:30px}.km{margin-right:5px}.ln{display:inline-block}.pa{margin-right:16px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 727.98px)">.g{display:none}.al{height:56px}.am{display:flex}.as{display:block}.cm{margin-bottom:0px}.cn{height:110px}.en{margin-top:32px}.eo{flex-direction:column-reverse}.gh{margin-bottom:30px}.gi{margin-left:0px}.kl{margin-left:8px}.lm{display:inline-block}.lu{padding-top:0}.lx{margin-bottom:24px}.ly{align-items:center}.lz{width:102px}.ma{position:relative}.me{padding-left:0}.mk{margin-top:24px}.mz{padding-bottom:12px}.na{margin-top:16px}.oz{margin-right:16px}.pm{margin-left:16px}.pn{margin-right:0px}.qk{padding:28px 0 12px}.qx{flex-direction:column}.ra{padding:20px 0 28px}.rb{padding:20px 0}.rc{border-top:1px solid rgba(255, 255, 255, 0.54)}.rd{margin-top:0}.re{margin-bottom:16px}.rf{width:100%}.rg{flex-direction:row}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 551.98px)">.h{display:none}.ab{margin:0 24px}.do{font-size:34px}.dp{margin-top:0.56em}.dq{line-height:42px}.dr{letter-spacing:-0.016em}.em{margin-top:32px}.fd{margin-bottom:0px}.gf{margin-bottom:30px}.gg{margin-left:0px}.gu{font-size:18px}.gv{margin-top:1.56em}.gw{line-height:28px}.gx{letter-spacing:-0.003em}.hq{margin-top:40px}.if{font-size:22px}.ig{margin-top:1.2em}.ih{letter-spacing:0}.iy{margin-top:0.67em}.jh{margin-top:1.34em}.kk{margin-left:8px}.ll{display:inline-block}.nb{font-size:20px}.nc{line-height:24px}.nl{width:calc(100% + 24px)}.nm{margin-left:-12px}.nn{margin-right:-12px}.oa{padding-left:12px}.ob{padding-right:12px}.oc{flex-basis:100%}.od{max-width:100%}.oy{margin-right:16px}.pc{font-size:16px}.pd{line-height:20px}.py{min-width:48px}.pz{min-height:48px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (min-width: 904px) and (max-width: 1079.98px)">.i{display:none}.af{margin:0 64px}.ea{font-size:48px}.eb{margin-top:0.55em}.ec{line-height:60px}.ed{letter-spacing:-0.011em}.hg{font-size:21px}.hh{margin-top:2em}.hi{line-height:32px}.hj{letter-spacing:-0.003em}.ht{margin-top:56px}.ip{font-size:30px}.iq{margin-top:1.95em}.ir{line-height:36px}.is{letter-spacing:0}.jb{margin-top:0.86em}.jk{margin-top:1.05em}.nh{font-size:22px}.ni{line-height:28px}.nu{width:calc(100% + 32px)}.nv{margin-left:-16px}.nw{margin-right:-16px}.om{padding-left:16px}.on{padding-right:16px}.oo{flex-basis:25%}.op{max-width:25%}.pi{font-size:16px}.pj{line-height:20px}.qe{min-width:70px}.qf{min-height:70px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (min-width: 728px) and (max-width: 903.98px)">.j{display:none}.ae{margin:0 48px}.dw{font-size:48px}.dx{margin-top:0.55em}.dy{line-height:60px}.dz{letter-spacing:-0.011em}.hc{font-size:21px}.hd{margin-top:2em}.he{line-height:32px}.hf{letter-spacing:-0.003em}.hs{margin-top:56px}.il{font-size:30px}.im{margin-top:1.95em}.in{line-height:36px}.io{letter-spacing:0}.ja{margin-top:0.86em}.jj{margin-top:1.05em}.nf{font-size:22px}.ng{line-height:28px}.nr{width:calc(100% + 28px)}.ns{margin-left:-14px}.nt{margin-right:-14px}.oi{padding-left:14px}.oj{padding-right:14px}.ok{flex-basis:50%}.ol{max-width:50%}.pg{font-size:16px}.ph{line-height:20px}.qc{min-width:48px}.qd{min-height:48px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (min-width: 552px) and (max-width: 727.98px)">.k{display:none}.ac{margin:0 24px}.ds{font-size:34px}.dt{margin-top:0.56em}.du{line-height:42px}.dv{letter-spacing:-0.016em}.gy{font-size:18px}.gz{margin-top:1.56em}.ha{line-height:28px}.hb{letter-spacing:-0.003em}.hr{margin-top:40px}.ii{font-size:22px}.ij{margin-top:1.2em}.ik{letter-spacing:0}.iz{margin-top:0.67em}.ji{margin-top:1.34em}.nd{font-size:20px}.ne{line-height:24px}.no{width:calc(100% + 24px)}.np{margin-left:-12px}.nq{margin-right:-12px}.oe{padding-left:12px}.of{padding-right:12px}.og{flex-basis:100%}.oh{max-width:100%}.pe{font-size:16px}.pf{line-height:20px}.qa{min-width:48px}.qb{min-height:48px}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="print">.z{display:none}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="(orientation: landscape) and (max-width: 903.98px)">.fj{max-height:none}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="(prefers-reduced-motion: no-preference)">.jt{transition:opacity 200ms}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 1230px)">.ju{display:none}</style><style type="text/css" data-fela-rehydration="475" data-fela-type="RULE" media="all and (max-width: 1240px)">.jx{display:none}</style></head><body><div id="root"><div class="a b c"><div class="d e f g h i j k"></div><script>document.domain = document.domain;</script><div class="s"><nav class="s t u v w c x y z"><div><div class="s c"><div class="n p"><div class="ab ac ae af ag ah ai aj"><div class="ak n o al am"><div class="n o an x"><a href="https://medium.com/?source=post_page-----48ddbd0208f8--------------------------------" rel="noopener" aria-label="Homepage"><svg viewBox="0 0 1043.63 592.71" class="q ao"><g data-name="Layer 2"><g data-name="Layer 1"><path d="M588.67 296.36c0 163.67-131.78 296.35-294.33 296.35S0 460 0 296.36 131.78 0 294.34 0s294.33 132.69 294.33 296.36M911.56 296.36c0 154.06-65.89 279-147.17 279s-147.17-124.94-147.17-279 65.88-279 147.16-279 147.17 124.9 147.17 279M1043.63 296.36c0 138-23.17 249.94-51.76 249.94s-51.75-111.91-51.75-249.94 23.17-249.94 51.75-249.94 51.76 111.9 51.76 249.94"></path></g></g></svg></a></div><div class="s ap x"></div></div></div></div></div><div class="aq s ar as"><div class="n p"><div class="ab ac ae af ag ah ai aj"><div class="at au n o"><div class="av s ap"><a href="/james-reads-public-cloud-technology-blog?source=post_page-----48ddbd0208f8--------------------------------" rel="noopener"><div class="aw ax s"><img alt="James Read’s Code, Containers and Cloud blog" class="" src="https://miro.medium.com/max/86/1*6I6y2FWHSG2KcaAaaUoFaQ.png" width="43" height="36"/></div></a></div><div class="ay s az"><ul class="ba bb bc bd be n bf g bg bh bi"><li class="n o bj bk bl bm"><span class="bp b bq br bs bt bu"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/linux?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd ce cf cg ch ci" rel="noopener">Linux</a></span></li><li class="n o bj bk bl bm"><span class="bp b bq br bs bt bu"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/git?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd ce cf cg ch ci" rel="noopener">Git</a></span></li><li class="n o bj bk bl bm"><span class="bp b bq br bs bt bu"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/azure?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd ce cf cg ch ci" rel="noopener">Azure</a></span></li><li class="n o bj bk bl bm"><span class="bp b bq br bs bt bu"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/ansible?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd ce cf cg ch ci" rel="noopener">Ansible</a></span></li><span class="bj bn bo"></span><li class="n o bj bk bl bm"><span class="bp b bq br bs bt bu"><a href="http://jread.com/?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd ce cf cg ch ci" rel="noopener nofollow">jread.com</a></span></li></ul></div></div></div></div></div></div></nav><div class="cj ck cl s cm cn"></div><article><section class="co cp cq cr aj cs ct s"></section><span class="s"></span><div><div class="t v da db dc dd"></div><section class="de df dg dh di"><div class="n p"><div class="ab ac ae af ag dj ai aj"><div class=""><h1 id="ce52" class="dk dl dm dn b do dp dq dr ds dt du dv dw dx dy dz ea eb ec ed ee ef eg eh ei ej">How to properly archive a project</h1><div class="ek"><div class="n el em en eo"><div class="o n"><div><a href="https://james-read.medium.com/?source=post_page-----48ddbd0208f8--------------------------------" rel="noopener"><div class="ep eq er"><div class="es n et o p t eu ev ew ex ey dd"><svg width="57" height="57" viewBox="0 0 57 57"><path fill-rule="evenodd" clip-rule="evenodd" d="M28.5 1.2A27.45 27.45 0 0 0 4.06 15.82L3 15.27A28.65 28.65 0 0 1 28.5 0C39.64 0 49.29 6.2 54 15.27l-1.06.55A27.45 27.45 0 0 0 28.5 1.2zM4.06 41.18A27.45 27.45 0 0 0 28.5 55.8a27.45 27.45 0 0 0 24.44-14.62l1.06.55A28.65 28.65 0 0 1 28.5 57 28.65 28.65 0 0 1 3 41.73l1.06-.55z"></path></svg></div><img alt="James Read" class="s ez er eq" src="https://miro.medium.com/fit/c/96/96/1*r6dBWnhVsGMv2UAdynsNNw.jpeg" width="48" height="48"/></div></a></div><div class="fa aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="fc n o fd"><span class="bp b fb br au fe ff fg fh fi fj ej"><a href="https://james-read.medium.com/?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">James Read</a></span><div class="fa s ap h"><span><button class="bp b bq br fn fo fp fq fr fs ft cd fu fv fw fx fy fz ga ct gb gc">Follow</button></span></div></div></span></div></div><span class="bp b fb br gd"><span class="bp b fb br au fe ff fg fh fi fj gd"><div><a class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener" href="/james-reads-public-cloud-technology-blog/how-to-properly-archive-a-project-48ddbd0208f8?source=post_page-----48ddbd0208f8--------------------------------">Jul 8</a> <!-- -->·<!-- --> <!-- -->5<!-- --> min read</div></span></span></div></div><div class="n ge gf gg gh gi gj gk gl z"><div class="n o"><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on twitter"><svg width="29" height="29" class="gp"><path d="M22.05 7.54a4.47 4.47 0 0 0-3.3-1.46 4.53 4.53 0 0 0-4.53 4.53c0 .35.04.7.08 1.05A12.9 12.9 0 0 1 5 6.89a5.1 5.1 0 0 0-.65 2.26c.03 1.6.83 2.99 2.02 3.79a4.3 4.3 0 0 1-2.02-.57v.08a4.55 4.55 0 0 0 3.63 4.44c-.4.08-.8.13-1.21.16l-.81-.08a4.54 4.54 0 0 0 4.2 3.15 9.56 9.56 0 0 1-5.66 1.94l-1.05-.08c2 1.27 4.38 2.02 6.94 2.02 8.3 0 12.86-6.9 12.84-12.85.02-.24 0-.43 0-.65a8.68 8.68 0 0 0 2.26-2.34c-.82.38-1.7.62-2.6.72a4.37 4.37 0 0 0 1.95-2.51c-.84.53-1.81.9-2.83 1.13z"></path></svg></button></div><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on linkedin"><svg width="29" height="29" viewBox="0 0 29 29" fill="none" class="gp"><path d="M5 6.36C5 5.61 5.63 5 6.4 5h16.2c.77 0 1.4.61 1.4 1.36v16.28c0 .75-.63 1.36-1.4 1.36H6.4c-.77 0-1.4-.6-1.4-1.36V6.36z"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M10.76 20.9v-8.57H7.89v8.58h2.87zm-1.44-9.75c1 0 1.63-.65 1.63-1.48-.02-.84-.62-1.48-1.6-1.48-.99 0-1.63.64-1.63 1.48 0 .83.62 1.48 1.59 1.48h.01zM12.35 20.9h2.87v-4.79c0-.25.02-.5.1-.7.2-.5.67-1.04 1.46-1.04 1.04 0 1.46.8 1.46 1.95v4.59h2.87v-4.92c0-2.64-1.42-3.87-3.3-3.87-1.55 0-2.23.86-2.61 1.45h.02v-1.24h-2.87c.04.8 0 8.58 0 8.58z" fill="#fff"></path></svg></button></div><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on facebook"><svg width="29" height="29" class="gp"><path d="M23.2 5H5.8a.8.8 0 0 0-.8.8V23.2c0 .44.35.8.8.8h9.3v-7.13h-2.38V13.9h2.38v-2.38c0-2.45 1.55-3.66 3.74-3.66 1.05 0 1.95.08 2.2.11v2.57h-1.5c-1.2 0-1.48.57-1.48 1.4v1.96h2.97l-.6 2.97h-2.37l.05 7.12h5.1a.8.8 0 0 0 .79-.8V5.8a.8.8 0 0 0-.8-.79"></path></svg></button></div><div class="gq s"></div><div class="s an"></div></div></div></div></div></div><p id="3825" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">The TURTLES model.</p><figure class="hq hr hs ht hu hv cq cr paragraph-image"><div class="cq cr hp"><img alt="" class="aj hw hx" src="https://miro.medium.com/max/1100/1*iFBp8me_41MFPUno2q1tDA.jpeg" width="550" height="378" role="presentation"/></div><figcaption class="hy hz cs cq cr ia ib bp b fb br gd">This author found a picture of a flipped tortoise, but could not find a flipped turtle. This author does not condone flipping of turtles, nor tortoises. Image purchased and licensed from Masterfile.com.</figcaption></figure><p id="8328" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">How many times have you seen projects abandoned on GitHub, or internal Wikis, with no explanation, no “next steps”, no follow-up or notes? How many hundreds of hours were lost to that project, and what was learned?</p><p id="462d" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">This article proposes a model (“TURTLES”), or more simply, a checklist, of how to properly archive a project.</p><h1 id="0652" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Is now the right time to archive this project?</h1><ul class=""><li id="b908" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">T — Technologists: </strong>Do enough people contribute to maintaining this project? Developers, Architects, Security, Operations?</li><li id="9d4e" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">U — Users: </strong>Does this project have enough active users?</li><li id="e3ff" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">R — Requirements: </strong>Is this project still doing what we set out for it to do?</li><li id="dbaf" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">T — Technology: </strong>Are there any unsustainable technologies behind this project?</li><li id="9234" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">L — Learning: </strong>Is anything being learned by maintaining this project? (See my article <a class="bv jm" rel="noopener" href="/james-reads-public-cloud-technology-blog/odyssey-projects-47138a44acda">about Odyssey projects</a> — sometimes “just coding to learn” is enough of a reason to keep a project going).</li><li id="3fd5" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">E — Ecosystem: </strong>Is there an alternative to writing this project?</li><li id="57c3" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">S — Salvage:</strong> Can anything useful be salvaged from this project?</li></ul><p id="dd2a" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">Models are easier to remember when there is an acronym — hence, “TURTLES”. :-)</p><p id="3f57" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">The suggestions below assume that you <strong class="gt jg">document </strong>t<strong class="gt jg">he answers to these questions </strong>— in the project README, on your wiki, or somewhere else where it’s easily seen by all.</p><h1 id="b817" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive checklist —Technologists &amp; Users</h1><p id="459a" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho de ej">NB: I deliberately chose the word “technologist” because I wanted to include developers, architects, security, operations, and many other roles.</p><ul class=""><li id="cde8" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho jd je jf ej"><strong class="gt jg">Why did this project fail to keep developers interest?</strong> How would that be changed for next time? Did big parts of the code rely on just one developer who understood them?</li><li id="f5c4" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Why did this project fail to keep its users, and grow users?</strong></li><li id="430a" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What was the cost of maintaining this project?</strong> Could 5 full-time developers not keep up with it? Was it costing huge amounts of money to keep all the test servers running?</li><li id="8dad" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Who were the users of this project?</strong> Anyone significant (any references?), and how did this project attract users?</li><li id="f223" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">How could have the project grown, what stopped it? </strong>Did it need more marketing, or more budget, did it need to be shown more frequently at conferences?</li></ul><h1 id="eeec" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive checklist — Requirements</h1><ul class=""><li id="339f" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">Which of the original requirements were met?</strong> Make a list. Of those which were unmet, why is that?</li><li id="a685" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Did any scope creep happen? If so, why?</strong> Bad expectation / issue management? Bad initial scoping? Too little focus on the MVP?</li><li id="0a3d" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What future requirements were planned, that could not be met with this project? </strong>Did the project have to work on Azure, or AWS, and it was only compatible with VMware environments?</li></ul><h1 id="4620" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive checklist — Technology</h1><ul class=""><li id="ff18" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">What technical decisions about architecture are not sustainable? </strong>Is this project a monolith in the modern world of microservices? Is the architecture hard to scale horizontally?</li><li id="3160" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Would you choose a different language or core dependencies differently next time? </strong>Would you choose log4j for all logging instead of logback? Golang instead of Java — why?</li><li id="054f" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Are all the dependencies frozen? </strong>If we want to re-build this project 5-years, or 10 years from now, relying on “latest” or “3.x+” is probably a bad idea. Maybe adjust your package.json, pom.xml or similar to stick dependencies to the version that exists now.</li><li id="3560" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Are any of the technologies outdated or dead? </strong>Is this project using PHP and Smarty with HTML4, in a world of reactive, progressive web apps? Does it rely on jQuery, when native HTML5 will do?</li></ul><h1 id="b189" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive checklist — Learning</h1><p id="7219" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho de ej">Side note: I feel this is the <strong class="gt jg">absolutely most important thing</strong> about arching a project.</p><ul class=""><li id="541d" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho jd je jf ej"><strong class="gt jg">What was learned by the developers?</strong></li><li id="2b48" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What was learned by operations?</strong></li><li id="42e0" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What was learned by project managers?</strong></li><li id="bde7" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What was learned by the budget owners?</strong></li><li id="86be" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">What was learned from the line of business, or business owner?</strong></li></ul><p id="cff1" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">If you do anything from this article, document what was learned. Have a wash-up meeting, make sure people acknowledge the learning points, and have them to hand for the future.</p><h1 id="5594" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive checklist — Ecosystem</h1><ul class=""><li id="17ae" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">Did a different project or technology come along that was more successful than this project? </strong>That’s OK, but why did it “win”? Did it do the same thing at reduced cost, did it do 90% of what we wanted to do anyway?</li><li id="1417" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Was this project duplicating something else? </strong>Why are you leaving this project instead of that one? Are you joining forces?</li><li id="b93a" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Does a better Open-Source alternative exist? </strong>Great, but is that project 50% overlap, 100% overlap, or somewhere in-between? What assumptions have been made?</li></ul><h1 id="6c18" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Archive Checklist — Salvage</h1><ul class=""><li id="6524" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">Can any of the core parts of the code be moved into a smaller, reusable library? </strong>Even things like Utility classes, or extensions you built to a configmap reader, could be usable elsewhere.</li><li id="ca52" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Is it possible, or advisable, that this project be forked?</strong> It could be continued by a different team?</li><li id="fe36" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Was there a successful non-technical thing that is salvageable? </strong>For example, was there a good format for weekly reports, or project management used with this project?</li></ul><h1 id="c4ae" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Next steps — help future archaeologists</h1><ul class=""><li id="8b00" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho jd je jf ej"><strong class="gt jg">TELL PEOPLE IT’S BEEN ARCHIVED — and summarize why. </strong>Don’t just abandon the repository (basically the whole point of this article!). If you can include all the documented reasons publicly, great — but at least include a summary of why.</li><li id="91aa" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Place notices on your project public website. </strong>Explain this for non-technical users.</li><li id="ab94" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Place persistent notices in chat rooms and mailing lists. </strong>For example, in a chat channel, set the channel topic.</li><li id="fc83" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Link to any ongoing or follow-up work. </strong>If there was a project that is the successor to this project — tell people!</li><li id="e040" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Place warnings for those coming after you </strong>— does this project cause or create problems, does its design, or its approach have false, or poor assumptions now-a-days?</li><li id="2fb3" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Does this project have a readme, explaining what it does? </strong>Help the casual browser, or future you, understand what this project did.</li><li id="8703" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Does this project have instructions for developers</strong>? Explain what build tools, libraries, or infrastructure are needed to build the project.</li><li id="1b7a" class="gr gs dm gt b gu jh gw gx gy ji ha hb hc jj he hf hg jk hi hj hk jl hm hn ho jd je jf ej"><strong class="gt jg">Is the supported platform documented?</strong> Was it built only with Windows 98 support, or only compiles “properly” with the Borland C compiler?</li></ul><h1 id="424e" class="ic id dm bp ie if ig gw ih ii ij ha ik il im in io ip iq ir is it iu iv iw ix ej">Summary</h1><p id="4209" class="gr gs dm gt b gu iy gw gx gy iz ha hb hc ja he hf hg jb hi hj hk jc hm hn ho de ej">Don’t just leave that Git repository to rot. Archive the project using the checklist above to help yourself, help others, and help those that come after you.</p><p id="a159" class="gr gs dm gt b gu gv gw gx gy gz ha hb hc hd he hf hg hh hi hj hk hl hm hn ho de ej">I’ll be honest, I have rarely ever <strong class="gt jg">archived</strong> <strong class="gt jg">my projects properly</strong>, until now. I’m going to be using this going forward for myself, and I hope you will consider using the model to archive your projects properly too.</p></div></div></section></div></article><div class="jn dd jp jv aj jw u jt jx" data-test-id="post-sidebar"><div class="n p"><div class="ab ac ae af ag ah ai aj"><div class="jy n jz"><div class="dd"><div><div class="kb s"><a href="/james-reads-public-cloud-technology-blog?source=post_sidebar--------------------------post_sidebar-----------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener"><h2 class="bp ie ka br dl ej de">James Read’s Code, Containers and Cloud blog</h2></a><div class="kc kd s"><p class="bp b fb br au ke ff fg kf fi fj gd">Code inside containers that run on the cloud!</p></div><div class="gb" aria-hidden="false" aria-describedby="collectionFollowPopover" aria-labelledby="collectionFollowPopover"></div></div><div class="kg kh aj n o et ki"><div class="kj n"><div class="n o et"><div class="s ep kk kl km kn ko"><span><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener" href="/m/signin?actionUrl=https%3A%2F%2Fmedium.com%2F_%2Fvote%2Fjames-reads-public-cloud-technology-blog%2F48ddbd0208f8&amp;operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fjames-reads-public-cloud-technology-blog%2Fhow-to-properly-archive-a-project-48ddbd0208f8&amp;user=James%20Read&amp;userId=603db01e0829&amp;source=post_sidebar-----48ddbd0208f8---------------------clap_sidebar-----------"><div class="cc kp kq kr ks kt ku kv r kw kx"><svg width="29" height="29" aria-label="clap"><g fill-rule="evenodd"><path d="M13.74 1l.76 2.97.76-2.97zM16.82 4.78l1.84-2.56-1.43-.47zM10.38 2.22l1.84 2.56-.41-3.03zM22.38 22.62a5.11 5.11 0 0 1-3.16 1.61l.49-.45c2.88-2.89 3.45-5.98 1.69-9.21l-1.1-1.94-.96-2.02c-.31-.67-.23-1.18.25-1.55a.84.84 0 0 1 .66-.16c.34.05.66.28.88.6l2.85 5.02c1.18 1.97 1.38 5.12-1.6 8.1M9.1 22.1l-5.02-5.02a1 1 0 0 1 .7-1.7 1 1 0 0 1 .72.3l2.6 2.6a.44.44 0 0 0 .63-.62L6.1 15.04l-1.75-1.75a1 1 0 1 1 1.41-1.41l4.15 4.15a.44.44 0 0 0 .63 0 .44.44 0 0 0 0-.62L6.4 11.26l-1.18-1.18a1 1 0 0 1 0-1.4 1.02 1.02 0 0 1 1.41 0l1.18 1.16L11.96 14a.44.44 0 0 0 .62 0 .44.44 0 0 0 0-.63L8.43 9.22a.99.99 0 0 1-.3-.7.99.99 0 0 1 .3-.7 1 1 0 0 1 1.41 0l7 6.98a.44.44 0 0 0 .7-.5l-1.35-2.85c-.31-.68-.23-1.19.25-1.56a.85.85 0 0 1 .66-.16c.34.06.66.28.88.6L20.63 15c1.57 2.88 1.07 5.54-1.55 8.16a5.62 5.62 0 0 1-5.06 1.65 9.35 9.35 0 0 1-4.93-2.72zM13 6.98l2.56 2.56c-.5.6-.56 1.41-.15 2.28l.26.56-4.25-4.25a.98.98 0 0 1-.12-.45 1 1 0 0 1 .29-.7 1.02 1.02 0 0 1 1.41 0zm8.89 2.06c-.38-.56-.9-.92-1.49-1.01a1.74 1.74 0 0 0-1.34.33c-.38.29-.61.65-.71 1.06a2.1 2.1 0 0 0-1.1-.56 1.78 1.78 0 0 0-.99.13l-2.64-2.64a1.88 1.88 0 0 0-2.65 0 1.86 1.86 0 0 0-.48.85 1.89 1.89 0 0 0-2.67-.01 1.87 1.87 0 0 0-.5.9c-.76-.75-2-.75-2.7-.04a1.88 1.88 0 0 0 0 2.66c-.3.12-.61.29-.87.55a1.88 1.88 0 0 0 0 2.66l.62.62a1.88 1.88 0 0 0-.9 3.16l5.01 5.02c1.6 1.6 3.52 2.64 5.4 2.96a7.16 7.16 0 0 0 1.18.1c1.03 0 2-.25 2.9-.7A5.9 5.9 0 0 0 23 23.24c3.34-3.34 3.08-6.93 1.74-9.17l-2.87-5.04z"></path></g></svg></div></a></span></div></div></div><div class="ky kj s"><button class="ks kq cc"><div class="n o et"><div class="n o"><svg width="25" height="25" aria-label="responses" class="kz la ks kx"><path d="M19.07 21.12a6.33 6.33 0 0 1-3.53-1.1 7.8 7.8 0 0 1-.7-.52c-.77.21-1.57.32-2.38.32-4.67 0-8.46-3.5-8.46-7.8C4 7.7 7.79 4.2 12.46 4.2c4.66 0 8.46 3.5 8.46 7.8 0 2.06-.85 3.99-2.4 5.45a6.28 6.28 0 0 0 1.14 2.59c.15.21.17.48.06.7a.69.69 0 0 1-.62.38h-.03zm0-1v.5l.03-.5h-.03zm-3.92-1.64l.21.2a6.09 6.09 0 0 0 3.24 1.54 7.14 7.14 0 0 1-.83-1.84 5.15 5.15 0 0 1-.16-.75 2.4 2.4 0 0 1-.02-.29v-.23l.18-.15a6.6 6.6 0 0 0 2.3-4.96c0-3.82-3.4-6.93-7.6-6.93-4.19 0-7.6 3.11-7.6 6.93 0 3.83 3.41 6.94 7.6 6.94.83 0 1.64-.12 2.41-.35l.28-.08z" fill-rule="evenodd"></path></svg></div></div></button></div><div class="lb s"></div></div></div></div></div></div></div></div><div class="jn dd jo jp jq ex jr js jt ju"></div><div><div class="lc hv n jz p"><div class="n p"><div class="ab ac ae af ag dj ai aj"><div class="n ld"></div><div class="n o ld"></div><div class="le s"><ul class="cc bb"><li class="gb ba gq lf"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/programming" class="bp b bq lg gd lh li gc s lj">Programming</a></li><li class="gb ba gq lf"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/coding" class="bp b bq lg gd lh li gc s lj">Coding</a></li><li class="gb ba gq lf"><a href="https://medium.com/james-reads-public-cloud-technology-blog/tagged/project-management" class="bp b bq lg gd lh li gc s lj">Project Management</a></li></ul></div><div class="le n el z"><div class="n o et"><div class="lk s"><span class="s ll lm ln e d"><div class="n o et"><div class="s ep kk kl km kn ko"><span><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener" href="/m/signin?actionUrl=https%3A%2F%2Fmedium.com%2F_%2Fvote%2Fjames-reads-public-cloud-technology-blog%2F48ddbd0208f8&amp;operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fjames-reads-public-cloud-technology-blog%2Fhow-to-properly-archive-a-project-48ddbd0208f8&amp;user=James%20Read&amp;userId=603db01e0829&amp;source=post_actions_footer-----48ddbd0208f8---------------------clap_footer-----------"><div class="cc kp kq kr ks kt ku kv r kw kx"><svg width="25" height="25" viewBox="0 0 25 25" aria-label="clap"><g fill-rule="evenodd"><path d="M11.74 0l.76 2.97.76-2.97zM14.81 3.78l1.84-2.56-1.42-.47zM8.38 1.22l1.84 2.56L9.8.75zM20.38 21.62a5.11 5.11 0 0 1-3.16 1.61l.49-.45c2.88-2.89 3.45-5.98 1.69-9.21l-1.1-1.94-.96-2.02c-.31-.67-.23-1.18.25-1.55a.84.84 0 0 1 .66-.16c.34.05.66.28.88.6l2.85 5.02c1.18 1.97 1.38 5.12-1.6 8.1M7.1 21.1l-5.02-5.02a1 1 0 0 1 .7-1.7 1 1 0 0 1 .72.3l2.6 2.6a.44.44 0 0 0 .63-.62L4.1 14.04l-1.75-1.75a1 1 0 1 1 1.41-1.41l4.15 4.15a.44.44 0 0 0 .63 0 .44.44 0 0 0 0-.62L4.4 10.26 3.22 9.08a1 1 0 0 1 0-1.4 1.02 1.02 0 0 1 1.41 0l1.18 1.16L9.96 13a.44.44 0 0 0 .62 0 .44.44 0 0 0 0-.63L6.43 8.22a.99.99 0 0 1-.3-.7.99.99 0 0 1 .3-.7 1 1 0 0 1 1.41 0l7 6.98a.44.44 0 0 0 .7-.5l-1.35-2.85c-.31-.68-.23-1.19.25-1.56a.85.85 0 0 1 .66-.16c.34.06.66.28.88.6L18.63 14c1.57 2.88 1.07 5.54-1.55 8.16a5.62 5.62 0 0 1-5.06 1.65 9.35 9.35 0 0 1-4.93-2.72zM11 5.98l2.56 2.56c-.5.6-.56 1.41-.15 2.28l.26.56-4.25-4.25a.98.98 0 0 1-.12-.45 1 1 0 0 1 .29-.7 1.02 1.02 0 0 1 1.41 0zm8.89 2.06c-.38-.56-.9-.92-1.49-1.01a1.74 1.74 0 0 0-1.34.33c-.38.29-.61.65-.71 1.06a2.1 2.1 0 0 0-1.1-.56 1.78 1.78 0 0 0-.99.13l-2.64-2.64a1.88 1.88 0 0 0-2.65 0 1.86 1.86 0 0 0-.48.85 1.89 1.89 0 0 0-2.67-.01 1.87 1.87 0 0 0-.5.9c-.76-.75-2-.75-2.7-.04a1.88 1.88 0 0 0 0 2.66c-.3.12-.61.29-.87.55a1.88 1.88 0 0 0 0 2.66l.62.62a1.88 1.88 0 0 0-.9 3.16l5.01 5.02c1.6 1.6 3.52 2.64 5.4 2.96a7.16 7.16 0 0 0 1.18.1c1.03 0 2-.25 2.9-.7A5.9 5.9 0 0 0 21 22.24c3.34-3.34 3.08-6.93 1.74-9.17l-2.87-5.04z"></path></g></svg></div></a></span></div></div></span><span class="s h g f lo lp"><div class="n o et"><div class="s ep kk kl km kn ko"><span><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener" href="/m/signin?actionUrl=https%3A%2F%2Fmedium.com%2F_%2Fvote%2Fjames-reads-public-cloud-technology-blog%2F48ddbd0208f8&amp;operation=register&amp;redirect=https%3A%2F%2Fmedium.com%2Fjames-reads-public-cloud-technology-blog%2Fhow-to-properly-archive-a-project-48ddbd0208f8&amp;user=James%20Read&amp;userId=603db01e0829&amp;source=post_actions_footer-----48ddbd0208f8---------------------clap_footer-----------"><div class="cc kp kq kr ks kt ku kv r kw kx"><svg width="25" height="25" viewBox="0 0 25 25" aria-label="clap"><g fill-rule="evenodd"><path d="M11.74 0l.76 2.97.76-2.97zM14.81 3.78l1.84-2.56-1.42-.47zM8.38 1.22l1.84 2.56L9.8.75zM20.38 21.62a5.11 5.11 0 0 1-3.16 1.61l.49-.45c2.88-2.89 3.45-5.98 1.69-9.21l-1.1-1.94-.96-2.02c-.31-.67-.23-1.18.25-1.55a.84.84 0 0 1 .66-.16c.34.05.66.28.88.6l2.85 5.02c1.18 1.97 1.38 5.12-1.6 8.1M7.1 21.1l-5.02-5.02a1 1 0 0 1 .7-1.7 1 1 0 0 1 .72.3l2.6 2.6a.44.44 0 0 0 .63-.62L4.1 14.04l-1.75-1.75a1 1 0 1 1 1.41-1.41l4.15 4.15a.44.44 0 0 0 .63 0 .44.44 0 0 0 0-.62L4.4 10.26 3.22 9.08a1 1 0 0 1 0-1.4 1.02 1.02 0 0 1 1.41 0l1.18 1.16L9.96 13a.44.44 0 0 0 .62 0 .44.44 0 0 0 0-.63L6.43 8.22a.99.99 0 0 1-.3-.7.99.99 0 0 1 .3-.7 1 1 0 0 1 1.41 0l7 6.98a.44.44 0 0 0 .7-.5l-1.35-2.85c-.31-.68-.23-1.19.25-1.56a.85.85 0 0 1 .66-.16c.34.06.66.28.88.6L18.63 14c1.57 2.88 1.07 5.54-1.55 8.16a5.62 5.62 0 0 1-5.06 1.65 9.35 9.35 0 0 1-4.93-2.72zM11 5.98l2.56 2.56c-.5.6-.56 1.41-.15 2.28l.26.56-4.25-4.25a.98.98 0 0 1-.12-.45 1 1 0 0 1 .29-.7 1.02 1.02 0 0 1 1.41 0zm8.89 2.06c-.38-.56-.9-.92-1.49-1.01a1.74 1.74 0 0 0-1.34.33c-.38.29-.61.65-.71 1.06a2.1 2.1 0 0 0-1.1-.56 1.78 1.78 0 0 0-.99.13l-2.64-2.64a1.88 1.88 0 0 0-2.65 0 1.86 1.86 0 0 0-.48.85 1.89 1.89 0 0 0-2.67-.01 1.87 1.87 0 0 0-.5.9c-.76-.75-2-.75-2.7-.04a1.88 1.88 0 0 0 0 2.66c-.3.12-.61.29-.87.55a1.88 1.88 0 0 0 0 2.66l.62.62a1.88 1.88 0 0 0-.9 3.16l5.01 5.02c1.6 1.6 3.52 2.64 5.4 2.96a7.16 7.16 0 0 0 1.18.1c1.03 0 2-.25 2.9-.7A5.9 5.9 0 0 0 21 22.24c3.34-3.34 3.08-6.93 1.74-9.17l-2.87-5.04z"></path></g></svg></div></a></span></div></div></span></div><div class="lq s"><button class="ks kq cc"><div class="n o et"><div class="n o"><svg width="29" height="29" aria-label="responses" class="kz la ks kx lr"><path d="M21.27 20.06a9.04 9.04 0 0 0 2.75-6.68C24.02 8.21 19.67 4 14.1 4S4 8.21 4 13.38c0 5.18 4.53 9.39 10.1 9.39 1 0 2-.14 2.95-.41.28.25.6.49.92.7a7.46 7.46 0 0 0 4.19 1.3c.27 0 .5-.13.6-.35a.63.63 0 0 0-.05-.65 8.08 8.08 0 0 1-1.29-2.58 5.42 5.42 0 0 1-.15-.75zm-3.85 1.32l-.08-.28-.4.12a9.72 9.72 0 0 1-2.84.43c-4.96 0-9-3.71-9-8.27 0-4.55 4.04-8.26 9-8.26 4.95 0 8.77 3.71 8.77 8.27 0 2.25-.75 4.35-2.5 5.92l-.24.21v.32a5.59 5.59 0 0 0 .21 1.29c.19.7.49 1.4.89 2.08a6.43 6.43 0 0 1-2.67-1.06c-.34-.22-.88-.48-1.16-.74z"></path></svg></div></div></button></div></div><div class="n o"><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on twitter"><svg width="29" height="29" class="gp"><path d="M22.05 7.54a4.47 4.47 0 0 0-3.3-1.46 4.53 4.53 0 0 0-4.53 4.53c0 .35.04.7.08 1.05A12.9 12.9 0 0 1 5 6.89a5.1 5.1 0 0 0-.65 2.26c.03 1.6.83 2.99 2.02 3.79a4.3 4.3 0 0 1-2.02-.57v.08a4.55 4.55 0 0 0 3.63 4.44c-.4.08-.8.13-1.21.16l-.81-.08a4.54 4.54 0 0 0 4.2 3.15 9.56 9.56 0 0 1-5.66 1.94l-1.05-.08c2 1.27 4.38 2.02 6.94 2.02 8.3 0 12.86-6.9 12.84-12.85.02-.24 0-.43 0-.65a8.68 8.68 0 0 0 2.26-2.34c-.82.38-1.7.62-2.6.72a4.37 4.37 0 0 0 1.95-2.51c-.84.53-1.81.9-2.83 1.13z"></path></svg></button></div><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on linkedin"><svg width="29" height="29" viewBox="0 0 29 29" fill="none" class="gp"><path d="M5 6.36C5 5.61 5.63 5 6.4 5h16.2c.77 0 1.4.61 1.4 1.36v16.28c0 .75-.63 1.36-1.4 1.36H6.4c-.77 0-1.4-.6-1.4-1.36V6.36z"></path><path fill-rule="evenodd" clip-rule="evenodd" d="M10.76 20.9v-8.57H7.89v8.58h2.87zm-1.44-9.75c1 0 1.63-.65 1.63-1.48-.02-.84-.62-1.48-1.6-1.48-.99 0-1.63.64-1.63 1.48 0 .83.62 1.48 1.59 1.48h.01zM12.35 20.9h2.87v-4.79c0-.25.02-.5.1-.7.2-.5.67-1.04 1.46-1.04 1.04 0 1.46.8 1.46 1.95v4.59h2.87v-4.92c0-2.64-1.42-3.87-3.3-3.87-1.55 0-2.23.86-2.61 1.45h.02v-1.24h-2.87c.04.8 0 8.58 0 8.58z" fill="#fff"></path></svg></button></div><div class="gm s ap"><button class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" aria-label="Share on facebook"><svg width="29" height="29" class="gp"><path d="M23.2 5H5.8a.8.8 0 0 0-.8.8V23.2c0 .44.35.8.8.8h9.3v-7.13h-2.38V13.9h2.38v-2.38c0-2.45 1.55-3.66 3.74-3.66 1.05 0 1.95.08 2.2.11v2.57h-1.5c-1.2 0-1.48.57-1.48 1.4v1.96h2.97l-.6 2.97h-2.37l.05 7.12h5.1a.8.8 0 0 0 .79-.8V5.8a.8.8 0 0 0-.8-.79"></path></svg></button></div><div class="ls s ap"></div></div></div></div></div><div><div class="n p"><div class="ab ac ae af ag dj ai aj"><div class="kg kh lt le s lu z"><div class="s g"><div class="kg s"></div><div class="lv lw s ep"><span class="s lx am ly"><div class="s t lz ma"><a href="/james-reads-public-cloud-technology-blog?source=follow_footer-------------------------------------" rel="noopener"><img alt="James Read’s Code, Containers and Cloud blog" class="cw mb bi" src="https://miro.medium.com/fit/c/160/160/1*XqJbD2HsIml2OKBYUGtZ0g.png" width="80" height="80"/></a></div><span class="s"><div class="mc md n me"><div class="aj n o el"><h2 class="bp ie mf mg dl ej"><a href="/james-reads-public-cloud-technology-blog?source=follow_footer-------------------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener">James Read’s Code, Containers and Cloud blog</a></h2><div class="s g"><div class="gb" aria-hidden="false" aria-describedby="collectionFollowPopover" aria-labelledby="collectionFollowPopover"></div></div></div></div></span></span><div class="mc hp s me as"><div class="mh s"><p class="bp b ka mi gd">Code inside containers that run on the cloud!</p></div><div class="mj mk as"><div class="gb" aria-hidden="false" aria-describedby="collectionFollowPopover" aria-labelledby="collectionFollowPopover"></div></div></div></div></div><div class="mj as"><div class="ml s"><div class="n et"><div class="mm s"><a href="https://james-read.medium.com/?source=follow_footer-------------------------------------" rel="noopener"><div class="ep mn mo"><div class="es n et o p t eu ev ew ex ey dd"><svg width="49" height="49" viewBox="0 0 49 49"><path fill-rule="evenodd" clip-rule="evenodd" d="M24.5 1.1c-9.39 0-17.53 5.55-21.51 13.66L2 14.28C6.15 5.82 14.66 0 24.5 0S42.85 5.82 47 14.28l-.99.48C42.03 6.65 33.9 1.1 24.5 1.1zM2.99 34.24C6.97 42.35 15.1 47.9 24.5 47.9c9.39 0 17.53-5.55 21.51-13.66l.99.48C42.85 43.18 34.34 49 24.5 49S6.15 43.18 2 34.72l.99-.48z"></path></svg></div><img alt="James Read" class="s ez mo mn" src="https://miro.medium.com/fit/c/80/80/1*r6dBWnhVsGMv2UAdynsNNw.jpeg" width="40" height="40"/></div></a></div><div class="mp s"><p class="bp b mq mr ms gd bt">Written by</p><div class="n et"><h2 class="bp ie ka br dl ej"><a href="https://james-read.medium.com/?source=follow_footer-------------------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener">James Read</a></h2><div class="mp s"><span><button class="bp b bq br fn fo fp fq fr fs ft cd fu fv fw fx fy fz ga ct gb gc">Follow</button></span></div></div><div class="mt s"><p class="bp b fb br gd">Public Cloud and Open Source advocate. Red Hat Solution Architect during the day. Enthusiastic developer at night :) http://jread.com</p></div></div></div><div class="ml s"><div class="n et"><a href="/james-reads-public-cloud-technology-blog?source=follow_footer-------------------------------------" rel="noopener"><img alt="James Read’s Code, Containers and Cloud blog" class="cw mn mo" src="https://miro.medium.com/fit/c/80/80/1*XqJbD2HsIml2OKBYUGtZ0g.png" width="40" height="40"/></a><div class="mp s"><div class="n et"><h2 class="bp ie ka br dl ej"><a href="/james-reads-public-cloud-technology-blog?source=follow_footer-------------------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm" rel="noopener">James Read’s Code, Containers and Cloud blog</a></h2><div class="mp s"><div class="gb" aria-hidden="false" aria-describedby="collectionFollowPopover" aria-labelledby="collectionFollowPopover"></div></div></div><div class="mt s"><p class="bp b fb br gd">Code inside containers that run on the cloud!</p></div></div></div></div></div></div></div></div></div><div class="s cu z"><div class="n p"><div class="ab ac ae af ag ah ai aj"><div class="mu mv s"><div class="mw mx my mv s mz na"><h2 class="bp ie nb nc ih nd ne ik nf ng io nh ni is nj nk iw ej">More From Medium</h2></div><div class="bf n et ld nl nm nn no np nq nr ns nt nu nv nw nx ny nz"><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a rel="noopener" href="/waterstons-development/software-adoption-the-inertia-problem-48d254b7eb39?source=post_internal_links---------0----------------------------">Software Adoption: The Inertia Problem</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://grozzer.medium.com/?source=post_internal_links---------0----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Chris Grosberg</a><span> <!-- -->in<!-- --> <a href="/waterstons-development?source=post_internal_links---------0----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Waterstons Development</a></span></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener" href="/waterstons-development/software-adoption-the-inertia-problem-48d254b7eb39?source=post_internal_links---------0----------------------------"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/1*axj3IzLuzoFA-AxWXGNWSA.jpeg?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/1*axj3IzLuzoFA-AxWXGNWSA.jpeg" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/1*axj3IzLuzoFA-AxWXGNWSA.jpeg 48w, https://miro.medium.com/fit/c/140/140/1*axj3IzLuzoFA-AxWXGNWSA.jpeg 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a rel="noopener" href="/virta-health/building-software-to-scale-virta-48d608de7af8?source=post_internal_links---------1----------------------------">Building Software to Scale Virta</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener" href="/@fehguy?source=post_internal_links---------1----------------------------">Tony Tam</a><span> <!-- -->in<!-- --> <a href="/virta-health?source=post_internal_links---------1----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Virta Health</a></span></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener" href="/virta-health/building-software-to-scale-virta-48d608de7af8?source=post_internal_links---------1----------------------------"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/0*LuGgG07luaW9nRWO?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/0*LuGgG07luaW9nRWO" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/0*LuGgG07luaW9nRWO 48w, https://miro.medium.com/fit/c/140/140/0*LuGgG07luaW9nRWO 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a rel="noopener" href="/charot/deploy-arm-templates-using-azure-logic-apps-api-management-48d66ccd9ee4?source=post_internal_links---------2----------------------------">Deploy ARM Templates using Azure Logic Apps &amp; API Management</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://charotamine.medium.com/?source=post_internal_links---------2----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Amine Charot</a><span> <!-- -->in<!-- --> <a href="/charot?source=post_internal_links---------2----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Charot</a></span></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener" href="/charot/deploy-arm-templates-using-azure-logic-apps-api-management-48d66ccd9ee4?source=post_internal_links---------2----------------------------"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/1*2kYdgcRC9yn0Arr5vjAWeg.png?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/1*2kYdgcRC9yn0Arr5vjAWeg.png" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/1*2kYdgcRC9yn0Arr5vjAWeg.png 48w, https://miro.medium.com/fit/c/140/140/1*2kYdgcRC9yn0Arr5vjAWeg.png 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a href="https://alibaba-cloud.medium.com/how-to-install-bookstack-on-centos-7-48d7d98a919d?source=post_internal_links---------3----------------------------" rel="noopener">How to Install BookStack on CentOS 7</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://alibaba-cloud.medium.com/?source=post_internal_links---------3----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Alibaba Cloud</a></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a href="https://alibaba-cloud.medium.com/how-to-install-bookstack-on-centos-7-48d7d98a919d?source=post_internal_links---------3----------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/0*Lu-z3lD9LEb0A_HU.png?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/0*Lu-z3lD9LEb0A_HU.png" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/0*Lu-z3lD9LEb0A_HU.png 48w, https://miro.medium.com/fit/c/140/140/0*Lu-z3lD9LEb0A_HU.png 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a rel="noopener" href="/@SravanCynixit/best-etl-tools-in-2020-a-complete-updated-list-48da29e5b952?source=post_internal_links---------4----------------------------">Best ETL Tools In 2020 (A Complete Updated List)</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener" href="/@SravanCynixit?source=post_internal_links---------4----------------------------">Sravan Cynixit</a></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener" href="/@SravanCynixit/best-etl-tools-in-2020-a-complete-updated-list-48da29e5b952?source=post_internal_links---------4----------------------------"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/0*De7uu9446kbFrwRQ.jpg?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/0*De7uu9446kbFrwRQ.jpg" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/0*De7uu9446kbFrwRQ.jpg 48w, https://miro.medium.com/fit/c/140/140/0*De7uu9446kbFrwRQ.jpg 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a href="https://cloudmersive.medium.com/create-and-encrypt-a-zip-file-in-c-c-48dcf68f554a?source=post_internal_links---------5----------------------------" rel="noopener">Create and Encrypt a ZIP File in C/C++</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://cloudmersive.medium.com/?source=post_internal_links---------5----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Cloudmersive</a></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a href="https://cloudmersive.medium.com/create-and-encrypt-a-zip-file-in-c-c-48dcf68f554a?source=post_internal_links---------5----------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/1*XeakHRugVqodJWPSmPps_w.jpeg?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/1*XeakHRugVqodJWPSmPps_w.jpeg" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/1*XeakHRugVqodJWPSmPps_w.jpeg 48w, https://miro.medium.com/fit/c/140/140/1*XeakHRugVqodJWPSmPps_w.jpeg 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a href="https://erdemakkuzu.medium.com/java-8-date-time-api-48d242e745e6?source=post_internal_links---------6----------------------------" rel="noopener">Java 8 Date/Time API</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://erdemakkuzu.medium.com/?source=post_internal_links---------6----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Erdem Akkuzu</a></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a href="https://erdemakkuzu.medium.com/java-8-date-time-api-48d242e745e6?source=post_internal_links---------6----------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/1*Q9bgOEQuo3mt9e9rqgr49Q.jpeg?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/1*Q9bgOEQuo3mt9e9rqgr49Q.jpeg" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/1*Q9bgOEQuo3mt9e9rqgr49Q.jpeg 48w, https://miro.medium.com/fit/c/140/140/1*Q9bgOEQuo3mt9e9rqgr49Q.jpeg 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div><div class="oa ob oc od oe of og oh oi oj ok ol om on oo op oq or os ot ou"><div class="ov ow s"><div class="aj ox"><div class="n el"><div class="s az oy oz pa"><div class="pb s"><h2 class="bp ie pc pd ih pe pf ik pg ph io pi pj is pk pl iw ej"><a href="https://yigituyan.medium.com/part-6-setting-up-reverse-proxy-nginx-b1ee3c921c15?source=post_internal_links---------7----------------------------" rel="noopener">Part 6 - Setting Up Reverse Proxy (Nginx)</a></h2></div><div class="o n"><div></div><div class="aj s"><div class="n"><div style="flex:1"><span class="bp b fb br ej"><div class="cj n o fd"><span class="bp b bq br ej"><a href="https://yigituyan.medium.com/?source=post_internal_links---------7----------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg fl fm" rel="noopener">Yiğit (Yeet) Uyan</a></span></div></span></div></div></div></div></div><div class="mp gq s pm pn"><a href="https://yigituyan.medium.com/part-6-setting-up-reverse-proxy-nginx-b1ee3c921c15?source=post_internal_links---------7----------------------------" class="bv bw bx by bz ca cb cc bb cd gn go cg fl fm s" rel="noopener"><div class="pr s ep ps"><div class="pt pu s"><div class="jn po t u v ox aj au pp pq"><img class="t u v ox aj pv pw px" src="https://miro.medium.com/max/60/1*kKKFAxyROhBO3ahQ14GKqQ.png?q=20" width="70" height="70" role="presentation"/></div><img class="jn po py pz qa qb qc qd qe qf qg qh c" width="70" height="70" role="presentation"/><noscript><img class="py pz qa qb qc qd qe qf qg qh" src="https://miro.medium.com/fit/c/140/140/1*kKKFAxyROhBO3ahQ14GKqQ.png" width="70" height="70" srcSet="https://miro.medium.com/fit/c/96/140/1*kKKFAxyROhBO3ahQ14GKqQ.png 48w, https://miro.medium.com/fit/c/140/140/1*kKKFAxyROhBO3ahQ14GKqQ.png 70w" sizes="70px" role="presentation"/></noscript></div></div></a></div></div></div></div></div></div></div></div></div></div></div></div></div><div class="qi s qj qk"><div class="n p"><div class="ab ac ae af ag ah ai aj"><div class="ql qm lv n el g"><div class="qn n el"><div class="qo s qp"><div class="pb s"><a href="https://medium.com/about?autoplay=1&amp;source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener"><h2 class="bp ie qu mi dl qv">Learn more.</h2></a></div><p class="bp b fb br qw">Medium<!-- --> is an open platform where 170 million readers come to find insightful and dynamic thinking. Here, expert and undiscovered voices alike dive into the heart of any topic and bring new ideas to the surface.<!-- --> <a href="https://medium.com/about?autoplay=1&amp;source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd cg qs qt jm" rel="noopener">Learn more</a></p></div><div class="qo s qp"><div class="pb s"><a href="https://medium.com/topics?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener"><h2 class="bp ie qu mi dl qv">Make <!-- -->Medium<!-- --> yours.</h2></a></div><p class="bp b fb br qw">Follow the writers, publications, and topics that matter to you, and you’ll see them on your homepage and in your inbox.<!-- --> <a href="https://medium.com/topics?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd cg qs qt jm" rel="noopener">Explore</a></p></div><div class="qo s qp"><div class="pb s"><a href="https://medium.com/creator-tools?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener"><h2 class="bp ie qu mi dl qv">Write a story on <!-- -->Medium<!-- -->.</h2></a></div><p class="bp b fb br qw">If you have a story to tell, knowledge to share, or a perspective to offer — welcome home. It’s easy and free to post your thinking on any topic.<!-- --> <a href="https://medium.com/creator-tools?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd cg qs qt jm" rel="noopener">Start a blog</a></p></div></div></div><div class="n jz"><div class="n el qx"><a href="https://medium.com/?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener" aria-label="Go to homepage"><svg viewBox="0 0 3940 610" class="fp qy"><path d="M594.79 308.2c0 163.76-131.85 296.52-294.5 296.52S5.8 472 5.8 308.2 137.65 11.69 300.29 11.69s294.5 132.75 294.5 296.51M917.86 308.2c0 154.16-65.93 279.12-147.25 279.12s-147.25-125-147.25-279.12S689.29 29.08 770.61 29.08s147.25 125 147.25 279.12M1050 308.2c0 138.12-23.19 250.08-51.79 250.08s-51.79-112-51.79-250.08 23.19-250.08 51.8-250.08S1050 170.09 1050 308.2M1862.77 37.4l.82-.18v-6.35h-167.48l-155.51 365.5-155.51-365.5h-180.48v6.35l.81.18c30.57 6.9 46.09 17.19 46.09 54.3v434.45c0 37.11-15.58 47.4-46.15 54.3l-.81.18V587H1327v-6.35l-.81-.18c-30.57-6.9-46.09-17.19-46.09-54.3V116.9L1479.87 587h11.33l205.59-483.21V536.9c-2.62 29.31-18 38.36-45.68 44.61l-.82.19v6.3h213.3v-6.3l-.82-.19c-27.71-6.25-43.46-15.3-46.08-44.61l-.14-445.2h.14c0-37.11 15.52-47.4 46.08-54.3m97.43 287.8c3.49-78.06 31.52-134.4 78.56-135.37 14.51.24 26.68 5 36.14 14.16 20.1 19.51 29.55 60.28 28.09 121.21zm-2.11 22h250v-1.05c-.71-59.69-18-106.12-51.34-138-28.82-27.55-71.49-42.71-116.31-42.71h-1c-23.26 0-51.79 5.64-72.09 15.86-23.11 10.7-43.49 26.7-60.45 47.7-27.3 33.83-43.84 79.55-47.86 130.93-.13 1.54-.24 3.08-.35 4.62s-.18 2.92-.25 4.39a332.64 332.64 0 0 0-.36 21.69C1860.79 507 1923.65 600 2035.3 600c98 0 155.07-71.64 169.3-167.8l-7.19-2.53c-25 51.68-69.9 83-121 79.18-69.76-5.22-123.2-75.95-118.35-161.63m532.69 157.68c-8.2 19.45-25.31 30.15-48.24 30.15s-43.89-15.74-58.78-44.34c-16-30.7-24.42-74.1-24.42-125.51 0-107 33.28-176.21 84.79-176.21 21.57 0 38.55 10.7 46.65 29.37zm165.84 76.28c-30.57-7.23-46.09-18-46.09-57V5.28L2424.77 60v6.7l1.14-.09c25.62-2.07 43 1.47 53.09 10.79 7.9 7.3 11.75 18.5 11.75 34.26v71.14c-18.31-11.69-40.09-17.38-66.52-17.38-53.6 0-102.59 22.57-137.92 63.56-36.83 42.72-56.3 101.1-56.3 168.81C2230 518.72 2289.53 600 2378.13 600c51.83 0 93.53-28.4 112.62-76.3V588h166.65v-6.66zm159.29-505.33c0-37.76-28.47-66.24-66.24-66.24-37.59 0-67 29.1-67 66.24s29.44 66.24 67 66.24c37.77 0 66.24-28.48 66.24-66.24m43.84 505.33c-30.57-7.23-46.09-18-46.09-57h-.13V166.65l-166.66 47.85v6.5l1 .09c36.06 3.21 45.93 15.63 45.93 57.77V588h166.8v-6.66zm427.05 0c-30.57-7.23-46.09-18-46.09-57V166.65L3082 212.92v6.52l.94.1c29.48 3.1 38 16.23 38 58.56v226c-9.83 19.45-28.27 31-50.61 31.78-36.23 0-56.18-24.47-56.18-68.9V166.66l-166.66 47.85V221l1 .09c36.06 3.2 45.94 15.62 45.94 57.77v191.27a214.48 214.48 0 0 0 3.47 39.82l3 13.05c14.11 50.56 51.08 77 109 77 49.06 0 92.06-30.37 111-77.89v66h166.66v-6.66zM3934.2 588v-6.67l-.81-.19c-33.17-7.65-46.09-22.07-46.09-51.43v-243.2c0-75.83-42.59-121.09-113.93-121.09-52 0-95.85 30.05-112.73 76.86-13.41-49.6-52-76.86-109.06-76.86-50.12 0-89.4 26.45-106.25 71.13v-69.87l-166.66 45.89v6.54l1 .09c35.63 3.16 45.93 15.94 45.93 57V588h155.5v-6.66l-.82-.2c-26.46-6.22-35-17.56-35-46.66V255.72c7-16.35 21.11-35.72 49-35.72 34.64 0 52.2 24 52.2 71.28V588h155.54v-6.66l-.82-.2c-26.46-6.22-35-17.56-35-46.66v-248a160.45 160.45 0 0 0-2.2-27.68c7.42-17.77 22.34-38.8 51.37-38.8 35.13 0 52.2 23.31 52.2 71.28V588z"></path></svg></a><div class="mt qz n el ra"><p class="bp b ka mi qv"><a href="https://medium.com/about?autoplay=1&amp;source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg qs qt" rel="noopener">About</a></p><p class="bp b ka mi qv"><a href="https://medium.com/new-story?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg qs qt" rel="noopener">Write</a></p><p class="bp b ka mi qv"><a href="https://help.medium.com/hc/en-us?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg qs qt" rel="noopener">Help</a></p><p class="bp b ka mi qv"><a href="https://policy.medium.com/medium-terms-of-service-9db0094a1e0f?source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd fk cg qs qt" rel="noopener">Legal</a></p></div></div><div class="mj rb rc rd am"><p class="bp b ka mi qw">Get the Medium app</p></div><div class="mj re rf am rg"><div class="rh s"><a href="https://itunes.apple.com/app/medium-everyones-stories/id828256236?pt=698524&amp;mt=8&amp;ct=post_page&amp;source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener nofollow"><img alt="A button that says &#x27;Download on the App Store&#x27;, and if clicked it will lead you to the iOS App store" class="" src="https://miro.medium.com/max/270/1*Crl55Tm6yDNMoucPo1tvDg.png" width="135" height="41"/></a></div><div class="s"><a href="https://play.google.com/store/apps/details?id=com.medium.reader&amp;source=post_page-----48ddbd0208f8--------------------------------" class="bv bw bx by bz ca cb cc bb cd qq qr cg qs qt" rel="noopener nofollow"><img alt="A button that says &#x27;Get it on, Google Play&#x27;, and if clicked it will lead you to the Google Play store" class="" src="https://miro.medium.com/max/270/1*W_RAPQ62h0em559zluJLdQ.png" width="135" height="41"/></a></div></div></div></div></div></div></div></div></div><script>window.__BUILD_ID__ = "main-20210708-192449-a4aa9bb4f2"</script><script>window.__GRAPHQL_URI__ = "https://medium.com/_/graphql"</script><script>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</script><script>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</script><script>window.__MIDDLEWARE_STATE__={"session":{"xsrf":""},"cache":{"cacheStatus":"HIT"}}</script><script src="https://cdn-client.medium.com/lite/static/js/manifest.f8637a15.js"></script><script src="https://cdn-client.medium.com/lite/static/js/9115.c6381264.js"></script><script src="https://cdn-client.medium.com/lite/static/js/main.44b10c22.js"></script><script src="https://cdn-client.medium.com/lite/static/js/5573.159bf40f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/instrumentation.6fa29f8a.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/reporting.6471519f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8743.73be257b.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/2749.49330c48.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/4586.57274e03.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3257.d59f5406.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6753.3c8e7b29.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1356.951e99b8.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1575.8ddbcac2.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/8275.d083c36d.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7317.422c15ae.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1146.b9758a18.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3810.00772e9e.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7883.c7760f89.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/7526.e4160194.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3844.4fd87e5d.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/251.e5213de5.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1429.82f766ce.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/4902.1e8aef27.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/4697.6f1d7ac5.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1366.b6c8f73f.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/609.b8a77fb4.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/9972.2e7900a2.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3507.ae1ed59a.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6375.87205f81.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/6371.4450b1ce.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3664.ab8256b6.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/3874.87ccf9aa.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1794.352c336e.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/1860.281d8e43.chunk.js"></script>
<script src="https://cdn-client.medium.com/lite/static/js/Post.618d7d44.chunk.js"></script><script>window.main();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"66c815eaedb0059c","token":"0b5f665943484354a59c39c6833f7078","version":"2021.6.0","si":10}'></script>
</body></html>