Klaytn
Published in

Klaytn

Klaytn IDE Update

Klaytn IDE has been updated.

— Supports various Solidity versions (0.1.1 ~ 0.8.11).
— Supports various EVM versions (Homestead ~ Istanbul).With the current

EVM versions on Klaytn networks, some solidity features can be restricted.(Reference: https://docs.soliditylang.org/en/latest/using-the-compiler.html?highlight=evm#target-options)

- Cypress Mainnet (Constantinople EVM)
— Opcode chainid, selfbalance are not supported yet.
— block.basefee, basefee() are not supported yet.

- Baobab Testnet (Istanbul EVM)
— block.basefee, basefee() are not supported yet.The restricted features will be available after the Klaytn upgrade to London EVM.

Baobab network EVM will be upgraded at block number 80295291 (estimated for January 11th, 2022), and Cypress EVM will be upgraded in a few months.

--

--

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store