Lightroom Updated to 2015.7

A little rant

Adobe yesterday released a new update to Lightroom. This brings the release to 2015.7 for CC users or 6.7 for non creative cloud owners. Among the numerous bug fixes and new camera and lens support were a couple of new features. One in particular bears a bit of discussion. Apple has added the option to use Smart Previews instead of originals as a way to speed up Lightroom.

The idea for this came about from a sort of hack that has been well known for a while. Because smart previews are smaller basically a smaller resolution version of the normal RAW file, using hem will cause Lightroom to process a bit faster. Many Lightroom users discovered that if you put your files on an external drive, create smart previews of them and then disconnect the drive, it would force Lightroom to use the smart previews instead of the regular full resolution file. This would in turn cause Lightroom to operate more quickly.

In the latest version of the software, Adobe has added an option in the preferences to mimic this behaviour, without having to move files to an external drive. Basically, there is an option to always use Smart Previews. While I’m sure there are lots of people hailing this move as a great thing, and I know I’m going to get grief for saying this, but Im really surprised by this, and not in a good way.

This is basically proxy editing. This technique has been used for years for visual effects and video editing. You use a low resolution version so that you can work in real time, or faster than you otherwise could, and then you render out the full version at the end. In a lot of modern video software, the ability to work without having to use proxies is often touted as a performance milestone and a key feature. Adobe has now just done the opposite — and for stills! To me, this just highlights how bad the performance issues of Lightroom are that you would need to implement such a system to begin with.

I get that if you’re using large files from 50 and 100mp cameras that this will come as a much needed performance boost, but surely a piece of modern software should have proper caching techniques anyway, so that this kind of proxy editing shouldn’t be necessary. Performance on Lightroom has long been an issue for many people, and rather than tackle it properly, this to me is putting a bandaid on the problem and selling it as a feature. Look at the demos of On One’s upcoming raw software, and tell me that this doesn’t seem a bit ridiculous in comparison.

But even if you accept that this is a good idea, and I’m sure quite a few people will, then the implementation is not the best. You have to go into preferences to enable it, and it’s an all on or off situation. A far better option would have been some sort of toggle on the interface, like a switch in the develop module for example. Or alternatively use it when you’re zoomed out, but switch to full resolution when you zoom in. Make it invisible to the user, and use the technology as part of an internal caching / preview system. But for a piece of still editing software, in 2016 to need to use proxies to speed up performance is just ridiculous. In my opinion anyway.

I know I’m going to get a lot of hate mail for saying this. I’m sure there are lots of people out there who think that this is a great thing and I certainly don’t begrudge you your opinion. After all this is just my opinion. I appreciate that many users can benefit from the speed boost that this will bring, but I really do believe that this should not be necessary. I do like Lightroom, and the abilities it has, but in my opinion, Lightroom badly needs a ground up re-write. The code is old and slow compared to modern software and while this option provides some relief for people on slower systems, or with large files, to me this just highlights bigger problems with the application.

Send your hate mail to….

[UPDATE] Since installing the update, I’ve noticed some pretty serious, albeit specific performance issues. Editing Sony ARW files from the A7 on my main computer (Mac Pro) seems to have gotten a lot slower in this update. It’s borderline unusable. However editing Fuji files still seems ok. I need to do more checks to see if it’s something up with my configuration, however before the update it was fine and after the update….not so much. I’ve seen a few reports online about other people having issues too, but not a huge amount yet. It will take a few days to see if it’s a real thing or not. Hopefully it’s something I’m doing wrong. I need export the project to my laptop and check just to be sure. If anyone else has noticed any problems — please let me know (either here or in the comments on the original article — see link below)


Originally published at blog.thomasfitzgeraldphotography.com.