EIGRP Default Route

Anggara
Network Warrior
Published in
5 min readApr 15, 2017

This simple lab is about default route in EIGRP.

Scenario :

13.13.13.13/32 and 23.23.23.23/32 are not advertised into EIGRP and they should be reachable through default route.

Redistribute Static

Configuration on R1 :

R1(config)#interface e0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shut
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shut
R1(config)#router eigrp 10
R1(config-router)#network 10.10.10.1 0.0.0.0
R1(config-router)#network 1.1.1.1 0.0.0.0
R1(config-router)#no auto-summary

Configuration on R2 :

R2(config)#interface e0/1
R2(config-if)#ip address 20.20.20.1 255.255.255.252
R2(config-if)#no shut
R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut
R2(config)#router eigrp 10
R2(config-router)#network 10.10.10.2 0.0.0.0
R2(config-router)#network 20.20.20.1 0.0.0.0
R2(config-router)#network 2.2.2.2 0.0.0.0
R2(config-router)#no auto-summary

Configuration on R3 :

R3(config)#interface e0/0
R3(config-if)#ip address 20.20.20.2 255.255.255.252
R3(config-if)#no shut
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no shut
R3(config)#interface loopback 1
R3(config-if)#ip address 13.13.13.13 255.255.255.255
R3(config-if)#no shut
R3(config)#interface loopback 2
R3(config-if)#ip address 23.23.23.23 255.255.255.255
R3(config-if)#no shut
R3(config)#router eigrp 10
R3(config-router)#network 20.20.20.2 0.0.0.0
R3(config-router)#network 3.3.3.3 0.0.0.0
R3(config-router)#no auto-summary

Now verify from R1 and R2 :

R2#sh ip route eigrp
— output omitted —
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 10.10.10.1, 00:08:36, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 20.20.20.2, 00:06:22, Ethernet0/1
R1#sh ip route eigrp
— output omitted —
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.10.10.2, 00:09:28, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/435200] via 10.10.10.2, 00:07:14, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
D 20.20.20.0 [90/307200] via 10.10.10.2, 00:09:28, Ethernet0/0
R2#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R2#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R1#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R1#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)

From the result 13.13.13.13/32 and 23.23.23.23/32 aren’t exist in the routing tables of R1 and R2, at least we need a default route here.

OK, now add static route on R2 and redistribute it into EIGRP :

R2(config)#ip route 0.0.0.0 0.0.0.0 20.20.20.2
R2(config)#router eigrp 10
R2(config-router)#redistribute static

Let’s verify from R2 and R1 once again :

R2#sh ip route
— output omitted —
Gateway of last resort is 20.20.20.2 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 20.20.20.2
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 10.10.10.1, 00:17:54, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
— output omitted —
R2#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
R2#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/13 ms
R1#sh ip route eigrp
— output omitted —
Gateway of last resort is 10.10.10.2 to network 0.0.0.0D*EX 0.0.0.0/0 [170/307200] via 10.10.10.2, 00:04:05, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.10.10.2, 00:19:15, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/435200] via 10.10.10.2, 00:17:01, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
D 20.20.20.0 [90/307200] via 10.10.10.2, 00:19:15, Ethernet0/0
R1#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/3/9 ms
R1#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/6/15 ms

From the result, we can see that R1 and R2 can ping to 13.13.13.13/32 and 23.23.23.23/32 successfully. R2 has a static default route with IP next-hop 20.20.20.2/30, also R1 has default route that advertised by EIGRP.

IP Summary Address

Besides Redistribute Static method, we also can use IP Summary Address to configure the default route.

Firstly, remove static default route and redistribution static that has configured on R2.

R2(config)#no ip route 0.0.0.0 0.0.0.0 20.20.20.2
R2(config)#router eigrp 10
R2(config-router)#no redistribute static

Back to original configuration, R1 & R2 can’t reach 13.13.13.13/32 and 23.23.23.23/32.

R2#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R2#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R1#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)
R1#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
…..
Success rate is 0 percent (0/5)

Let’s move to R3 and add this configuration :

R3(config)#interface e0/0
R3(config-if)#ip summary-address eigrp 10 0.0.0.0 0.0.0.0

Now back to R1 and R2 for verification :

R1#sh ip route eigrp
–output omitted–
Gateway of last resort is 10.10.10.2 to network 0.0.0.0D* 0.0.0.0/0 [90/435200] via 10.10.10.2, 00:07:47, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 10.10.10.2, 00:27:53, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
D 20.20.20.0 [90/307200] via 10.10.10.2, 00:22:51, Ethernet0/0
R2#sh ip route eigrp
–output omitted–
Gateway of last resort is 20.20.20.2 to network 0.0.0.0D* 0.0.0.0/0 [90/409600] via 20.20.20.2, 00:08:07, Ethernet0/1
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 10.10.10.1, 00:28:18, Ethernet0/0
R1#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/6/14 ms
R1#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/17 ms
R2#ping 13.13.13.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.13, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/5/15 ms
R2#ping 23.23.23.23
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.23, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/6/15 ms

From the result, we can see the default route that advertised by EIGRP on routing tables of R1 and R2, and they can reach 13.13.13.13/32 and 23.23.23.23/32 now.

Please hit the ♥ button if you liked this article. You will help others find it. Thank you.

--

--

Network Warrior
Network Warrior

Published in Network Warrior

IP Networking, Routing, Switching, Operating Systems, and more…

Anggara
Anggara

Written by Anggara

An ordinary person who has extraordinary life | a traveler | a seeker