RIP Default Route with Default-Information Originate

Anggara
Network Warrior
Published in
3 min readApr 14, 2017

Lab Scenario :

IP 3.3.3.3/32 , 4.4.4.4/32 , 5.5.5.5/32 on R3 will not advertised through RIP. R1 and R2 will reach them through default route.

Configuration on R1 :

R1(config)#interface e0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shut
R1(config)#interface e0/1
R1(config-if)#ip address 30.30.30.1 255.255.255.252
R1(config-if)#no shut
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shut
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 0.0.0.0
R1(config-router)#no auto-summary

Configuration on R2 :

R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut
R2(config)#interface e0/1
R2(config-if)#ip address 20.20.20.1 255.255.255.252
R2(config-if)#no shut
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 0.0.0.0
R2(config-router)#no auto-summary

Configuration on R3 :

R3(config)#interface e0/0
R3(config-if)#ip address 20.20.20.2 255.255.255.252
R3(config-if)#no shut
R3(config)#interface e0/1
R3(config-if)#ip address 30.30.30.2 255.255.255.252
R3(config-if)#no shut
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 20.20.20.0
R3(config-router)#network 30.30.30.0
R3(config-router)#no auto-summary
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no shut
R3(config)#interface loopback 1
R3(config-if)#ip address 4.4.4.4 255.255.255.255
R3(config-if)#no shut
R3(config)#interface loopback 2
R3(config-if)#ip address 5.5.5.5 255.255.255.255
R3(config-if)#no shut

OK, now verify from R1 and R2 :

R1#sh ip route rip
— output omitted —
Gateway of last resort is not set2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.10.10.2, 00:00:15, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
R 20.20.20.0 [120/1] via 30.30.30.2, 00:00:17, Ethernet0/1
[120/1] via 10.10.10.2, 00:00:15, Ethernet0/0
R2#sh ip route rip
— output omitted —
Gateway of last resort is not set1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.10.10.1, 00:00:06, Ethernet0/0
30.0.0.0/30 is subnetted, 1 subnets
R 30.30.30.0 [120/1] via 20.20.20.2, 00:00:12, Ethernet0/1
[120/1] via 10.10.10.1, 00:00:06, Ethernet0/0

R1 and R2 can’t reach 3.3.3.3/32 , 4.4.4.4/32 , and 5.5.5.5/32 . Because they are not advertised by R3.

Based on scenario we will inject the default route into R1 and R2, so they can reach 3.3.3.3/32, 4.4.4.4/32, and 5.5.5.5/32.

Let’s add configuration on R3 :

R3(config)#router rip
R3(config-router)#default-information originate

OK done, let’s verify again from R1 and R2 :

R1#sh ip route rip
— output omitted —
Gateway of last resort is 30.30.30.2 to network 0.0.0.0R* 0.0.0.0/0 [120/1] via 30.30.30.2, 00:00:13, Ethernet0/1
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.10.10.2, 00:00:10, Ethernet0/0
20.0.0.0/30 is subnetted, 1 subnets
R 20.20.20.0 [120/1] via 30.30.30.2, 00:00:13, Ethernet0/1
[120/1] via 10.10.10.2, 00:00:10, Ethernet0/0
R2#sh ip route rip
— output omitted —
Gateway of last resort is 20.20.20.2 to network 0.0.0.0
R* 0.0.0.0/0 [120/1] via 20.20.20.2, 00:00:10, Ethernet0/1
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.10.10.1, 00:00:03, Ethernet0/0
30.0.0.0/30 is subnetted, 1 subnets
R 30.30.30.0 [120/1] via 20.20.20.2, 00:00:10, Ethernet0/1
[120/1] via 10.10.10.1, 00:00:03, Ethernet0/0

Well, R1 and R2 have default route in routing table now. Let’s do ping test to 3.3.3.3/32, 4.4.4.4/32, and 5.5.5.5/32.

Well done, R1 and R2 now can reach 3.3.3.3/32, 4.4.4.4/32, and 5.5.5.5/32.

Please hit the ♥ button if you liked this post. You will help others find it. Thanks!

--

--

Anggara
Network Warrior

An ordinary person who has extraordinary life | a traveler | a seeker