Seu Biblivre 5 não funciona mais depois de uma atualização do Java? Aqui está a solução.

O Biblivre 5, sobre o qual escrevo há algum tempo, normalmente é instalado por meio do instalador oficial baixado do site, devido à facilidade que ele oferece para instalar as dependências e ferramentas do sistema e deixar tudo rodando (meus posts sobre Biblivre 5 normalmente lidam com a tarefa não tão trivial de implantar o Biblivre 5 em outros sistemas como Linux ou macOS).

Recentemente, com o novo bug do Temer, além do uso do tzupdater, surgiu a sugestão de se atualizar a versão do Java para remediar o problema. Foi aí que eu vi que a instalação padrão do Biblivre 5 no Windows não é exatamente simpática a atualizações do Java.

Assim que eu reiniciei o sistema após atualizar o Java para a última versão (no momento que escrevo esta postagem, 1.8.0_191), o Biblivre 5 parou de funcionar. Não por culpa dele, mas porque o Tomcat, onde o Biblivre 5 é implantado, simplesmente não conseguiu iniciar automaticamente junto com o sistema. Bang!

Isto é o que você no Windows vê quando o Tomcat pára de funcionar.

Isso acontece porque o Tomcat está configurado por padrão para usar o Java que é instalado pelo instalador do Biblivre 5, que fica em uma pasta diferente do Java mais atual. Assim, a configuração padrão do Tomcat vai atrás do Java numa pasta que não existe mais após a atualização.

Felizmente, tudo o que você precisa fazer é atualizar a configuração do Java para o serviço do Tomcat, conforme mostrado no vídeo abaixo.

Depois disso seu Tomcat vai estar funcionando e o Biblivre 5 também.