RIP Default Route with Redistribute Static

Anggara
Network Warrior
Published in
2 min readApr 15, 2017

Same with previous post about RIP Default Route with Default-Information Originate, but now we will use static default route that redistributed into RIP to inject the default route.

Assumed R2 is connected to internet through interface null0.

Configuration on R1 :

R1(config)#interface e0/0
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shut
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shut
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#net
R1(config-router)#network 0.0.0.0
R1(config-router)#no auto-summary

Configuration on R2 :

R2(config)#interface e0/0
R2(config-if)#ip address 10.10.10.2 255.255.255.252
R2(config-if)#no shut
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shut
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 0.0.0.0
R2(config-router)#no auto-summary

Now checking from R1 :

R1#sh ip route rip
— output omitted —
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.10.10.2, 00:00:14, Ethernet0/0

R1 can see 2.2.2.2/32, but R1 stil can’t reach internet or other network behind R2, since the default route still not exist.

Let’s add configuration on R2 :

R2(config)#ip route 0.0.0.0 0.0.0.0 null0
R2(config)#router rip
R2(config-router)#redistribute static

All we do is add static default route through interface null0 and redistribute it into RIP.

Now let’s verify again from R1 :

R1#sh ip route rip
— output omitted —
Gateway of last resort is 10.10.10.2 to network 0.0.0.0R* 0.0.0.0/0 [120/1] via 10.10.10.2, 00:00:17, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 10.10.10.2, 00:00:17, Ethernet0/0

Well done, R1 has default route now with next hop 10.10.10.2 (R2).

What about R2 ? Let’s check :

R2#sh ip route
— output omitted —
Gateway of last resort is 0.0.0.0 to network 0.0.0.0S* 0.0.0.0/0 is directly connected, Null0
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.10.10.1, 00:00:26, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/30 is directly connected, Ethernet0/0
L 10.10.10.2/32 is directly connected, Ethernet0/0

R2 has a static default route through interface null0 now.

Please hit the ♥ button if you liked this post. You’ll help others find it. Thanks!

--

--

Anggara
Network Warrior

An ordinary person who has extraordinary life | a traveler | a seeker